aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--multimedia/aom/Makefile4
-rw-r--r--multimedia/aom/distinfo6
-rw-r--r--multimedia/aom/files/patch-aom_src_aom__encoder.c22
-rw-r--r--multimedia/ffmpeg/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-aom/Makefile2
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox/Makefile2
9 files changed, 33 insertions, 10 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index ed29d9b25049..3c4138bdd2f5 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,7 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 68.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/multimedia/aom/Makefile b/multimedia/aom/Makefile
index b5b7a24b0204..521825639f22 100644
--- a/multimedia/aom/Makefile
+++ b/multimedia/aom/Makefile
@@ -2,8 +2,8 @@
PORTNAME= aom
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0.0-2499
-DISTVERSIONSUFFIX= -gce7d07ee6
+DISTVERSION= 1.0.0-2541
+DISTVERSIONSUFFIX= -g7e56b507f
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
diff --git a/multimedia/aom/distinfo b/multimedia/aom/distinfo
index d9ff18018865..c2ea4ede84f5 100644
--- a/multimedia/aom/distinfo
+++ b/multimedia/aom/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570838721
-SHA256 (jbeich-aom-v1.0.0-2499-gce7d07ee6_GH0.tar.gz) = 4ce5eabd7f2051d7cfdf315d658f32f1cd5dfcdeae841643c3bba74a6e0d6bb8
-SIZE (jbeich-aom-v1.0.0-2499-gce7d07ee6_GH0.tar.gz) = 3433022
+TIMESTAMP = 1571512649
+SHA256 (jbeich-aom-v1.0.0-2541-g7e56b507f_GH0.tar.gz) = f77abe4613341c7ff30eca6934cab23a87b2e3846e5d7646ef383ef50a77d0d4
+SIZE (jbeich-aom-v1.0.0-2541-g7e56b507f_GH0.tar.gz) = 3438521
diff --git a/multimedia/aom/files/patch-aom_src_aom__encoder.c b/multimedia/aom/files/patch-aom_src_aom__encoder.c
new file mode 100644
index 000000000000..2067455cf7cc
--- /dev/null
+++ b/multimedia/aom/files/patch-aom_src_aom__encoder.c
@@ -0,0 +1,22 @@
+/usr/bin/ld.bfd: /usr/local/lib/libaom.so: undefined reference to `init_config'
+
+--- aom/src/aom_encoder.c.orig 2019-10-19 19:17:29 UTC
++++ aom/src/aom_encoder.c
+@@ -27,7 +27,16 @@
+ #include "aom/aom_encoder.h"
+ #include "aom/internal/aom_codec_internal.h"
+
+-extern void init_config(cfg_options_t *pConfig);
++#if CONFIG_FILEOPTIONS
++// Copied from common/args.c
++extern __attribute__((weak)) void init_config(cfg_options_t *pConfig) {
++ memset(pConfig, 0, sizeof(cfg_options_t));
++ pConfig->super_block_size = 0; // Dynamic
++ pConfig->max_partition_size = 128;
++ pConfig->min_partition_size = 4;
++ pConfig->disable_trellis_quant = 3;
++}
++#endif
+
+ #define SAVE_STATUS(ctx, var) (ctx ? (ctx->err = var) : var)
+
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 335f773a14ad..acd6c6b1e904 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 4.2.1
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= multimedia audio net
MASTER_SITES= https://ffmpeg.org/releases/
diff --git a/multimedia/gstreamer1-plugins-aom/Makefile b/multimedia/gstreamer1-plugins-aom/Makefile
index 12256d4a503b..0d822fdf338e 100644
--- a/multimedia/gstreamer1-plugins-aom/Makefile
+++ b/multimedia/gstreamer1-plugins-aom/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
COMMENT= GStreamer (libaom) plugin
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 5c0274a6f00b..f1c7cd3bc121 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 3.0.8
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 4
CATEGORIES= multimedia audio net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 14d51d08a280..092fa389fb21 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= firefox
DISTVERSION= 68.2.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 0a030133ed9d..fe810181644c 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 70.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \