aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/lilypond-devel/Makefile41
-rw-r--r--print/lilypond-devel/distinfo6
-rw-r--r--print/lilypond-devel/files/patch-Documentation_GNUmakefile4
-rw-r--r--print/lilypond-devel/files/patch-config.make.in4
-rw-r--r--print/lilypond-devel/files/patch-configure78
-rw-r--r--print/lilypond-devel/files/patch-flower_include_std-string.hh4
-rw-r--r--print/lilypond-devel/files/patch-flower_include_std-vector.hh4
-rw-r--r--print/lilypond-devel/files/patch-lily_include_lily-guile.hh8
-rw-r--r--print/lilypond-devel/files/patch-python_GNUmakefile4
-rw-r--r--print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make6
-rw-r--r--print/lilypond-devel/pkg-descr4
-rw-r--r--print/lilypond-devel/pkg-plist1
12 files changed, 88 insertions, 76 deletions
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 01fbf7ea1295..b150e3baeda9 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lilypond
-DISTVERSION= 2.19.83
-PORTREVISION= 1
+DISTVERSION= 2.20.0
CATEGORIES= print audio
MASTER_SITES= http://lilypond.org/download/source/v${DISTVERSION:R}/
PKGNAMESUFFIX= -devel
@@ -27,35 +26,20 @@ BUILD_DEPENDS= pdftexi2dvi:print/texinfo \
rsync:net/rsync \
texi2html:textproc/texi2html \
zip:archivers/zip
-RUN_DEPENDS= mftrace:print/mftrace \
- ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
LIB_DEPENDS= libltdl.so:devel/libltdl \
- libguile.so:lang/guile \
+ libguile.so:lang/guile1 \
libgmp.so:math/gmp \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-
-INFO= internals \
- lilypond-changes \
- lilypond-contributor \
- lilypond-essay \
- lilypond-extending \
- lilypond-internals \
- lilypond-learning \
- lilypond-notation \
- lilypond-snippets \
- lilypond-usage \
- lilypond-web \
- music-glossary
+RUN_DEPENDS= mftrace:print/mftrace \
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
USES= bison:build compiler:gcc-c++11-lib gettext ghostscript gmake \
gnome perl5 pkgconfig python:2.7
USE_CXXSTD= c++11
-USE_TEX= latex texmf
-USE_PERL5= build
USE_GNOME= pango
-
-MAKEFILE= GNUmakefile
+USE_PERL5= build
+USE_TEX= latex texmf
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-texgyre-dir=${LOCALBASE}/${TEXMFDISTDIR}/fonts/opentype/public/tex-gyre \
@@ -63,8 +47,21 @@ CONFIGURE_ARGS+=--with-texgyre-dir=${LOCALBASE}/${TEXMFDISTDIR}/fonts/opentype/p
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} YACC=${YACC} HOME=${WRKDIR}
+MAKEFILE= GNUmakefile
ALL_TARGET= all
+INFO= internals \
+ lilypond-changes \
+ lilypond-contributor \
+ lilypond-essay \
+ lilypond-extending \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-snippets \
+ lilypond-usage \
+ lilypond-web \
+ music-glossary
PLIST_SUB= DISTVERSION=${DISTVERSION}
OPTIONS_DEFINE= NLS
diff --git a/print/lilypond-devel/distinfo b/print/lilypond-devel/distinfo
index b5427a48f3cd..33be34a32e53 100644
--- a/print/lilypond-devel/distinfo
+++ b/print/lilypond-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1554060216
-SHA256 (lilypond-2.19.83.tar.gz) = 96ba4f4b342d21057ad74d85d647aea7e47a5c24f895127c2b3553a252738fb3
-SIZE (lilypond-2.19.83.tar.gz) = 17996428
+TIMESTAMP = 1587345646
+SHA256 (lilypond-2.20.0.tar.gz) = 595901323fbc88d3039ca4bdbc2d8c5ce46b182edcb3ea9c0940eba849bba661
+SIZE (lilypond-2.20.0.tar.gz) = 18100533
diff --git a/print/lilypond-devel/files/patch-Documentation_GNUmakefile b/print/lilypond-devel/files/patch-Documentation_GNUmakefile
index 2cd8552613d2..8aff0ea6823e 100644
--- a/print/lilypond-devel/files/patch-Documentation_GNUmakefile
+++ b/print/lilypond-devel/files/patch-Documentation_GNUmakefile
@@ -1,6 +1,6 @@
---- Documentation/GNUmakefile.orig 2017-02-26 12:08:59 UTC
+--- Documentation/GNUmakefile.orig 2020-02-04 16:12:57 UTC
+++ Documentation/GNUmakefile
-@@ -73,9 +73,9 @@ source-links = $(outdir)/source\
+@@ -74,9 +74,9 @@ source-links = $(outdir)/source\
MAIN_INFO_DOC = lilypond-web
INFO_DOCS = lilypond-usage lilypond-changes lilypond-contributor lilypond-internals \
lilypond-essay lilypond-learning lilypond-notation music-glossary \
diff --git a/print/lilypond-devel/files/patch-config.make.in b/print/lilypond-devel/files/patch-config.make.in
index 833c329decb7..ac94b09983f3 100644
--- a/print/lilypond-devel/files/patch-config.make.in
+++ b/print/lilypond-devel/files/patch-config.make.in
@@ -1,6 +1,6 @@
---- config.make.in.orig 2017-02-26 12:08:59 UTC
+--- config.make.in.orig 2020-02-04 16:12:57 UTC
+++ config.make.in
-@@ -69,7 +69,7 @@ sharedstatedir = @sharedstatedir@
+@@ -73,7 +73,7 @@ sharedstatedir = @sharedstatedir@
stepmake = @stepmake@
package_datadir = $(datadir)/$(package)
diff --git a/print/lilypond-devel/files/patch-configure b/print/lilypond-devel/files/patch-configure
index 48afff01b139..c4bb616f37fc 100644
--- a/print/lilypond-devel/files/patch-configure
+++ b/print/lilypond-devel/files/patch-configure
@@ -1,24 +1,24 @@
---- configure.orig 2019-03-20 13:52:23 UTC
+--- configure.orig 2020-03-01 14:00:51 UTC
+++ configure
-@@ -10512,13 +10512,8 @@ $as_echo_n "checking $r version... " >&6; }
+@@ -2298,13 +2298,8 @@ $as_echo_n "checking $r version... " >&6; }
## for compatibility reasons.
- ## grab the first version number in --version output.
+ ## grab the first version number in --version output.
- eval _ver=\"\`("$exe" --version || "$exe" -V) 2>&1 |
-- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
-- head -n 1 |
-- tr ' ' '\n' |
-- sed 's/\([0-9][0-9]*\.[0-9][0-9.]*\).*/\1/g' |
-- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
-- head -n 1\`\"
+- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
+- head -n 1 |
+- tr ' ' '\n' |
+- sed 's/\([0-9][0-9]*\.[0-9][0-9.]*\).*/\1/g' |
+- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
+- head -n 1\`\"
+ eval _ver=\"\`("$exe" --version || "$exe" -V) 2>/dev/null |
-+ awk '$1 ~ "fontforge" { print $2 }'\`\"
++ awk '$1 ~ "fontforge" { print $2 }'\`\"
if test -z "$_ver"; then
## If empty, try date [fontforge]
-@@ -11595,75 +11590,10 @@ test -n "$PKG_CONFIG" || PKG_CONFIG="no"
-
- if test $? -eq 0 -a -n "0.9.0"; then
+@@ -11631,71 +11626,10 @@ test -n "$PKG_CONFIG" || PKG_CONFIG="no"
+ if test $? -eq 0; then
+ if test -n "0.9.0" -o -n ""; then
- r="`eval echo '$'"PKG_CONFIG"`"
- { $as_echo "$as_me:$LINENO: checking $r version" >&5
@@ -31,10 +31,7 @@
- ## this test should work in ash, bash, pdksh (ksh), zsh
- type -p $r 2>/dev/null | tail -n 1 | awk '{print $NF}'
-`
-- if test -n ""; then
-- ver=""
-- else
-- ver=`
+- ver=`
- ## "$exe" --version 2>&1 | grep -v '^$' | head -n 1 | awk '{print $NF}'
- ##
- ## ARG.
@@ -50,26 +47,25 @@
- ## use eval trickery, because we cannot use multi-level $() instead of ``
- ## for compatibility reasons.
-
-- ## grab the first version number in --version output.
+- ## grab the first version number in --version output.
- eval _ver=\"\`("$exe" --version || "$exe" -V) 2>&1 |
-- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
-- head -n 1 |
-- tr ' ' '\n' |
-- sed 's/\([0-9][0-9]*\.[0-9][0-9.]*\).*/\1/g' |
-- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
-- head -n 1\`\"
+- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
+- head -n 1 |
+- tr ' ' '\n' |
+- sed 's/\([0-9][0-9]*\.[0-9][0-9.]*\).*/\1/g' |
+- grep -E '(^| )[0-9][0-9]*\.[0-9]' |
+- head -n 1\`\"
-
- if test -z "$_ver"; then
- ## If empty, try date [fontforge]
- eval _ver=\"\`("$exe" --version || "$exe" -V) 2>&1 \
-- | grep '\(^\|[^0-9a-f]\)[0-9]\{6,8\}\([^0-9a-f]\|$\)' \
-- | head -n 1 \
-- | sed -e 's/^[^.0-9]*//' -e 's/[^.0-9]*$//'\`\"
+- | grep '\(^\|[^0-9a-f]\)[0-9]\{6,8\}\([^0-9a-f]\|$\)' \
+- | head -n 1 \
+- | sed -e 's/^[^.0-9]*//' -e 's/[^.0-9]*$//'\`\"
- fi
- echo "$_ver"
- #dnl
-`
-- fi
- num=`
- echo "$ver" | awk -F. '
- {
@@ -78,7 +74,7 @@
- }
- {printf "%.0f\n", $1*1000000 + $2*1000 + three}'
-`
-- req=`
+- min=`
- echo "0.9.0" | awk -F. '
- {
- if ($3) {three = $3}
@@ -88,10 +84,32 @@
-`
- { $as_echo "$as_me:$LINENO: result: $ver" >&5
-$as_echo "$ver" >&6; }
-- if test "$num" -lt "$req"; then
+- if test "$num" -lt "$min"; then
-
+ if test ! $?; then
+ ver=`$PKG_CONFIG --version`
eval "REQUIRED"=\"`eval echo \"'$'REQUIRED\" \""$r >= 0.9.0 (installed: $ver)"\"`\"
fi
+@@ -15001,21 +14935,6 @@ $as_echo "$ver" >&6; }
+
+ eval "$DOCUMENTATION_REQUIRED"=\"`eval echo \"'$'$DOCUMENTATION_REQUIRED\" \""$r >= 1.82 (installed: $ver)"\"`\"
+
+- fi
+- if test -n "1.82"; then
+- max=`
+- echo "1.82" | awk -F. '
+- {
+- if ($3) {three = $3}
+- else {three = 0}
+- }
+- {printf "%.0f\n", $1*1000000 + $2*1000 + three}'
+-`
+- if test "$num" -gt "$max"; then
+-
+- eval "$DOCUMENTATION_REQUIRED"=\"`eval echo \"'$'$DOCUMENTATION_REQUIRED\" \""$r <= 1.82 (installed: $ver)"\"`\"
+-
+- fi
+ fi
+ vervar="`echo TEXI2HTML | tr 'a-z' 'A-Z'`_VERSION"
+ eval `echo $vervar=$num`
diff --git a/print/lilypond-devel/files/patch-flower_include_std-string.hh b/print/lilypond-devel/files/patch-flower_include_std-string.hh
index 4a1bc78d35f5..404ca9e46503 100644
--- a/print/lilypond-devel/files/patch-flower_include_std-string.hh
+++ b/print/lilypond-devel/files/patch-flower_include_std-string.hh
@@ -1,11 +1,11 @@
---- flower/include/std-string.hh.orig 2017-02-26 12:08:59 UTC
+--- flower/include/std-string.hh.orig 2020-03-01 14:00:51 UTC
+++ flower/include/std-string.hh
@@ -38,6 +38,7 @@ using namespace std;
typedef size_t ssize;
#define NPOS string::npos
+#if _cplusplus <= 19971L
- string to_string (const string&);
+ string to_string (const string &);
string to_string (char c, int n = 1);
string to_string (int i, char const *format = 0);
@@ -49,6 +50,7 @@ string to_string (unsigned);
diff --git a/print/lilypond-devel/files/patch-flower_include_std-vector.hh b/print/lilypond-devel/files/patch-flower_include_std-vector.hh
index 6b5a18f75fb9..d743167e94ce 100644
--- a/print/lilypond-devel/files/patch-flower_include_std-vector.hh
+++ b/print/lilypond-devel/files/patch-flower_include_std-vector.hh
@@ -1,6 +1,6 @@
---- flower/include/std-vector.hh.orig 2017-02-26 12:08:59 UTC
+--- flower/include/std-vector.hh.orig 2020-02-04 16:12:57 UTC
+++ flower/include/std-vector.hh
-@@ -212,6 +212,6 @@ junk_pointers (vector<T> &v)
+@@ -224,6 +224,6 @@ junk_pointers (vector<T> &v)
vector<string> string_split (string str, char c);
string string_join (vector<string> const &strs, const string &infix);
diff --git a/print/lilypond-devel/files/patch-lily_include_lily-guile.hh b/print/lilypond-devel/files/patch-lily_include_lily-guile.hh
index 513ea0ff2b13..5215ad1c4a0b 100644
--- a/print/lilypond-devel/files/patch-lily_include_lily-guile.hh
+++ b/print/lilypond-devel/files/patch-lily_include_lily-guile.hh
@@ -1,8 +1,8 @@
---- lily/include/lily-guile.hh.orig 2017-02-26 12:08:59 UTC
+--- lily/include/lily-guile.hh.orig 2020-02-04 16:12:57 UTC
+++ lily/include/lily-guile.hh
-@@ -20,6 +20,8 @@
- #ifndef LILY_GUILE_HH
- #define LILY_GUILE_HH
+@@ -22,6 +22,8 @@
+
+ #include "config.hh"
+#include <cstddef>
+
diff --git a/print/lilypond-devel/files/patch-python_GNUmakefile b/print/lilypond-devel/files/patch-python_GNUmakefile
index d3da0c816a28..2ae4deb553bb 100644
--- a/print/lilypond-devel/files/patch-python_GNUmakefile
+++ b/print/lilypond-devel/files/patch-python_GNUmakefile
@@ -1,6 +1,6 @@
---- python/GNUmakefile.orig 2017-02-26 12:08:59 UTC
+--- python/GNUmakefile.orig 2020-02-04 16:12:57 UTC
+++ python/GNUmakefile
-@@ -14,7 +14,6 @@ CONFIG_LDFLAGS=
+@@ -12,7 +12,6 @@ CONFIG_LDFLAGS=
INSTALLATION_OUT_SUFFIXES=1
INSTALLATION_OUT_FILES=$(OUT_SO_MODULES)
diff --git a/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make b/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make
index 291221eddce0..1b92bca728de 100644
--- a/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make
+++ b/print/lilypond-devel/files/patch-stepmake_stepmake_texinfo-vars.make
@@ -1,11 +1,11 @@
---- stepmake/stepmake/texinfo-vars.make.orig 2017-02-26 12:08:59 UTC
+--- stepmake/stepmake/texinfo-vars.make.orig 2020-03-01 14:00:51 UTC
+++ stepmake/stepmake/texinfo-vars.make
-@@ -31,7 +31,7 @@ DO_TEXI_DEP = ( echo ./$@: $(call scan-t
+@@ -31,7 +31,7 @@ DO_TEXI_DEP = ( echo ./$@: $(call scan-texi,$<) > $(ba
TEXINFO_PAPERSIZE_OPTION= $(if $(findstring $(PAPERSIZE),a4),,-t @afourpaper)
-MAKEINFO_FLAGS += --enable-encoding --error-limit=0 $(DOCUMENTATION_INCLUDES)
+MAKEINFO_FLAGS += --enable-encoding --force $(DOCUMENTATION_INCLUDES)
- MAKEINFO = LANG= $(MAKEINFO_PROGRAM) $(MAKEINFO_FLAGS)
+ MAKEINFO = LANG=C $(MAKEINFO_PROGRAM) $(MAKEINFO_FLAGS)
# texi2html xref map files
diff --git a/print/lilypond-devel/pkg-descr b/print/lilypond-devel/pkg-descr
index 0e1a17dd5380..d4312d6ae528 100644
--- a/print/lilypond-devel/pkg-descr
+++ b/print/lilypond-devel/pkg-descr
@@ -7,6 +7,4 @@ can write MIDI files, and there is a MIDI to lilypond conversion
tool, midi2ly. Conversion tools for PMX, MUP, ABC, Finale and
Musedata are also included.
-WWW: http://lilypond.org/
-
-Patrick Atamaniuk
+WWW: https://lilypond.org/
diff --git a/print/lilypond-devel/pkg-plist b/print/lilypond-devel/pkg-plist
index 4ef9a35cdd53..28e78d1b002e 100644
--- a/print/lilypond-devel/pkg-plist
+++ b/print/lilypond-devel/pkg-plist
@@ -277,7 +277,6 @@ share/emacs/site-lisp/lilypond-words.el
%%DATADIR%%/%%DISTVERSION%%/scm/chord-ignatzek-names.scm
%%DATADIR%%/%%DISTVERSION%%/scm/chord-name.scm
%%DATADIR%%/%%DISTVERSION%%/scm/clip-region.scm
-%%DATADIR%%/%%DISTVERSION%%/scm/coverage.scm
%%DATADIR%%/%%DISTVERSION%%/scm/define-context-properties.scm
%%DATADIR%%/%%DISTVERSION%%/scm/define-event-classes.scm
%%DATADIR%%/%%DISTVERSION%%/scm/define-grob-interfaces.scm