aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Layout-Manager/Makefile34
-rw-r--r--graphics/p5-Layout-Manager/distinfo3
-rw-r--r--graphics/p5-Layout-Manager/pkg-descr4
-rw-r--r--graphics/p5-Layout-Manager/pkg-plist11
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0005b5abad5a..1f116d44b1d5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -544,6 +544,7 @@
SUBDIR += p5-Imager-Plot
SUBDIR += p5-Imager-QRCode
SUBDIR += p5-Imlib2
+ SUBDIR += p5-Layout-Manager
SUBDIR += p5-OpenGL
SUBDIR += p5-SVG-DOM2
SUBDIR += p5-SVG-Graph
diff --git a/graphics/p5-Layout-Manager/Makefile b/graphics/p5-Layout-Manager/Makefile
new file mode 100644
index 000000000000..90f54a4a8838
--- /dev/null
+++ b/graphics/p5-Layout-Manager/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: Layout-Manager
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Layout-Manager
+PORTVERSION= 0.16
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/G/GP/GPHAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= 2D Layout Management
+
+BUILD_DEPENDS= p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-AttributeHelpers>=0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-Module-Install>=0.64:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Geometry-Primitive>=0:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+ p5-Graphics-Primitive>=0:${PORTSDIR}/graphics/p5-Graphics-Primitive
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Layout::Manager.3 \
+ Layout::Manager::Absolute.3 \
+ Layout::Manager::Axis.3 \
+ Layout::Manager::Compass.3 \
+ Layout::Manager::Flow.3 \
+ Layout::Manager::Single.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Layout-Manager/distinfo b/graphics/p5-Layout-Manager/distinfo
new file mode 100644
index 000000000000..0d4243c7577d
--- /dev/null
+++ b/graphics/p5-Layout-Manager/distinfo
@@ -0,0 +1,3 @@
+MD5 (Layout-Manager-0.16.tar.gz) = f702042551fd12f9f1542e8a16dc52a9
+SHA256 (Layout-Manager-0.16.tar.gz) = 14fa5b52ff20bdf60bcc5321b4e62752ca0e013ada720519970e7f1bbce7ac7a
+SIZE (Layout-Manager-0.16.tar.gz) = 30786
diff --git a/graphics/p5-Layout-Manager/pkg-descr b/graphics/p5-Layout-Manager/pkg-descr
new file mode 100644
index 000000000000..7f77121d89bb
--- /dev/null
+++ b/graphics/p5-Layout-Manager/pkg-descr
@@ -0,0 +1,4 @@
+Layout::Manager provides a simple interface for creating layout managers, or
+classes that size and position components withing a container.
+
+WWW: http://search.cpan.org/dist/Layout-Manager/
diff --git a/graphics/p5-Layout-Manager/pkg-plist b/graphics/p5-Layout-Manager/pkg-plist
new file mode 100644
index 000000000000..4e250b3f1d46
--- /dev/null
+++ b/graphics/p5-Layout-Manager/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Layout/Manager/.packlist
+%%SITE_PERL%%/Layout/Manager.pm
+%%SITE_PERL%%/Layout/Manager/Absolute.pm
+%%SITE_PERL%%/Layout/Manager/Axis.pm
+%%SITE_PERL%%/Layout/Manager/Compass.pm
+%%SITE_PERL%%/Layout/Manager/Flow.pm
+%%SITE_PERL%%/Layout/Manager/Single.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Layout/Manager
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Layout
+@dirrmtry %%SITE_PERL%%/Layout/Manager
+@dirrmtry %%SITE_PERL%%/Layout