aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/mars_nwe/Makefile33
-rw-r--r--net/mars_nwe/distinfo2
-rw-r--r--net/mars_nwe/files/nwserv.sh11
-rw-r--r--net/mars_nwe/files/patch-aa9
-rw-r--r--net/mars_nwe/pkg-message2
-rw-r--r--net/mars_nwe/pkg-plist1
-rw-r--r--net/mars_nwe/pkg-plist.DOC25
7 files changed, 68 insertions, 15 deletions
diff --git a/net/mars_nwe/Makefile b/net/mars_nwe/Makefile
index 4783e24f92de..67c4045222e7 100644
--- a/net/mars_nwe/Makefile
+++ b/net/mars_nwe/Makefile
@@ -6,31 +6,46 @@
#
PORTNAME= mars_nwe
-PORTVERSION= 0.99.b17
+PORTVERSION= 0.99.b18
CATEGORIES= net
MASTER_SITES= http://www.compu-art.de/download/ \
ftp://ftp.gwdg.de/pub/linux/misc/ncpfs/mars_nwe/ \
ftp://ftp.butya.kz/pub/mars_nwe/
-DISTNAME= mars_nwe-0.99.pl17
+DISTNAME= mars_nwe-0.99.pl18
EXTRACT_SUFX= .tgz
MAINTAINER= bp@FreeBSD.org
WRKSRC= ${WRKDIR}/mars_nwe
+PLIST= ${WRKDIR}/PLIST.DYN
+
+NDOCDIR= ${PREFIX}/share/doc/mars_nwe
+
do-build:
@(cd ${WRKSRC} && ${MAKE} all)
do-install:
@(cd ${WRKSRC} && ./mk.li install)
@${INSTALL_DATA} ${WRKSRC}/examples/nw.ini ${PREFIX}/etc/nwserv.conf.example
- @${ECHO} "You'll need to create a startup file to load MARS_NWE Server when booting."
- @${ECHO} "Create a nwserv.sh in ${PREFIX}/etc/rc.d directory and modify"
- @${ECHO} "${PREFIX}/etc/nwserv.conf manually before you loading server."
- @${ECHO} "Kernel should be compiled with IPX support and IPXrouted should be"
- @${ECHO} "started before server."
- @${ECHO} ""
@${ECHO} "Please read details in ${WORKDIR}/mars_nwe/doc directory."
- @${ECHO} "Especially README.FREEBSD file."
+
+pre-install:
+ @cp ${PKGDIR}/PLIST ${WRKDIR}/PLIST.DYN
+.if !defined(NOPORSDOCS)
+ @cat ${PKGDIR}/PLIST.DOC >> ${WRKDIR}/PLIST.DYN
+.endif
+
+post-install:
+ @${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" \
+ ${FILESDIR}/nwserv.sh \
+ >${PREFIX}/etc/rc.d/nwserv.sh
+ @${CHMOD} 0755 ${PREFIX}/etc/rc.d/nwserv.sh
+.if !defined(NOPORTDOCS)
+ @if ! [ -d ${NDOCDIR} ]; then ${MKDIR} ${NDOCDIR}; fi
+ ${RM} -f ${WRKSRC}/doc/*.orig
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${NDOCDIR}
+.endif
+ @${ECHO_MSG} "Look in ${NDOCDIR} for documentation."
.include <bsd.port.mk>
diff --git a/net/mars_nwe/distinfo b/net/mars_nwe/distinfo
index 98f2e72ae874..e57ccc5c04c0 100644
--- a/net/mars_nwe/distinfo
+++ b/net/mars_nwe/distinfo
@@ -1 +1 @@
-MD5 (mars_nwe-0.99.pl17.tgz) = e9dd321df6cec84ee79aec5635219051
+MD5 (mars_nwe-0.99.pl18.tgz) = d114f51c3b92e79765820fbe737a278c
diff --git a/net/mars_nwe/files/nwserv.sh b/net/mars_nwe/files/nwserv.sh
new file mode 100644
index 000000000000..67a7a4bf9b84
--- /dev/null
+++ b/net/mars_nwe/files/nwserv.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+PREFIX=/usr/local
+
+PROG=${PREFIX}/sbin/nwserv
+
+if [ x$1 = xstart ]; then
+ (sleep 120;${PROG}) &
+elif [ "x$1" = "xstop" ]; then
+ ${PROG} -k
+fi
diff --git a/net/mars_nwe/files/patch-aa b/net/mars_nwe/files/patch-aa
index 7831a907157a..876a0d68d65f 100644
--- a/net/mars_nwe/files/patch-aa
+++ b/net/mars_nwe/files/patch-aa
@@ -4,8 +4,8 @@ RCS file: /usr/local/cvsrp/mars/doc/README.FREEBSD,v
retrieving revision 1.1.1.3
retrieving revision 1.5
diff -u -r1.1.1.3 -r1.5
---- README.FREEBSD 1999/06/04 09:38:04 1.1.1.3
-+++ README.FREEBSD 1999/06/04 09:42:09 1.5
+--- doc/README.FREEBSD 1999/06/04 09:38:04 1.1.1.3
++++ doc/README.FREEBSD 1999/06/04 09:42:09 1.5
@@ -44,7 +44,6 @@
with switch '-s'. Please use only patched version of IPXrouted if you
are run 2.2.8 or 3.x of FreeBSD.
@@ -20,8 +20,8 @@ RCS file: /usr/local/cvsrp/mars/examples/config.h,v
retrieving revision 1.1.1.1
retrieving revision 1.2
diff -u -r1.1.1.1 -r1.2
---- config.h 1999/01/28 06:21:38 1.1.1.1
-+++ config.h 1999/01/28 06:23:09 1.2
+--- examples/config.h 1999/01/28 06:21:38 1.1.1.1
++++ examples/config.h 1999/01/28 06:23:09 1.2
@@ -11,9 +11,9 @@
# define PATHNAME_PROGS "." /* where to find the executables */
# define PATHNAME_BINDERY "." /* directory for bindery-files */
@@ -33,3 +33,4 @@ diff -u -r1.1.1.1 -r1.2
+# define PATHNAME_PROGS "/usr/local/sbin" /* where to find the executables */
# define PATHNAME_BINDERY "/var/nwserv/db" /* directory for bindery-files */
#endif
+
diff --git a/net/mars_nwe/pkg-message b/net/mars_nwe/pkg-message
index 13e4e0e00eb5..1721f5e6e81c 100644
--- a/net/mars_nwe/pkg-message
+++ b/net/mars_nwe/pkg-message
@@ -1 +1 @@
-After building look into work/mars_nwe/doc directory.
+After building look into share/doc/mars_nwe directory.
diff --git a/net/mars_nwe/pkg-plist b/net/mars_nwe/pkg-plist
index 8a1585d99c16..0981ca10a11c 100644
--- a/net/mars_nwe/pkg-plist
+++ b/net/mars_nwe/pkg-plist
@@ -1,4 +1,5 @@
etc/nwserv.conf.example
+etc/rc.d/nwserv.sh
sbin/nwserv
sbin/ncpserv
sbin/nwbind
diff --git a/net/mars_nwe/pkg-plist.DOC b/net/mars_nwe/pkg-plist.DOC
new file mode 100644
index 000000000000..1a54398534f4
--- /dev/null
+++ b/net/mars_nwe/pkg-plist.DOC
@@ -0,0 +1,25 @@
+share/doc/mars_nwe/BUGS
+share/doc/mars_nwe/BUGS.nl
+share/doc/mars_nwe/CHANGES
+share/doc/mars_nwe/CREDITS
+share/doc/mars_nwe/FAQS
+share/doc/mars_nwe/FILESHARING
+share/doc/mars_nwe/FRAGEN
+share/doc/mars_nwe/FRAGEN.erik
+share/doc/mars_nwe/HOWTO.ger
+share/doc/mars_nwe/INSTALL
+share/doc/mars_nwe/INSTALL.ger
+share/doc/mars_nwe/INSTALL.nl
+share/doc/mars_nwe/NEWS
+share/doc/mars_nwe/PIPE-FS
+share/doc/mars_nwe/PIPE-FS.ger
+share/doc/mars_nwe/PPP
+share/doc/mars_nwe/PPP.isdn
+share/doc/mars_nwe/README
+share/doc/mars_nwe/README.FREEBSD
+share/doc/mars_nwe/README.NLS
+share/doc/mars_nwe/README.ger
+share/doc/mars_nwe/TRUSTEES
+share/doc/mars_nwe/VRAGEN.NL
+share/doc/mars_nwe/mars_nwe.lsm
+@dirrm share/doc/mars_nwe