aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/sylpheed/Makefile13
-rw-r--r--mail/sylpheed/distinfo2
-rw-r--r--mail/sylpheed2-devel/Makefile13
-rw-r--r--mail/sylpheed2-devel/distinfo2
-rw-r--r--mail/sylpheed2/Makefile13
-rw-r--r--mail/sylpheed2/distinfo2
-rw-r--r--mail/sylpheed3/Makefile13
-rw-r--r--mail/sylpheed3/distinfo2
8 files changed, 44 insertions, 16 deletions
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index 27780bfc6937..a49a79b03fd5 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= sylpheed
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.good-day.net/sylpheed/
MAINTAINER= lehmann@ans-netz.de
USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_LIBTOOL= yes
+
+CONFIGURE_SCRIPT= autogen.sh
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6
+CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.3:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.4:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.endif
@@ -47,6 +51,9 @@ pre-extract:
.endif
@${ECHO_MSG}
+pre-configure:
+ ${PERL} -pi -e "s|AM_PROG_INSTALL|AC_PROG_INSTALL|g" ${WRKSRC}/aclocal.m4
+ ${RM} -f ${WRKSRC}/ac/gpgme.m4
post-install:
.if !defined(NOPORTDOCS)
diff --git a/mail/sylpheed/distinfo b/mail/sylpheed/distinfo
index 1d160a997268..48d5dc070765 100644
--- a/mail/sylpheed/distinfo
+++ b/mail/sylpheed/distinfo
@@ -1 +1 @@
-MD5 (sylpheed-0.6.3.tar.bz2) = 538225dec1ef6d896e4bd950fc085d3e
+MD5 (sylpheed-0.6.4.tar.bz2) = 517ed25347565e776526364566163c10
diff --git a/mail/sylpheed2-devel/Makefile b/mail/sylpheed2-devel/Makefile
index 27780bfc6937..a49a79b03fd5 100644
--- a/mail/sylpheed2-devel/Makefile
+++ b/mail/sylpheed2-devel/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= sylpheed
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.good-day.net/sylpheed/
MAINTAINER= lehmann@ans-netz.de
USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_LIBTOOL= yes
+
+CONFIGURE_SCRIPT= autogen.sh
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6
+CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.3:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.4:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.endif
@@ -47,6 +51,9 @@ pre-extract:
.endif
@${ECHO_MSG}
+pre-configure:
+ ${PERL} -pi -e "s|AM_PROG_INSTALL|AC_PROG_INSTALL|g" ${WRKSRC}/aclocal.m4
+ ${RM} -f ${WRKSRC}/ac/gpgme.m4
post-install:
.if !defined(NOPORTDOCS)
diff --git a/mail/sylpheed2-devel/distinfo b/mail/sylpheed2-devel/distinfo
index 1d160a997268..48d5dc070765 100644
--- a/mail/sylpheed2-devel/distinfo
+++ b/mail/sylpheed2-devel/distinfo
@@ -1 +1 @@
-MD5 (sylpheed-0.6.3.tar.bz2) = 538225dec1ef6d896e4bd950fc085d3e
+MD5 (sylpheed-0.6.4.tar.bz2) = 517ed25347565e776526364566163c10
diff --git a/mail/sylpheed2/Makefile b/mail/sylpheed2/Makefile
index 27780bfc6937..a49a79b03fd5 100644
--- a/mail/sylpheed2/Makefile
+++ b/mail/sylpheed2/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= sylpheed
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.good-day.net/sylpheed/
MAINTAINER= lehmann@ans-netz.de
USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_LIBTOOL= yes
+
+CONFIGURE_SCRIPT= autogen.sh
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6
+CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.3:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.4:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.endif
@@ -47,6 +51,9 @@ pre-extract:
.endif
@${ECHO_MSG}
+pre-configure:
+ ${PERL} -pi -e "s|AM_PROG_INSTALL|AC_PROG_INSTALL|g" ${WRKSRC}/aclocal.m4
+ ${RM} -f ${WRKSRC}/ac/gpgme.m4
post-install:
.if !defined(NOPORTDOCS)
diff --git a/mail/sylpheed2/distinfo b/mail/sylpheed2/distinfo
index 1d160a997268..48d5dc070765 100644
--- a/mail/sylpheed2/distinfo
+++ b/mail/sylpheed2/distinfo
@@ -1 +1 @@
-MD5 (sylpheed-0.6.3.tar.bz2) = 538225dec1ef6d896e4bd950fc085d3e
+MD5 (sylpheed-0.6.4.tar.bz2) = 517ed25347565e776526364566163c10
diff --git a/mail/sylpheed3/Makefile b/mail/sylpheed3/Makefile
index 27780bfc6937..a49a79b03fd5 100644
--- a/mail/sylpheed3/Makefile
+++ b/mail/sylpheed3/Makefile
@@ -6,22 +6,26 @@
#
PORTNAME= sylpheed
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= mail ipv6
MASTER_SITES= http://sylpheed.good-day.net/sylpheed/
MAINTAINER= lehmann@ans-netz.de
USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_LIBTOOL= yes
+
+CONFIGURE_SCRIPT= autogen.sh
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6
+CONFIGURE_ARGS= --disable-compface --disable-gdk-pixbuf --enable-ipv6 --prefix=${PREFIX} --with-included-gettext
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.3:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.4:${PORTSDIR}/security/gpgme
RUN_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--enable-gpgme
.endif
@@ -47,6 +51,9 @@ pre-extract:
.endif
@${ECHO_MSG}
+pre-configure:
+ ${PERL} -pi -e "s|AM_PROG_INSTALL|AC_PROG_INSTALL|g" ${WRKSRC}/aclocal.m4
+ ${RM} -f ${WRKSRC}/ac/gpgme.m4
post-install:
.if !defined(NOPORTDOCS)
diff --git a/mail/sylpheed3/distinfo b/mail/sylpheed3/distinfo
index 1d160a997268..48d5dc070765 100644
--- a/mail/sylpheed3/distinfo
+++ b/mail/sylpheed3/distinfo
@@ -1 +1 @@
-MD5 (sylpheed-0.6.3.tar.bz2) = 538225dec1ef6d896e4bd950fc085d3e
+MD5 (sylpheed-0.6.4.tar.bz2) = 517ed25347565e776526364566163c10