aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/cpupdate/Makefile7
-rw-r--r--sysutils/cpupdate/distinfo10
-rw-r--r--sysutils/cpupdate/files/cpupdate.in8
-rw-r--r--sysutils/cpupdate/files/pkg-message.in3
-rw-r--r--sysutils/cpupdate/pkg-descr2
5 files changed, 16 insertions, 14 deletions
diff --git a/sysutils/cpupdate/Makefile b/sysutils/cpupdate/Makefile
index 54953c42da2c..90b5521e09ea 100644
--- a/sysutils/cpupdate/Makefile
+++ b/sysutils/cpupdate/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cpupdate
-DISTVERSION= g20180323
-PORTREVISION= 1
+DISTVERSION= g20180324
CATEGORIES= sysutils
MAINTAINER= eugen@FreeBSD.org
@@ -23,13 +22,13 @@ SUB_LIST= CPM_DIR=${CPM_DIR} INTEL_DIR=${INTEL_DIR}
USE_GITHUB= yes
GH_ACCOUNT= kernschmelze
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= 7633a43
+GH_TAGNAME= 82ec0b6
PLIST_FILES= sbin/${PORTNAME} man/man8/${PORTNAME}.8.gz
CPM_ACCOUNT= platomav
CPM_PROJECT= CPUMicrocodes
-CPM_TAGNAME= 079248c
+CPM_TAGNAME= 869ad44
OPTIONS_DEFINE= CPM INTEL
CPM_DESC= Download platomav/CPUMicrocodes collection
diff --git a/sysutils/cpupdate/distinfo b/sysutils/cpupdate/distinfo
index 8874ac5f69bf..8eb5f7b1ed4e 100644
--- a/sysutils/cpupdate/distinfo
+++ b/sysutils/cpupdate/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1523034276
+TIMESTAMP = 1525090663
SHA256 (microcode-20180312.tgz) = 0b381face2df1b0a829dc4fa8fa93f47f39e11b1c9c22ebd44f8614657c1e779
SIZE (microcode-20180312.tgz) = 3789662
-SHA256 (kernschmelze-cpupdate-g20180323-7633a43_GH0.tar.gz) = b6a595223b7e70fbdf170b51d6aee4d907b36e080c18d076b6a17ae16bd63d28
-SIZE (kernschmelze-cpupdate-g20180323-7633a43_GH0.tar.gz) = 4566592
-SHA256 (platomav-CPUMicrocodes-079248c_GH0.tar.gz) = 89c875f5467409af543b83abe069a00bc29a7933a64a30450a5b06ab0cfa0c7c
-SIZE (platomav-CPUMicrocodes-079248c_GH0.tar.gz) = 4602296
+SHA256 (kernschmelze-cpupdate-g20180324-82ec0b6_GH0.tar.gz) = 653a64962077550eeb75c683e2ff23e1901846b89d64d34630c1b0693128e0fe
+SIZE (kernschmelze-cpupdate-g20180324-82ec0b6_GH0.tar.gz) = 4566676
+SHA256 (platomav-CPUMicrocodes-869ad44_GH0.tar.gz) = d3f3446e5a82fc874faf72e68a5c617cb61e772c0c00b61983408d343859d245
+SIZE (platomav-CPUMicrocodes-869ad44_GH0.tar.gz) = 4602485
diff --git a/sysutils/cpupdate/files/cpupdate.in b/sysutils/cpupdate/files/cpupdate.in
index 57fdff7d4f4b..87135ce28cfc 100644
--- a/sysutils/cpupdate/files/cpupdate.in
+++ b/sysutils/cpupdate/files/cpupdate.in
@@ -5,14 +5,14 @@
# PROVIDE: cpupdate
# REQUIRE: FILESYSTEMS kldxref
# BEFORE: netif
-# KEYWORD: nojail
+# KEYWORD: nojail resume
# Add these lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
# cpupdate_enable (bool): Set to NO by default.
# Set it to YES to enable cpupdate.
-# cpupdate_irbs_enable (bool): Enable Indirect Branch Restricted
+# cpupdate_ibrs_enable (bool): Enable Indirect Branch Restricted
# Speculation after start of cpupdate.
# Default is YES.
# cpupdate_flags (string): Command line flags for cpupdate.
@@ -28,11 +28,11 @@ load_rc_config $name
: ${cpupdate_enable:="NO"}
: ${cpupdate_flags="-w -u"}
-: ${cpupdate_irbs_enable="YES"}
+: ${cpupdate_ibrs_enable="YES"}
command=%%PREFIX%%/sbin/${name}
cpupdate_poststart() {
- checkyesno cpupdate_irbs_enable && sysctl -i hw.ibrs_disable=0
+ checkyesno cpupdate_ibrs_enable && sysctl -i hw.ibrs_disable=0
return 0
}
diff --git a/sysutils/cpupdate/files/pkg-message.in b/sysutils/cpupdate/files/pkg-message.in
index f8c810968213..7f13dead3a38 100644
--- a/sysutils/cpupdate/files/pkg-message.in
+++ b/sysutils/cpupdate/files/pkg-message.in
@@ -10,3 +10,6 @@ In this case you can run "make install-microcodes" to install them to
%%DATADIR%%
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
+Suspend/resume sequence clears microcode update, so make sure your system runs
+"service cpupdate start" again on resume.
+!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
diff --git a/sysutils/cpupdate/pkg-descr b/sysutils/cpupdate/pkg-descr
index b3959475735e..fd9c31484d5f 100644
--- a/sysutils/cpupdate/pkg-descr
+++ b/sysutils/cpupdate/pkg-descr
@@ -1,6 +1,6 @@
x86 CPU microcode utility for BSD.
-It is still work in progress but should do its job for Intel chips already.
+At the moment, it is for Intel processors only.
Note: update FreeBSD to OSVERSION level 1101507 for 11.x or 1200055 for 12.0+
before building/using this utility if your microcode update brings