aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/vcg/Makefile20
-rw-r--r--graphics/vcg/pkg-descr19
2 files changed, 22 insertions, 17 deletions
diff --git a/graphics/vcg/Makefile b/graphics/vcg/Makefile
index a50bd0fd56c1..10a5e6876019 100644
--- a/graphics/vcg/Makefile
+++ b/graphics/vcg/Makefile
@@ -5,25 +5,26 @@ PORTNAME= vcg
PORTVERSION= 1.30
PORTREVISION= 2
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.cs.uni-sb.de/pub/graphics/vcg/
+MASTER_SITES= http://download.polytechnic.edu.na/pub2/openpkg1/sources/DST/vcg/ \
+ http://ftp.gwdg.de/linux/openpkg/openpkg-ftp/sources/DST/vcg/ \
+ http://ftp.sjtu.edu.cn/sites/ftp.openpkg.org/sources/DST/vcg/ \
+ ftp://ftp.cs.uni-sb.de/pub/graphics/vcg/
DISTNAME= ${PORTNAME}.20050204
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A Visualization Tool for compiler graphs
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-11-26
+LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
-USE_GCC= any
-USE_XORG= x11 xext
-MANL= pbmrot90.l pbmshift.l pbm2hp.l vcgdemomaker.l vcg.l xvcg.l
+WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}
+USE_XORG= x11 xext
MAKE_JOBS_UNSAFE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}
+MANL= pbmrot90.l pbmshift.l pbm2hp.l vcgdemomaker.l vcg.l xvcg.l
pre-patch:
@${MKDIR} ${WRKSRC}/preconf/X11ccFreeBSD
@@ -38,4 +39,9 @@ pre-patch:
< ${FILESDIR}/${file} > ${WRKSRC}/preconf/X11ccFreeBSD/${file}
.endfor
+post-patch:
+.for i in animation1.c animation2.c animation3.c vcgcount.c
+ @${REINPLACE_CMD} -e '/ main/s|^void|int|' ${WRKSRC}/demo/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/graphics/vcg/pkg-descr b/graphics/vcg/pkg-descr
index 4bbab0df5d58..b399f6bcc994 100644
--- a/graphics/vcg/pkg-descr
+++ b/graphics/vcg/pkg-descr
@@ -1,12 +1,11 @@
-The VCG tool reads a textual and readable specification of a
-graph and visualizes the graph. If not all positions of
-nodes are fixed, the tool layouts the graph using several
-heuristics as reducing the number of crossings, minimizing
-the size of edges, centering of nodes. The specification
-language of the VCG tool is nearly compatible to GRL, the
-language of the edge tool, but contains many extensions. The
-VCG tool allows folding of dynamically or statically speci-
-fied regions of the graph. It uses colors and runs on
-X11. (An older version runs on Sunview).
+The VCG tool reads a textual and readable specification of a graph and
+visualizes the graph. If not all positions of nodes are fixed, the tool
+layouts the graph using several heuristics as reducing the number of
+crossings, minimizing the size of edges, centering of nodes. The
+specification language of the VCG tool is nearly compatible to GRL, the
+language of the edge tool, but contains many extensions. The VCG tool
+allows folding of dynamically or statically specified regions of the
+graph. It uses colors and runs on X11. (An older version runs on
+Sunview).
WWW: http://rw4.cs.uni-sb.de/users/sander/html/gsvcg1.html