aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/unbound/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index a9a3adc60599..50964822a8ff 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unbound
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -33,7 +34,8 @@ PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
-OPTIONS= LIBEVENT "is useful when using many (10000) outgoing ports" off
+OPTIONS= LIBEVENT "is useful when using many (10000) outgoing ports" off \
+ THREADS "build with threads support" on
.include <bsd.port.pre.mk>
@@ -44,6 +46,10 @@ CONFIGURE_ARGS+= --with-libevent=${LOCALBASE}
CONFIGURE_ARGS+= --with-libevent=no
.endif
+.if !defined(WITH_THREADS)
+CONFIGURE_ARGS+= --without-pthreads
+.endif
+
post-patch:
@${MKDIR} ${WRKSRC}/balancer
@${RM} ${WRKSRC}/util/configlexer.c