aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/blitz++/Makefile7
-rw-r--r--math/blitz++/files/patch-bzconfig14
2 files changed, 15 insertions, 6 deletions
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index f3b434b867b9..4255fec67f45 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -15,16 +15,11 @@ DISTNAME= blitz-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ class library for scientific computing
-BROKEN= "Does not compile"
-
-LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
-
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="-lg2c"
-CONFIGURE_ARGS= --with-cxx=gcc --disable-debug --with-blas=${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-cxx=gcc --enable-optimize --disable-debug
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/math/blitz++/files/patch-bzconfig b/math/blitz++/files/patch-bzconfig
new file mode 100644
index 000000000000..1df9c25b90fc
--- /dev/null
+++ b/math/blitz++/files/patch-bzconfig
@@ -0,0 +1,14 @@
+--- compiler/bzconfig.orig Thu May 22 15:06:34 2003
++++ compiler/bzconfig Thu May 22 15:07:00 2003
+@@ -37,11 +37,6 @@
+ # to edit the next line
+ objextension='o'
+
+-if test ! -t 0; then
+- echo "Use 'sh bzconfig', not 'sh < bzconfig'"
+- exit 1
+-fi
+-
+ # clean="rm -f a.out core bztemp bztest bzjunk.cpp bzjunk.o bzjunk.ii bzjunk.int.c bzjunk.s"
+ clean="rm -f core"
+ trap '$clean; exit 1' 1 2 3 15