aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-toolkits/plib/Makefile3
-rw-r--r--x11-toolkits/plib/distinfo4
-rw-r--r--x11-toolkits/plib/files/patch-src::js::jsBSD.cxx29
-rw-r--r--x11-toolkits/plib/files/patch-src::net::netMessage.h11
-rw-r--r--x11-toolkits/plib/files/patch-src::net::netSocket.cxx10
-rw-r--r--x11-toolkits/plib/files/patch-src::ssg::ssg.cxx31
6 files changed, 3 insertions, 85 deletions
diff --git a/x11-toolkits/plib/Makefile b/x11-toolkits/plib/Makefile
index f03a82335b09..b19c803a4dbe 100644
--- a/x11-toolkits/plib/Makefile
+++ b/x11-toolkits/plib/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= plib
-PORTVERSION= 1.8.3
-PORTREVISION= 2
+PORTVERSION= 1.8.4
CATEGORIES= x11-toolkits
MASTER_SITES= http://plib.sourceforge.net/dist/
diff --git a/x11-toolkits/plib/distinfo b/x11-toolkits/plib/distinfo
index c8b39db64710..dcb99460c261 100644
--- a/x11-toolkits/plib/distinfo
+++ b/x11-toolkits/plib/distinfo
@@ -1,2 +1,2 @@
-MD5 (plib-1.8.3.tar.gz) = de10b19dfcee5da7115ee2a69656f34c
-SIZE (plib-1.8.3.tar.gz) = 742380
+MD5 (plib-1.8.4.tar.gz) = 5e3f289a9d1c5de0b1cfdec76bf139e6
+SIZE (plib-1.8.4.tar.gz) = 793758
diff --git a/x11-toolkits/plib/files/patch-src::js::jsBSD.cxx b/x11-toolkits/plib/files/patch-src::js::jsBSD.cxx
deleted file mode 100644
index 4109a6071094..000000000000
--- a/x11-toolkits/plib/files/patch-src::js::jsBSD.cxx
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/js/jsBSD.cxx.orig Sat Mar 20 01:21:53 2004
-+++ src/js/jsBSD.cxx Thu Jun 3 17:06:30 2004
-@@ -44,7 +44,11 @@
- #endif
-
- #include <sys/ioctl.h>
--#include <machine/joystick.h> // For analog joysticks
-+#if defined(__FreeBSD__)
-+# include <sys/joystick.h>
-+#else
-+# include <machine/joystick.h> // For analog joysticks
-+#endif
- #ifdef HAVE_USB_JS
- #if defined(__NetBSD__)
- #ifdef HAVE_USBHID_H
-@@ -54,7 +58,12 @@
- #endif
- #elif defined(__FreeBSD__)
- extern "C" {
--#include <libusbhid.h>
-+# if __FreeBSD_version < 500000
-+# include <libusbhid.h>
-+# else
-+# define HAVE_USBHID_H 1
-+# include <usbhid.h>
-+# endif
- }
- #endif
- #include <dev/usb/usb.h>
diff --git a/x11-toolkits/plib/files/patch-src::net::netMessage.h b/x11-toolkits/plib/files/patch-src::net::netMessage.h
deleted file mode 100644
index f54777ad3c4b..000000000000
--- a/x11-toolkits/plib/files/patch-src::net::netMessage.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/net/netMessage.h.orig Sat Mar 16 01:23:39 2002
-+++ src/net/netMessage.h Sat Mar 16 01:24:23 2002
-@@ -46,6 +46,8 @@
- #include <netinet/in.h> // ntohs() etc prototypes
- #endif
-
-+#include <arpa/inet.h>
-+
-
- class netGuid //Globally Unique IDentifier
- {
diff --git a/x11-toolkits/plib/files/patch-src::net::netSocket.cxx b/x11-toolkits/plib/files/patch-src::net::netSocket.cxx
deleted file mode 100644
index 3ceedd537e33..000000000000
--- a/x11-toolkits/plib/files/patch-src::net::netSocket.cxx
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/net/netSocket.cxx.orig Sun Oct 14 21:13:16 2001
-+++ src/net/netSocket.cxx Sun Oct 14 21:13:48 2001
-@@ -46,6 +46,7 @@
-
- /* Paul Wiltsey says we need this for Solaris 2.8 */
-
-+#include <netinet/in.h>
- #ifndef INADDR_NONE
- #define INADDR_NONE ((unsigned long)-1)
- #endif
diff --git a/x11-toolkits/plib/files/patch-src::ssg::ssg.cxx b/x11-toolkits/plib/files/patch-src::ssg::ssg.cxx
deleted file mode 100644
index fe2f93117904..000000000000
--- a/x11-toolkits/plib/files/patch-src::ssg::ssg.cxx
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/ssg/ssg.cxx.orig Mon Mar 3 11:25:56 2003
-+++ src/ssg/ssg.cxx Mon Mar 3 11:27:40 2003
-@@ -35,6 +35,7 @@
- # endif
- #endif
-
-+#if 0
- static bool glIsValidContext ( void )
- {
- #if defined(CONSOLE)
-@@ -49,6 +50,7 @@
- return ( glXGetCurrentContext () != NULL ) ;
- #endif
- }
-+#endif
-
- sgMat4 _ssgOpenGLAxisSwapMatrix =
- {
-@@ -105,10 +107,12 @@
-
- void ssgInit ()
- {
-+#if 0
- if ( ! glIsValidContext () )
- {
- ulSetError ( UL_FATAL, "ssgInit called without a valid OpenGL context.");
- }
-+#endif
-
- ssgTexturePath ( "." ) ;
- ssgModelPath ( "." ) ;