aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/jpeg-turbo/Makefile2
-rw-r--r--graphics/jpeg-turbo/files/patch-jchuff.c20
-rw-r--r--graphics/libjpeg-turbo/Makefile2
3 files changed, 22 insertions, 2 deletions
diff --git a/graphics/jpeg-turbo/Makefile b/graphics/jpeg-turbo/Makefile
index a097aec2eada..5a6d8443dbe0 100644
--- a/graphics/jpeg-turbo/Makefile
+++ b/graphics/jpeg-turbo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= jpeg-turbo
PORTVERSION= 1.3.1
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= graphics
MASTER_SITES= SF/lib${PORTNAME}/${PORTVERSION}
DISTNAME= lib${PORTNAME}-${PORTVERSION}
diff --git a/graphics/jpeg-turbo/files/patch-jchuff.c b/graphics/jpeg-turbo/files/patch-jchuff.c
new file mode 100644
index 000000000000..b636db44c5e1
--- /dev/null
+++ b/graphics/jpeg-turbo/files/patch-jchuff.c
@@ -0,0 +1,20 @@
+--- jchuff.c.orig 2013-09-28 03:23:49 UTC
++++ jchuff.c
+@@ -391,7 +391,16 @@ dump_buffer (working_state * state)
+ #endif
+
+
+-#define BUFSIZE (DCTSIZE2 * 2)
++/* Although it is exceedingly rare, it is possible for a Huffman-encoded
++ * coefficient block to be larger than the 128-byte unencoded block. For each
++ * of the 64 coefficients, PUT_BITS is invoked twice, and each invocation can
++ * theoretically store 16 bits (for a maximum of 2048 bits or 256 bytes per
++ * encoded block.) If, for instance, one artificially sets the AC
++ * coefficients to alternating values of 32767 and -32768 (using the JPEG
++ * scanning order-- 1, 8, 16, etc.), then this will produce an encoded block
++ * larger than 200 bytes.
++ */
++#define BUFSIZE (DCTSIZE2 * 4)
+
+ #define LOAD_BUFFER() { \
+ if (state->free_in_buffer < BUFSIZE) { \
diff --git a/graphics/libjpeg-turbo/Makefile b/graphics/libjpeg-turbo/Makefile
index c3d4b333b5a1..798426403242 100644
--- a/graphics/libjpeg-turbo/Makefile
+++ b/graphics/libjpeg-turbo/Makefile
@@ -1,7 +1,7 @@
# Created by: Denis Podolskiy <bytestore@yandex.ru>
# $FreeBSD$
-PORTREVISION= 4
+PORTREVISION= 5
PKGNAMEPREFIX= lib
COMMENT= SIMD-accelerated JPEG codec library, provides libTurboJPEG