aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/kompozer/pkg-deinstall.in26
-rw-r--r--www/kompozer/pkg-install.in33
-rw-r--r--www/mozilla/Makefile.common10
-rw-r--r--www/mozilla/pkg-deinstall.in1
-rw-r--r--www/nvu/pkg-deinstall.in26
-rw-r--r--www/nvu/pkg-install.in33
6 files changed, 7 insertions, 122 deletions
diff --git a/www/kompozer/pkg-deinstall.in b/www/kompozer/pkg-deinstall.in
deleted file mode 100644
index 513886b85f79..000000000000
--- a/www/kompozer/pkg-deinstall.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-# $MCom: ports/www/nvu/pkg-deinstall.in,v 1.1 2005/11/14 04:12:09 ahze Exp $
-#
-# Date created: Mon Nov 29, 2003
-# Whom: Thierry Thomas (<thierry@pompo.net>)
-# Fix the chrome registry.
-
-umask 022
-PATH=/bin:/usr/bin
-
-[ "x$1" = "x" ] && exit 1
-[ "x$2" != "xDEINSTALL" ] && exit 0
-
-NVUDIR=%%MOZDIR%%
-
-rm -rf ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/chrome/*.rdf
-rm -f ${NVUDIR}/component.reg
-rm -f ${NVUDIR}/components.ini
-rm -f ${NVUDIR}/defaults.ini
-rm -f ${NVUDIR}/components/*.dat
-rm -rf ${NVUDIR}/extensions
-
-exit 0
diff --git a/www/kompozer/pkg-install.in b/www/kompozer/pkg-install.in
deleted file mode 100644
index c3c37df29cac..000000000000
--- a/www/kompozer/pkg-install.in
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-# $MCom: ports/www/nvu/pkg-install.in,v 1.1 2005/11/14 04:12:09 ahze Exp $
-#
-# Date created: Mon Nov 29, 2003
-# Whom: Thierry Thomas (<thierry@pompo.net>)
-# Fix the chrome registry.
-
-umask 022
-PATH=/bin:/usr/bin:/usr/local/bin
-
-[ "x$1" = "x" ] && exit 1
-[ "x$2" != "xPOST-INSTALL" ] && exit 0
-
-NVUDIR=%%MOZDIR%%
-REGXPCOM=${NVUDIR}/regxpcom
-REGCHROME=${NVUDIR}/regchrome
-NVUBIN=${NVUDIR}/nvu-bin
-
-echo "===> Building Chrome's registry..."
-rm -rf ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/chrome/*.rdf
-mkdir -p ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/component.reg
-rm -rf ${NVUDIR}/extensions
-
-cd ${NVUDIR} || exit 1
-./run-mozilla.sh ${REGXPCOM} || true
-./run-mozilla.sh ${REGCHROME} || true
-./run-mozilla.sh ${NVUBIN} -register > /dev/null 2>&1
-
-exit 0
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index d8b58d49e95c..5a43d6383b76 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -94,6 +94,8 @@ MOZILLA_PLIST_DIRS?= bin include lib share/idl
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
+PKGINSTALL_INC?= ${MASTERDIR}/pkg-install.in
+PKGDEINSTALL_INC?= ${MASTERDIR}/pkg-deinstall.in
EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/* \
@@ -239,11 +241,11 @@ MOZCONFIG_SED?= ${SED} ${MOZ_SED_ARGS}
post-patch: gecko-post-patch gecko-moz-pis-patch
gecko-post-patch:
-.if exists(${MASTER_DIR}/pkg-install.in)
- @${MOZCONFIG_SED} < ${MASTER_DIR}/pkg-install.in > ${PKGINSTALL}
+.if exists(${PKGINSTALL_INC})
+ @${MOZCONFIG_SED} < ${PKGINSTALL_INC} > ${PKGINSTALL}
.endif
-.if exists(${MASTER_DIR}/pkg-deinstall.in)
- @${MOZCONFIG_SED} < ${MASTER_DIR}/pkg-deinstall.in > ${PKGDEINSTALL}
+.if exists(${PKGDEINSTALL_INC})
+ @${MOZCONFIG_SED} < ${PKGDEINSTALL_INC} > ${PKGDEINSTALL}
.endif
@${RM} -f ${MOZCONFIG}
.if !defined(NOMOZCONFIG)
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 1d381a06fe88..ca02bac44de0 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -23,5 +23,6 @@ rm -f ${MOZDIR}/components.ini
rm -f ${MOZDIR}/defaults.ini
rm -f ${MOZDIR}/chrome/app-chrome.manifest
rm -rf ${MOZDIR}/updates
+rm -rf ${MOZDIR}/extensions
exit 0
diff --git a/www/nvu/pkg-deinstall.in b/www/nvu/pkg-deinstall.in
deleted file mode 100644
index 513886b85f79..000000000000
--- a/www/nvu/pkg-deinstall.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-# $MCom: ports/www/nvu/pkg-deinstall.in,v 1.1 2005/11/14 04:12:09 ahze Exp $
-#
-# Date created: Mon Nov 29, 2003
-# Whom: Thierry Thomas (<thierry@pompo.net>)
-# Fix the chrome registry.
-
-umask 022
-PATH=/bin:/usr/bin
-
-[ "x$1" = "x" ] && exit 1
-[ "x$2" != "xDEINSTALL" ] && exit 0
-
-NVUDIR=%%MOZDIR%%
-
-rm -rf ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/chrome/*.rdf
-rm -f ${NVUDIR}/component.reg
-rm -f ${NVUDIR}/components.ini
-rm -f ${NVUDIR}/defaults.ini
-rm -f ${NVUDIR}/components/*.dat
-rm -rf ${NVUDIR}/extensions
-
-exit 0
diff --git a/www/nvu/pkg-install.in b/www/nvu/pkg-install.in
deleted file mode 100644
index c3c37df29cac..000000000000
--- a/www/nvu/pkg-install.in
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-# $MCom: ports/www/nvu/pkg-install.in,v 1.1 2005/11/14 04:12:09 ahze Exp $
-#
-# Date created: Mon Nov 29, 2003
-# Whom: Thierry Thomas (<thierry@pompo.net>)
-# Fix the chrome registry.
-
-umask 022
-PATH=/bin:/usr/bin:/usr/local/bin
-
-[ "x$1" = "x" ] && exit 1
-[ "x$2" != "xPOST-INSTALL" ] && exit 0
-
-NVUDIR=%%MOZDIR%%
-REGXPCOM=${NVUDIR}/regxpcom
-REGCHROME=${NVUDIR}/regchrome
-NVUBIN=${NVUDIR}/nvu-bin
-
-echo "===> Building Chrome's registry..."
-rm -rf ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/chrome/*.rdf
-mkdir -p ${NVUDIR}/chrome/overlayinfo
-rm -f ${NVUDIR}/component.reg
-rm -rf ${NVUDIR}/extensions
-
-cd ${NVUDIR} || exit 1
-./run-mozilla.sh ${REGXPCOM} || true
-./run-mozilla.sh ${REGCHROME} || true
-./run-mozilla.sh ${NVUBIN} -register > /dev/null 2>&1
-
-exit 0