aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/crescendo/Makefile4
-rw-r--r--news/fidogate/Makefile2
-rw-r--r--print/a2ps-letter/Makefile4
-rw-r--r--security/gnupg-idea/Makefile2
-rw-r--r--www/twig/Makefile2
5 files changed, 6 insertions, 8 deletions
diff --git a/net/crescendo/Makefile b/net/crescendo/Makefile
index 953c051c6624..9159b43eec34 100644
--- a/net/crescendo/Makefile
+++ b/net/crescendo/Makefile
@@ -41,9 +41,9 @@ pre-patch:
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog HACKING INSTALL NEWS \
+.for i in AUTHORS ChangeLog HACKING INSTALL NEWS \
README README.BINARY TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
.endfor
.endif
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index f3ca9f697ea9..3084af0351fc 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -62,7 +62,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-perl
post-patch:
.for i in ${FIXME}
${PERL5} -pi -e "s=([ ])log[(]=\\1log_fg(=" ${WRKSRC}/${i}
- @grep "log_fg" ${WRKSRC}/${i}
+ @${GREP} "log_fg" ${WRKSRC}/${i}
.endfor
pre-configure:
diff --git a/print/a2ps-letter/Makefile b/print/a2ps-letter/Makefile
index 8a85315020e7..1cff843d8f1b 100644
--- a/print/a2ps-letter/Makefile
+++ b/print/a2ps-letter/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= ftp://ftp.enst.fr/pub/unix/a2ps/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -${PAPERSIZE}
-DISTFILES= a2ps-${PORTVERSION}${EXTRACT_SUFX}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Formats an ascii file for printing on a postscript printer
@@ -28,7 +26,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-4.13
PAPERSIZE?= letter
PAPERSIZECNF= ${PAPERSIZE:S/l/L/:S/a/A/}
STRIP=
-CONFIGURE_ARGS= --with-medium=${PAPERSIZECNF} --sharedstatedir=$(PREFIX)/share --sysconfdir=$(PREFIX)/etc --datadir=$(PREFIX)/share --localstatedir=$(PREFIX)/share
+CONFIGURE_ARGS= --with-medium=${PAPERSIZECNF} --sharedstatedir=${PREFIX}/share --sysconfdir=${PREFIX}/etc --datadir=${PREFIX}/share --localstatedir=${PREFIX}/share
.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter && ${PAPERSIZE} != letterdj
.BEGIN:
diff --git a/security/gnupg-idea/Makefile b/security/gnupg-idea/Makefile
index 152c1027663f..9385d113a0c5 100644
--- a/security/gnupg-idea/Makefile
+++ b/security/gnupg-idea/Makefile
@@ -52,7 +52,7 @@ pre-extract:
post-extract:
.for i in rsa.c
- @tr -d '\r' <${_DISTDIR}/${i} >${WRKSRC}/${i}
+ @${TR} -d '\r' <${_DISTDIR}/${i} >${WRKSRC}/${i}
.endfor
do-patch:
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 181ecd5cddb0..20efcbdada3a 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/${PHP4_PORT}
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/${PHP3_PORT}
.endif
.if !defined(WITH_MYSQL)
-POSTGRESQL_PORT?= databases/postgresql-client
LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
.else
.endif
@@ -28,6 +27,7 @@ NO_BUILD= YES
PHP4_PORT?= www/mod_php4-twig
PHP3_PORT?= www/mod_php3
TWIG?= www/data-dist/twig
+POSTGRESQL_PORT?= databases/postgresql-client
PLIST_SUB+= TWIG=${TWIG}
ROOTFILES= index.php3 test.php3 goto.php3
CONFFILES= .htaccess mailfooter.inc.php3.sample