aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/py-libmpdclient/Makefile3
-rw-r--r--databases/py-MySQL/Makefile3
-rw-r--r--databases/py-SQLDict/Makefile16
-rw-r--r--devel/py-ice/Makefile2
-rw-r--r--devel/py-kqueue/Makefile2
-rw-r--r--devel/py-subversion/Makefile2
-rw-r--r--devel/py-tconfpy/Makefile3
-rw-r--r--devel/py-thrift/Makefile2
-rw-r--r--math/py-gnuplot/Makefile3
-rw-r--r--net-im/py-punjab/Makefile2
-rw-r--r--net/py-mp-random/Makefile2
-rw-r--r--textproc/py-HyperText/Makefile16
-rw-r--r--x11-toolkits/py-gnome/Makefile3
-rw-r--r--x11-toolkits/py-gtk/Makefile3
-rw-r--r--x11-toolkits/py-gtkscintilla/Makefile3
15 files changed, 36 insertions, 29 deletions
diff --git a/audio/py-libmpdclient/Makefile b/audio/py-libmpdclient/Makefile
index e4035a27e172..c0b47305a1c3 100644
--- a/audio/py-libmpdclient/Makefile
+++ b/audio/py-libmpdclient/Makefile
@@ -5,10 +5,11 @@
# $FreeBSD$
#
-PORTNAME= py-libmpdclient
+PORTNAME= libmpdclient
PORTVERSION= 0.10.0
CATEGORIES= audio python
MASTER_SITES= http://mercury.chem.pitt.edu/~shank/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= tim@n2it.net
COMMENT= Python bindings for libmpdclient
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 7283ccb40a14..30b6bf9e6627 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -5,10 +5,11 @@
# $FreeBSD$
#
-PORTNAME= py-MySQL
+PORTNAME= MySQL
PORTVERSION= 1.4
CATEGORIES= databases python
MASTER_SITES= http://mysql.osuosl.org/Downloads/Contrib/Old-Versions/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= MySQLmodule-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
diff --git a/databases/py-SQLDict/Makefile b/databases/py-SQLDict/Makefile
index 48d524f6015e..ffbc4a40d456 100644
--- a/databases/py-SQLDict/Makefile
+++ b/databases/py-SQLDict/Makefile
@@ -5,17 +5,17 @@
# $FreeBSD$
#
-PORTNAME= SQLDict
-PORTVERSION= 1.0.0
-CATEGORIES= databases python
-MASTER_SITES= http://dustman.net/andy/python/SQLDict/1.0.0/
-PKGNAMEPREFIX= py-
+PORTNAME= SQLDict
+PORTVERSION= 1.0.0
+CATEGORIES= databases python
+MASTER_SITES= http://dustman.net/andy/python/SQLDict/1.0.0/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Python dictionary wrapper around a SQL database
-USE_PYTHON= yes
-NO_WRKSUBDIR= yes
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
do-build:
@cd ${WRKSRC} && ${PYTHON_CMD} -c 'import SQLDict'
diff --git a/devel/py-ice/Makefile b/devel/py-ice/Makefile
index 5956c6f3df61..212c25b02bda 100644
--- a/devel/py-ice/Makefile
+++ b/devel/py-ice/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 3.3.1
CATEGORIES= devel python
MASTER_SITES= http://www.zeroc.com/download/Ice/3.3/ \
http://www.dirk.sh/dirk/Ice/
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Ice-${PORTVERSION}
MAINTAINER= dirk.ye@gmail.com
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index d371f4709bd6..002c4dd9a13d 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.4
PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= http://ox.eicat.ca/~dgilbert/files/
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyKQueue-${PORTVERSION}
EXTRACT_SUFX= .tbz
diff --git a/devel/py-subversion/Makefile b/devel/py-subversion/Makefile
index 897c4069f411..e985bda68abf 100644
--- a/devel/py-subversion/Makefile
+++ b/devel/py-subversion/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lev@FreeBSD.org
COMMENT= Python bindings for version control system
diff --git a/devel/py-tconfpy/Makefile b/devel/py-tconfpy/Makefile
index cf19ef65a053..a41e327d5649 100644
--- a/devel/py-tconfpy/Makefile
+++ b/devel/py-tconfpy/Makefile
@@ -4,10 +4,11 @@
#
# $FreeBSD$
-PORTNAME= py-tconfpy
+PORTNAME= tconfpy
PORTVERSION= 2.112
CATEGORIES= devel python
MASTER_SITES= http://www.tundraware.com/Software/tconfpy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= tconfpy@tundraware.com
COMMENT= A Python Configuration File Parser
diff --git a/devel/py-thrift/Makefile b/devel/py-thrift/Makefile
index c2e68e4981e6..3d60f8173cf6 100644
--- a/devel/py-thrift/Makefile
+++ b/devel/py-thrift/Makefile
@@ -8,7 +8,7 @@
PORTNAME= thrift
PORTVERSION= 20090622
CATEGORIES= devel python
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES=
MAINTAINER= jdugan@x1024.net
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index 14f8611c0a6b..5181bb41cfdb 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -5,10 +5,11 @@
# $FreeBSD$
#
-PORTNAME= py-gnuplot
+PORTNAME= gnuplot
PORTVERSION= 1.8
CATEGORIES= math python
MASTER_SITES= SF/gnuplot-py
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= gnuplot-py-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
diff --git a/net-im/py-punjab/Makefile b/net-im/py-punjab/Makefile
index 8715be41c5b8..e1e437d8cfed 100644
--- a/net-im/py-punjab/Makefile
+++ b/net-im/py-punjab/Makefile
@@ -9,7 +9,7 @@ PORTNAME= punjab
PORTVERSION= 0.12
CATEGORIES= net-im python
MASTER_SITES= http://butterfat.net/punjab/
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= beech@FreeBSD.org
COMMENT= HTTP-polling and HTTP-binding gateway for Jabber
diff --git a/net/py-mp-random/Makefile b/net/py-mp-random/Makefile
index 86adc6a87652..3ef3c370ded9 100644
--- a/net/py-mp-random/Makefile
+++ b/net/py-mp-random/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.0
PORTREVISION= 4
CATEGORIES= net python
MASTER_SITES= http://mirrorproject.com/widget/
-PKGNAMEPREFIX= py-
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= MirrorProjectRandomImageWidget-src-${PORTVERSION}
MAINTAINER= randomimage-widget@mirrorproject.com
diff --git a/textproc/py-HyperText/Makefile b/textproc/py-HyperText/Makefile
index 00b79dea4a04..b3f0825bc0e8 100644
--- a/textproc/py-HyperText/Makefile
+++ b/textproc/py-HyperText/Makefile
@@ -5,17 +5,17 @@
# $FreeBSD$
#
-PORTNAME= HyperText
-PORTVERSION= 1.0.1
-CATEGORIES= textproc python
-MASTER_SITES= http://dustman.net/andy/python/HyperText/1.0.1/
-PKGNAMEPREFIX= py-
+PORTNAME= HyperText
+PORTVERSION= 1.0.1
+CATEGORIES= textproc python
+MASTER_SITES= http://dustman.net/andy/python/HyperText/1.0.1/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Lightweight HTML/XHTML generator for Python
-USE_PYTHON= yes
-WRKSRC= ${WRKDIR}/HyperText
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/HyperText
# get rid of pre-compiled stuff: it may not work for the installed
# version of Python
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index a51d098d964e..16e7d68f3c73 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
#
-PORTNAME= py-gnome
+PORTNAME= gnome
PORTVERSION= 1.4.4
PORTREVISION= 10
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-python/1.4
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= gnome-python-${PORTVERSION}
DIST_SUBDIR= gnome
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index 071d1cf8b90d..c6541faad17b 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -5,11 +5,12 @@
# $FreeBSD$
#
-PORTNAME= py-gtk
+PORTNAME= gtk
PORTVERSION= 0.6.11
PORTREVISION= 7
CATEGORIES= x11-toolkits python
MASTER_SITES= GNOME
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= gnome-python-1.4.4
DIST_SUBDIR= gnome
diff --git a/x11-toolkits/py-gtkscintilla/Makefile b/x11-toolkits/py-gtkscintilla/Makefile
index f8c6286a989e..b9cbe3ecd8e6 100644
--- a/x11-toolkits/py-gtkscintilla/Makefile
+++ b/x11-toolkits/py-gtkscintilla/Makefile
@@ -5,12 +5,13 @@
# $FreeBSD$
# $MCom: ports/x11-toolkits/py-gtkscintilla/Makefile,v 1.1 2006/10/07 15:53:59 ahze Exp $
-PORTNAME= py-gtkscintilla
+PORTNAME= gtkscintilla
PORTVERSION= 0.8.2
PORTREVISION= 6
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= moleskine
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyGtkScintilla-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org