aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/lfhex/Makefile8
-rw-r--r--editors/lfhex/files/patch-src::reader.hpp18
2 files changed, 19 insertions, 7 deletions
diff --git a/editors/lfhex/Makefile b/editors/lfhex/Makefile
index fde9921bfb53..647f859056bb 100644
--- a/editors/lfhex/Makefile
+++ b/editors/lfhex/Makefile
@@ -30,10 +30,4 @@ MAKE_ARGS= CXXFLAGS="${CXXFLAGS}" \
PLIST_FILES= bin/lfhex
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
-BROKEN= "Does not build on FreeBSD >= 6.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/editors/lfhex/files/patch-src::reader.hpp b/editors/lfhex/files/patch-src::reader.hpp
new file mode 100644
index 000000000000..04c8e0efa058
--- /dev/null
+++ b/editors/lfhex/files/patch-src::reader.hpp
@@ -0,0 +1,18 @@
+--- src/reader.hpp.orig Fri Feb 13 13:28:32 2004
++++ src/reader.hpp Sat Dec 18 01:46:26 2004
+@@ -34,9 +34,13 @@
+ #include "local.h"
+
+ #ifdef DEBUG
+-#define INLINE
++# define INLINE
+ #else
+-#define INLINE inline
++# if defined(__GNUC__) && __GNUC__ == 3 && __GNUC_MINOR__ >= 1
++# define INLINE __attribute__((always_inline))
++# else
++# define INLINE inline
++# endif
+ #endif
+
+ typedef vector<uchar> ReadBuffer;