aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/linux-opera-devel/Makefile8
-rw-r--r--www/linux-opera/Makefile8
-rw-r--r--www/linux-opera7/Makefile8
3 files changed, 12 insertions, 12 deletions
diff --git a/www/linux-opera-devel/Makefile b/www/linux-opera-devel/Makefile
index ad95314c77d5..b6fbec3ee9c2 100644
--- a/www/linux-opera-devel/Makefile
+++ b/www/linux-opera-devel/Makefile
@@ -7,12 +7,12 @@
PORTNAME= opera
PKGNAMEPREFIX= linux-
-PORTVERSION= 6.0-20011122.1
-PORTREVISION= 1
+OPERAVERSION= 6.0-20011122.1
+PORTVERSION= ${OPERAVERSION:S/-/./}
CATEGORIES= www linux
MASTER_SITES= http://opera.online.no/linux/600/tp1/ \
ftp://ftp.opera.com/pub/opera/linux/600/tp1/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-static_qt.i386
+DISTNAME= ${PORTNAME}-${OPERAVERSION}-static_qt.i386
MAINTAINER= des@FreeBSD.org
@@ -38,7 +38,7 @@ do-install:
--docdir=${DOCSDIR} \
--sharedir=${DATADIR} \
--plugindir=${DATADIR}/plugins )
- rmdir ${DATADIR}/uninst/rollback_${PORTVERSION}
+ ${RM} -rf ${DATADIR}/uninst/rollback_${OPERAVERSION}
rmdir ${DATADIR}/uninst
.include <bsd.port.mk>
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index ad95314c77d5..b6fbec3ee9c2 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -7,12 +7,12 @@
PORTNAME= opera
PKGNAMEPREFIX= linux-
-PORTVERSION= 6.0-20011122.1
-PORTREVISION= 1
+OPERAVERSION= 6.0-20011122.1
+PORTVERSION= ${OPERAVERSION:S/-/./}
CATEGORIES= www linux
MASTER_SITES= http://opera.online.no/linux/600/tp1/ \
ftp://ftp.opera.com/pub/opera/linux/600/tp1/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-static_qt.i386
+DISTNAME= ${PORTNAME}-${OPERAVERSION}-static_qt.i386
MAINTAINER= des@FreeBSD.org
@@ -38,7 +38,7 @@ do-install:
--docdir=${DOCSDIR} \
--sharedir=${DATADIR} \
--plugindir=${DATADIR}/plugins )
- rmdir ${DATADIR}/uninst/rollback_${PORTVERSION}
+ ${RM} -rf ${DATADIR}/uninst/rollback_${OPERAVERSION}
rmdir ${DATADIR}/uninst
.include <bsd.port.mk>
diff --git a/www/linux-opera7/Makefile b/www/linux-opera7/Makefile
index ad95314c77d5..b6fbec3ee9c2 100644
--- a/www/linux-opera7/Makefile
+++ b/www/linux-opera7/Makefile
@@ -7,12 +7,12 @@
PORTNAME= opera
PKGNAMEPREFIX= linux-
-PORTVERSION= 6.0-20011122.1
-PORTREVISION= 1
+OPERAVERSION= 6.0-20011122.1
+PORTVERSION= ${OPERAVERSION:S/-/./}
CATEGORIES= www linux
MASTER_SITES= http://opera.online.no/linux/600/tp1/ \
ftp://ftp.opera.com/pub/opera/linux/600/tp1/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-static_qt.i386
+DISTNAME= ${PORTNAME}-${OPERAVERSION}-static_qt.i386
MAINTAINER= des@FreeBSD.org
@@ -38,7 +38,7 @@ do-install:
--docdir=${DOCSDIR} \
--sharedir=${DATADIR} \
--plugindir=${DATADIR}/plugins )
- rmdir ${DATADIR}/uninst/rollback_${PORTVERSION}
+ ${RM} -rf ${DATADIR}/uninst/rollback_${OPERAVERSION}
rmdir ${DATADIR}/uninst
.include <bsd.port.mk>