aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/libmesode/Makefile23
-rw-r--r--net-im/libmesode/distinfo3
-rw-r--r--net-im/libmesode/files/patch-configure.ac26
-rw-r--r--net-im/libmesode/pkg-descr3
-rw-r--r--net-im/libmesode/pkg-plist6
6 files changed, 62 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 9b3ea20a41cc..41eb5532053e 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -58,6 +58,7 @@
SUBDIR += libaccounts-glib
SUBDIR += libaccounts-qt5
SUBDIR += libjreen
+ SUBDIR += libmesode
SUBDIR += libnice
SUBDIR += libnice-gst010
SUBDIR += libnice-gst1
diff --git a/net-im/libmesode/Makefile b/net-im/libmesode/Makefile
new file mode 100644
index 000000000000..e7e07930d0f6
--- /dev/null
+++ b/net-im/libmesode/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= libmesode
+PORTVERSION= 0.9.1
+CATEGORIES= net-im
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Lightweight XMPP library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE.txt
+
+LIB_DEPENDS= libexpat.so:textproc/expat2
+
+USE_GITHUB= yes
+GH_ACCOUNT= boothj5
+USES= libtool pkgconfig autoreconf ssl
+GNU_CONFIGURE= yes
+INSTALL_TARGET=install-strip
+CONFIGURE_ARGS+= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/libmesode/distinfo b/net-im/libmesode/distinfo
new file mode 100644
index 000000000000..bc7ae36dd970
--- /dev/null
+++ b/net-im/libmesode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486247536
+SHA256 (boothj5-libmesode-0.9.1_GH0.tar.gz) = e693ea1577f0d9e6e58dd8ada9825c359784a225620cbc2fde7295369d295245
+SIZE (boothj5-libmesode-0.9.1_GH0.tar.gz) = 142880
diff --git a/net-im/libmesode/files/patch-configure.ac b/net-im/libmesode/files/patch-configure.ac
new file mode 100644
index 000000000000..a9aee4409930
--- /dev/null
+++ b/net-im/libmesode/files/patch-configure.ac
@@ -0,0 +1,26 @@
+--- configure.ac.orig 2016-09-17 18:34:38.000000000 +0200
++++ configure.ac 2017-02-05 00:01:38.603627000 +0100
+@@ -18,19 +18,19 @@
+ [PLATFORM="nix"])
+
+ PKG_CHECK_MODULES([expat], [expat >= 2.0.0],
+- [PC_REQUIRES+=(expat)],
++ [PC_REQUIRES="expat ${PC_REQUIRES}"],
+ [AC_CHECK_HEADER([expat.h],
+ [
+ expat_LIBS="-lexpat"
+- PC_LIBS+=($expat_LIBS)
++ PC_LIBS+=${expat_LIBS}
+ ],
+ [AC_MSG_ERROR([expat not found; expat required.])]
+ )
+ ])
+ with_parser=expat
+ PARSER_NAME=expat
+-PARSER_CFLAGS=$expat_CFLAGS
+-PARSER_LIBS=$expat_LIBS
++PARSER_CFLAGS=${expat_CFLAGS}
++PARSER_LIBS=${expat_LIBS}
+
+ AC_ARG_ENABLE([tls],
+ [AS_HELP_STRING([--disable-tls], [disable TLS support])])
diff --git a/net-im/libmesode/pkg-descr b/net-im/libmesode/pkg-descr
new file mode 100644
index 000000000000..59c468ff897f
--- /dev/null
+++ b/net-im/libmesode/pkg-descr
@@ -0,0 +1,3 @@
+libmesode is a fork of libstrophe, a minimal XMPP library written in C.
+
+WWW: https://github.com/boothj5/libmesode
diff --git a/net-im/libmesode/pkg-plist b/net-im/libmesode/pkg-plist
new file mode 100644
index 000000000000..c62616d6c712
--- /dev/null
+++ b/net-im/libmesode/pkg-plist
@@ -0,0 +1,6 @@
+include/mesode.h
+lib/libmesode.so.0.0.0
+lib/libmesode.so.0
+lib/libmesode.so
+lib/libmesode.a
+libdata/pkgconfig/libmesode.pc