aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/icebreaker/Makefile1
-rw-r--r--games/icebreaker/files/patch-options_c12
2 files changed, 13 insertions, 0 deletions
diff --git a/games/icebreaker/Makefile b/games/icebreaker/Makefile
index 3c10dce27309..0eb0f0fd298a 100644
--- a/games/icebreaker/Makefile
+++ b/games/icebreaker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icebreaker
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.mattdm.org/icebreaker/1.2.x/
EXTRACT_SUFX= .tgz
diff --git a/games/icebreaker/files/patch-options_c b/games/icebreaker/files/patch-options_c
new file mode 100644
index 000000000000..6ad8e49f5850
--- /dev/null
+++ b/games/icebreaker/files/patch-options_c
@@ -0,0 +1,12 @@
+$OpenBSD: patch-options_c,v 1.1 2003/06/17 01:32:49 avsm Exp $
+--- options.c.orig Tue Jun 17 02:20:08 2003
++++ options.c Tue Jun 17 02:21:20 2003
+@@ -71,7 +71,7 @@ int readoptions(void)
+ linebuf[i]=tolower(linebuf[i]);
+ }
+
+- if (sscanf(linebuf,"%20s %10s",optbuf,valbuf)==2)
++ if (sscanf(linebuf,"%19s %9s",optbuf,valbuf)==2)
+ {
+ if (!strcmp(optbuf,"sound"))
+ {