aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-Fax-Hylafax-Client/Makefile31
-rw-r--r--comms/p5-Fax-Hylafax-Client/distinfo2
-rw-r--r--comms/p5-Fax-Hylafax-Client/pkg-descr9
-rw-r--r--comms/p5-Fax-Hylafax-Client/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index bc23c576f5e0..81606725a7be 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -67,6 +67,7 @@
SUBDIR += openobex
SUBDIR += p5-Device-Modem
SUBDIR += p5-Device-SerialPort
+ SUBDIR += p5-Fax-Hylafax-Client
SUBDIR += plp
SUBDIR += pr
SUBDIR += predict
diff --git a/comms/p5-Fax-Hylafax-Client/Makefile b/comms/p5-Fax-Hylafax-Client/Makefile
new file mode 100644
index 000000000000..6f5a7e563a10
--- /dev/null
+++ b/comms/p5-Fax-Hylafax-Client/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Fax-Hylafax-Client
+# Date created: September 10 2005
+# Whom: Tony Shadwick <tshadwick@oss-solutions.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Fax-Hylafax-Client
+PORTVERSION= 1.01
+CATEGORIES= comms perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Fax
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tshadwick@oss-solutions.com
+COMMENT= A simple Perl client for the HylaFAX fax server
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net
+
+PERL_CONFIGURE= yes
+
+MAN3= Fax::Hylafax::Client.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or superior. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/p5-Fax-Hylafax-Client/distinfo b/comms/p5-Fax-Hylafax-Client/distinfo
new file mode 100644
index 000000000000..f7e9d3adcbbf
--- /dev/null
+++ b/comms/p5-Fax-Hylafax-Client/distinfo
@@ -0,0 +1,2 @@
+MD5 (Fax-Hylafax-Client-1.01.tar.gz) = 8585799f7832af57f3b942d47277ea94
+SIZE (Fax-Hylafax-Client-1.01.tar.gz) = 8124
diff --git a/comms/p5-Fax-Hylafax-Client/pkg-descr b/comms/p5-Fax-Hylafax-Client/pkg-descr
new file mode 100644
index 000000000000..05992ab02cde
--- /dev/null
+++ b/comms/p5-Fax-Hylafax-Client/pkg-descr
@@ -0,0 +1,9 @@
+Fax::Hylafax::Client is a simple Perl client for the HylaFAX fax server
+(www.hylafax.org). It communicates with the server directly through the FTP
+protocol and thus does not require any HylaFAX software component to be
+installed on the client machine.
+
+WWW: http://search.cpan.org/~arak/Fax-Hylafax-Client-1.01/
+
+- Tony Shadwick, OSS Solutions
+tshadwick@oss-solutions.com
diff --git a/comms/p5-Fax-Hylafax-Client/pkg-plist b/comms/p5-Fax-Hylafax-Client/pkg-plist
new file mode 100644
index 000000000000..2d68dc813754
--- /dev/null
+++ b/comms/p5-Fax-Hylafax-Client/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Fax/Hylafax/Client.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fax/Hylafax/Client/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Fax/Hylafax 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Fax 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fax/Hylafax/Client 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fax/Hylafax 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Fax 2>/dev/null || true