aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/aureal-kmod/Makefile2
-rw-r--r--audio/aureal-kmod/files/pkg-message.in4
-rw-r--r--java/jboss3/Makefile3
-rw-r--r--java/jboss4/Makefile3
-rw-r--r--mail/assp/Makefile2
-rw-r--r--mail/dk-milter/Makefile2
-rw-r--r--net/cvsup-mirror/Makefile2
-rw-r--r--net/cvsup-mirror/files/update.sh.in4
-rw-r--r--net/freeradius2/Makefile1
-rw-r--r--net/freeradius2/files/pkg-message.in6
-rw-r--r--net/openldap23-server/Makefile1
-rw-r--r--net/openldap23-server/files/pkg-message.in4
-rw-r--r--net/openldap23-server/pkg-plist4
-rw-r--r--net/openldap24-server/Makefile1
-rw-r--r--net/openldap24-server/files/pkg-message.in4
-rw-r--r--net/openldap24-server/pkg-plist2
-rw-r--r--security/openssh-portable/Makefile2
-rw-r--r--security/openvpn-devel/Makefile2
-rw-r--r--security/openvpn-devel/files/pkg-message.in2
-rw-r--r--security/openvpn/Makefile2
-rw-r--r--security/openvpn/files/pkg-message.in2
-rw-r--r--security/openvpn20/Makefile2
-rw-r--r--security/openvpn20/files/pkg-message.in2
-rw-r--r--sysutils/syslog-ng2/Makefile1
-rw-r--r--sysutils/syslog-ng2/files/pkg-message.in2
25 files changed, 24 insertions, 38 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index 6242d8c33eb8..e767fd2d24d7 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -27,7 +27,7 @@ KMODDIR_REL= ${KMODDIR:S%${PREFIX}/%%}
USE_RC_SUBR= aureal
SUB_FILES= pkg-message
-SUB_LIST= KMODDIR=${KMODDIR} RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
+SUB_LIST= KMODDIR=${KMODDIR}
PLIST_SUB= KMODDIR=${KMODDIR_REL}
diff --git a/audio/aureal-kmod/files/pkg-message.in b/audio/aureal-kmod/files/pkg-message.in
index 9f1dddb45e9d..1de583090000 100644
--- a/audio/aureal-kmod/files/pkg-message.in
+++ b/audio/aureal-kmod/files/pkg-message.in
@@ -7,11 +7,11 @@ aureal_enable="YES"
To load the driver run (as root):
-%%PREFIX%%/etc/rc.d/aureal%%RC_SUBR_SUFFIX%% start
+%%PREFIX%%/etc/rc.d/aureal start
To unload it:
-%%PREFIX%%/etc/rc.d/aureal%%RC_SUBR_SUFFIX%% stop
+%%PREFIX%%/etc/rc.d/aureal stop
It'll also load the driver automatically when the system is started.
diff --git a/java/jboss3/Makefile b/java/jboss3/Makefile
index 4355c4948987..0b8198cef6f4 100644
--- a/java/jboss3/Makefile
+++ b/java/jboss3/Makefile
@@ -36,8 +36,7 @@ APP_SHORTNAME= ${UNIQUENAME}
CONTROL_SCRIPT_NAME= ${APP_SHORTNAME}ctl
CONTROL_SCRIPT= ${PREFIX}/bin/${CONTROL_SCRIPT_NAME}
CONTROL_SCRIPT_MANPAGE_TITLE= ${CONTROL_SCRIPT_NAME:U}
-STARTUP_SCRIPT_NAME= ${APP_SHORTNAME}${RC_SUBR_SUFFIX}
-STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${STARTUP_SCRIPT_NAME}
+STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${USE_RC_SUBR}
USER= www
GROUP= www
STDOUT_LOG= ${LOG_DIR}/stdout.log
diff --git a/java/jboss4/Makefile b/java/jboss4/Makefile
index 4fd1e78ee3df..86059eddd993 100644
--- a/java/jboss4/Makefile
+++ b/java/jboss4/Makefile
@@ -36,8 +36,7 @@ APP_SHORTNAME= ${UNIQUENAME}
CONTROL_SCRIPT_NAME= ${APP_SHORTNAME}ctl
CONTROL_SCRIPT= ${PREFIX}/bin/${CONTROL_SCRIPT_NAME}
CONTROL_SCRIPT_MANPAGE_TITLE= ${CONTROL_SCRIPT_NAME:U}
-STARTUP_SCRIPT_NAME= ${APP_SHORTNAME}${RC_SUBR_SUFFIX}
-STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${STARTUP_SCRIPT_NAME}
+STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${USE_RC_SUBR}
USER= www
GROUP= www
STDOUT_LOG= ${LOG_DIR}/stdout.log
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index 72048ee30621..a0030288a520 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -58,7 +58,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${DISTNAME}/${PORTNAME:U}
.include <bsd.port.pre.mk>
-SUB_LIST+= RC_SCRIPT=${RC_SCRIPT}${RC_SUBR_SUFFIX}
+SUB_LIST+= RC_SCRIPT=${RC_SCRIPT}
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS+= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
diff --git a/mail/dk-milter/Makefile b/mail/dk-milter/Makefile
index 6812525b3200..40ff67453939 100644
--- a/mail/dk-milter/Makefile
+++ b/mail/dk-milter/Makefile
@@ -59,7 +59,7 @@ SITE_SUB+= -e '\|-static|s|%%STATIC%%||g'
SITE_SUB+= -e '\|-static|s|%%STATIC%%|dnl |g'
.endif
-SUB_LIST= "RC_SCRIPT=${PREFIX}/etc/rc.d/${USE_RC_SUBR:S/.sh$//}${RC_SUBR_SUFFIX}"
+SUB_LIST= "RC_SCRIPT=${PREFIX}/etc/rc.d/${USE_RC_SUBR:S/.sh$//}"
.if defined(WITH_DEBUG)
SITE_SUB+= -e '\|confOPTIMIZE.*-g|s/^dnl //g'
diff --git a/net/cvsup-mirror/Makefile b/net/cvsup-mirror/Makefile
index 634c0265ede1..cd4b94f01fa2 100644
--- a/net/cvsup-mirror/Makefile
+++ b/net/cvsup-mirror/Makefile
@@ -29,8 +29,6 @@ distrib=${base}/sup.client/distrib
.include <bsd.port.pre.mk>
-SUB_LIST+= CVSUPD="cvsupd${RC_SUBR_SUFFIX}"
-
do-extract:
@test -d ${WRKSRC} || ${MKDIR} ${WRKSRC}
diff --git a/net/cvsup-mirror/files/update.sh.in b/net/cvsup-mirror/files/update.sh.in
index 46b78b275390..965ab0df9437 100644
--- a/net/cvsup-mirror/files/update.sh.in
+++ b/net/cvsup-mirror/files/update.sh.in
@@ -45,9 +45,9 @@ su -f -m ${cuser} -c \
if [ ${ok} = yes ]; then
if [ -f ${base}/.start_server ]; then
- if [ -x ${startup}/%%CVSUPD%% ]; then
+ if [ -x ${startup}/cvsupd ]; then
echo -n "Starting the server:"
- /bin/sh ${startup}/%%CVSUPD%% start
+ /bin/sh ${startup}/cvsupd start
echo "."
fi
rm -f ${base}/.start_server
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index f079202293b8..19e5c3f2de2b 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -309,7 +309,6 @@ SUB_LIST+= USER="${RADIUS_USER}" \
RADDB="${PREFIX}/etc/raddb" \
LOGDIR="${LOGDIR}" \
LIBDIR="${PREFIX}/${FREERADIUS_LIBDIR}" \
- RC_SUBR_SUFFIX="${RC_SUBR_SUFFIX}"
SUB_FILES+= pkg-install pkg-deinstall pkg-message
MAN1= radclient.1 radeapclient.1 radlast.1 radtest.1 radwho.1 \
diff --git a/net/freeradius2/files/pkg-message.in b/net/freeradius2/files/pkg-message.in
index 34bceece5c1f..0b72f6bd99c3 100644
--- a/net/freeradius2/files/pkg-message.in
+++ b/net/freeradius2/files/pkg-message.in
@@ -27,16 +27,16 @@ radiusd_flags="-d /path/to/raddb"
To start the server in normal (daemon) mode, run:
-%%PREFIX%%/etc/rc.d/radiusd%%RC_SUBR_SUFFIX%% start
+%%PREFIX%%/etc/rc.d/radiusd start
and to stop the server, run:
-%%PREFIX%%/etc/rc.d/radiusd%%RC_SUBR_SUFFIX%% stop
+%%PREFIX%%/etc/rc.d/radiusd stop
To start the server in debugging mode, run:
-%%PREFIX%%/etc/rc.d/radiusd%%RC_SUBR_SUFFIX%% debug
+%%PREFIX%%/etc/rc.d/radiusd debug
You are advised to make cautious changes to the configuration, and to test
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 6bbf0999afb2..984d932e8f30 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -387,7 +387,6 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
.include "${FILESDIR}/manpages"
.else
SUB_LIST+= RC_DIR=${PREFIX} \
- RC_SUFX=${RC_SUBR_SUFFIX} \
LDAP_RUN_DIR=${LDAP_RUN_DIR} \
DATABASEDIR=${DATABASEDIR}
.endif
diff --git a/net/openldap23-server/files/pkg-message.in b/net/openldap23-server/files/pkg-message.in
index bdda2435ce87..20b5fba0c25a 100644
--- a/net/openldap23-server/files/pkg-message.in
+++ b/net/openldap23-server/files/pkg-message.in
@@ -10,7 +10,7 @@ to suit your needs and add the following lines to /etc/rc.conf:
slapd_sockets="/var/run/openldap/ldapi"
Then start the server with
- %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% start
+ %%PREFIX%%/etc/rc.d/slap start
or reboot.
Try `man slapd' and the online manual at
@@ -18,6 +18,6 @@ Try `man slapd' and the online manual at
for more information.
slapd runs under a non-privileged user id (by default `ldap'),
-see %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% for more information.
+see %%PREFIX%%/etc/rc.d/slapd for more information.
************************************************************
diff --git a/net/openldap23-server/pkg-plist b/net/openldap23-server/pkg-plist
index 1bbde4147a94..1cdbcd4ace2a 100644
--- a/net/openldap23-server/pkg-plist
+++ b/net/openldap23-server/pkg-plist
@@ -1,6 +1,6 @@
@comment $FreeBSD$
-@unexec %%RC_DIR%%/etc/rc.d/slapd%%RC_SUFX%% stop 2>&1 >/dev/null || true
-%%SLURPD%%@unexec %%RC_DIR%%/etc/rc.d/slurpd%%RC_SUFX%% stop 2>&1 >/dev/null || true
+@unexec %%RC_DIR%%/etc/rc.d/slapd stop 2>&1 >/dev/null || true
+%%SLURPD%%@unexec %%RC_DIR%%/etc/rc.d/slurpd stop 2>&1 >/dev/null || true
etc/openldap/schema/README
etc/openldap/schema/core.ldif
etc/openldap/schema/openldap.ldif
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index d3fb5170b4c8..205c12ae0275 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -448,7 +448,6 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
.include "${FILESDIR}/manpages"
.else
SUB_LIST+= RC_DIR=${PREFIX} \
- RC_SUFX=${RC_SUBR_SUFFIX} \
LDAP_RUN_DIR=${LDAP_RUN_DIR} \
DATABASEDIR=${DATABASEDIR}
.endif
diff --git a/net/openldap24-server/files/pkg-message.in b/net/openldap24-server/files/pkg-message.in
index bdda2435ce87..57483b1703b4 100644
--- a/net/openldap24-server/files/pkg-message.in
+++ b/net/openldap24-server/files/pkg-message.in
@@ -10,7 +10,7 @@ to suit your needs and add the following lines to /etc/rc.conf:
slapd_sockets="/var/run/openldap/ldapi"
Then start the server with
- %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% start
+ %%PREFIX%%/etc/rc.d/slapd start
or reboot.
Try `man slapd' and the online manual at
@@ -18,6 +18,6 @@ Try `man slapd' and the online manual at
for more information.
slapd runs under a non-privileged user id (by default `ldap'),
-see %%PREFIX%%/etc/rc.d/slapd%%RC_SUFX%% for more information.
+see %%PREFIX%%/etc/rc.d/slapd for more information.
************************************************************
diff --git a/net/openldap24-server/pkg-plist b/net/openldap24-server/pkg-plist
index d95a2980a45b..e67669660462 100644
--- a/net/openldap24-server/pkg-plist
+++ b/net/openldap24-server/pkg-plist
@@ -1,5 +1,5 @@
@comment $FreeBSD$
-@unexec %%RC_DIR%%/etc/rc.d/slapd%%RC_SUFX%% stop 2>&1 >/dev/null || true
+@unexec %%RC_DIR%%/etc/rc.d/slapd stop 2>&1 >/dev/null || true
etc/openldap/schema/README
etc/openldap/schema/core.ldif
etc/openldap/schema/cosine.ldif
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 34f910f89977..b17fcf6d52f8 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -215,7 +215,7 @@ SUB_LIST+= ETCSSH="${ETCSSH}"
PLIST_SUB+= EMPTYDIR="${EMPTYDIR}"
CONFIGURE_ARGS+= --sysconfdir=${ETCSSH} --with-privsep-path=${EMPTYDIR}
-RC_SCRIPT_NAME= openssh${RC_SUBR_SUFFIX}
+RC_SCRIPT_NAME= openssh
post-extract:
.if defined(OPENSSH_SNAPSHOT)
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 4b10c7612b37..4df7afd565de 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -38,8 +38,6 @@ SUB_LIST+= OSVERSION=${OSVERSION}
.include <bsd.port.pre.mk>
-SUB_LIST+= RCSFX=${RC_SUBR_SUFFIX}
-
.ifdef (LOG_OPENVPN)
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
diff --git a/security/openvpn-devel/files/pkg-message.in b/security/openvpn-devel/files/pkg-message.in
index 5abc9aad90e0..68de324afdb5 100644
--- a/security/openvpn-devel/files/pkg-message.in
+++ b/security/openvpn-devel/files/pkg-message.in
@@ -1,6 +1,6 @@
### ------------------------------------------------------------------------
### Edit /etc/rc.conf[.local] to start OpenVPN automatically at system
-### startup. See %%PREFIX%%/etc/rc.d/openvpn%%RCSFX%% for details.
+### startup. See %%PREFIX%%/etc/rc.d/openvpn for details.
### ------------------------------------------------------------------------
### For compatibility notes when interoperating with older OpenVPN
### versions, please, see <http://openvpn.net/relnotes.html>
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index f1c5cf8d0007..8239c8c12887 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -36,8 +36,6 @@ SUB_LIST+= OSVERSION=${OSVERSION}
.include <bsd.port.pre.mk>
-SUB_LIST+= RCSFX=${RC_SUBR_SUFFIX}
-
.ifdef (LOG_OPENVPN)
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
diff --git a/security/openvpn/files/pkg-message.in b/security/openvpn/files/pkg-message.in
index f79da215e039..57da107dbe67 100644
--- a/security/openvpn/files/pkg-message.in
+++ b/security/openvpn/files/pkg-message.in
@@ -1,6 +1,6 @@
### ------------------------------------------------------------------------
### Edit /etc/rc.conf[.local] to start OpenVPN automatically at system
-### startup. See %%PREFIX%%/etc/rc.d/openvpn%%RCSFX%% for details.
+### startup. See %%PREFIX%%/etc/rc.d/openvpn for details.
### ------------------------------------------------------------------------
### For compatibility notes when interoperating with older OpenVPN
### versions, please, see <http://openvpn.net/relnotes.html>
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index b13eca2c3972..2c659a637367 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -35,8 +35,6 @@ SUB_LIST+= OSVERSION=${OSVERSION}
.include <bsd.port.pre.mk>
-SUB_LIST+= RCSFX=${RC_SUBR_SUFFIX}
-
.ifdef (LOG_OPENVPN)
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
diff --git a/security/openvpn20/files/pkg-message.in b/security/openvpn20/files/pkg-message.in
index 4aec34fd990b..766203f9fc76 100644
--- a/security/openvpn20/files/pkg-message.in
+++ b/security/openvpn20/files/pkg-message.in
@@ -1,6 +1,6 @@
### ------------------------------------------------------------------------
### Edit /etc/rc.conf[.local] to start OpenVPN automatically at system
-### startup. See %%PREFIX%%/etc/rc.d/openvpn%%RCSFX%% for details.
+### startup. See %%PREFIX%%/etc/rc.d/openvpn for details.
### ------------------------------------------------------------------------
### For compatibility information, see <http://openvpn.net/relnotes.html>
### ------------------------------------------------------------------------
diff --git a/sysutils/syslog-ng2/Makefile b/sysutils/syslog-ng2/Makefile
index d921c93286dd..bd8b786ce124 100644
--- a/sysutils/syslog-ng2/Makefile
+++ b/sysutils/syslog-ng2/Makefile
@@ -24,7 +24,6 @@ USE_RC_SUBR= syslog-ng.sh
GNU_CONFIGURE= yes
USE_GNOME= glib20
SUB_FILES= pkg-message
-SUB_LIST= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
diff --git a/sysutils/syslog-ng2/files/pkg-message.in b/sysutils/syslog-ng2/files/pkg-message.in
index 3a30820d764f..7be559337413 100644
--- a/sysutils/syslog-ng2/files/pkg-message.in
+++ b/sysutils/syslog-ng2/files/pkg-message.in
@@ -25,5 +25,5 @@ syslog-ng is now installed! To replace FreeBSD's standard syslogd
5. Start syslog-ng:
- %%PREFIX%%/etc/rc.d/syslog-ng%%RC_SUBR_SUFFIX%% start
+ %%PREFIX%%/etc/rc.d/syslog-ng start