aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/pstngw/Makefile8
-rw-r--r--net/callgen/Makefile8
-rw-r--r--net/callgen323/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/comms/pstngw/Makefile b/comms/pstngw/Makefile
index d2c5d30695c4..b38a9c0c3959 100644
--- a/comms/pstngw/Makefile
+++ b/comms/pstngw/Makefile
@@ -26,7 +26,13 @@ THE_MACHTYPE= ${ARCH:S/i386/x86/}
PLIST_FILES= bin/pstngw
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/pstngw ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/callgen/Makefile b/net/callgen/Makefile
index 0a1c5e80ab32..63c96ae919ab 100644
--- a/net/callgen/Makefile
+++ b/net/callgen/Makefile
@@ -24,7 +24,13 @@ THE_MACHTYPE= ${ARCH:S/i386/x86/}
PLIST_FILES= bin/callgen323
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/callgen323 ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/callgen323/Makefile b/net/callgen323/Makefile
index 0a1c5e80ab32..63c96ae919ab 100644
--- a/net/callgen323/Makefile
+++ b/net/callgen323/Makefile
@@ -24,7 +24,13 @@ THE_MACHTYPE= ${ARCH:S/i386/x86/}
PLIST_FILES= bin/callgen323
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64 (shared libraries must be compiled with -fPIC)"
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_d/callgen323 ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>