aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/ctorrent/Makefile2
-rw-r--r--net-p2p/ctorrent/files/patch-ctorrent.cpp17
2 files changed, 18 insertions, 1 deletions
diff --git a/net-p2p/ctorrent/Makefile b/net-p2p/ctorrent/Makefile
index fc36f106a4fc..82c22f23026b 100644
--- a/net-p2p/ctorrent/Makefile
+++ b/net-p2p/ctorrent/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ctorrent
PORTVERSION= 3.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= http://www.rahul.net/dholmes/ctorrent/
DISTNAME= ${PORTNAME}-dnh${PORTVERSION}
diff --git a/net-p2p/ctorrent/files/patch-ctorrent.cpp b/net-p2p/ctorrent/files/patch-ctorrent.cpp
new file mode 100644
index 000000000000..9ff1f1350f8e
--- /dev/null
+++ b/net-p2p/ctorrent/files/patch-ctorrent.cpp
@@ -0,0 +1,17 @@
+--- ctorrent.cpp.orig 2009-11-13 10:20:39.377057366 +0300
++++ ctorrent.cpp 2009-11-13 10:21:01.916290662 +0300
+@@ -98,11 +98,11 @@
+ exit(0);
+ }
+
+- if( arg_daemon ) CONSOLE.Daemonize();
+-
+ if( !arg_flg_exam_only && (!arg_flg_check_only || arg_flg_force_seed_mode) )
+ if( arg_ctcs ) CTCS.Initial();
+
++ if( arg_daemon ) CONSOLE.Daemonize();
++
+ if( BTCONTENT.InitialFromMI(arg_metainfo_file, arg_save_as) < 0){
+ CONSOLE.Warning(1, "error, initial meta info failed.");
+ exit(1);
+