aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile3
-rw-r--r--astro/p5-Astro-SpaceTrack/Makefile3
-rw-r--r--comms/atslog/Makefile2
-rw-r--r--comms/p5-Device-Modem/Makefile9
-rw-r--r--comms/p5-Device-SerialPort/Makefile3
-rw-r--r--comms/p5-Fax-Hylafax-Client/Makefile3
-rw-r--r--shells/p5-Term-ShellUI/Makefile3
-rw-r--r--shells/zoidberg/Makefile3
-rw-r--r--x11-fonts/p5-Font-AFM/Makefile3
-rw-r--r--x11-fonts/p5-Font-TTF/Makefile3
-rw-r--r--x11-fonts/p5-Font-TTFMetrics/Makefile9
-rw-r--r--x11/bricons/Makefile4
-rw-r--r--x11/p5-X11-GUITest/Makefile9
-rw-r--r--x11/p5-X11-Protocol/Makefile9
14 files changed, 31 insertions, 35 deletions
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
index 9c1bd940a413..a31dfe0f3f57 100644
--- a/astro/p5-Astro-FITS-CFITSIO/Makefile
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl extension for using the cfitsio library
LIB_DEPENDS= cfitsio:${PORTSDIR}/astro/cfitsio
CONFIGURE_ENV= CFITSIO=${LOCALBASE}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Astro::FITS::CFITSIO.3
diff --git a/astro/p5-Astro-SpaceTrack/Makefile b/astro/p5-Astro-SpaceTrack/Makefile
index 3fae034f7740..8343c143584f 100644
--- a/astro/p5-Astro-SpaceTrack/Makefile
+++ b/astro/p5-Astro-SpaceTrack/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= -y
MAN1= SpaceTrack.1
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index 50d1e6da4a94..1c107f26258f 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -19,7 +19,7 @@ WWW_DESC= Install web interface
WWWGD_DESC= Graphic reports
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
USE_RC_SUBR= ${PORTNAME}d
PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL LICENSE TODO UPDATING USAGE
SUB_FILES= pkg-message
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
index c47e989c4bbc..4e9c5f34611b 100644
--- a/comms/p5-Device-Modem/Makefile
+++ b/comms/p5-Device-Modem/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Device-Modem
-# Date created: 22 July 2003
-# Whom: Anders Nordby <anders@FreeBSD.org>
-#
+# Created by: Anders Nordby <anders@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Device-Modem
PORTVERSION= 1.56
@@ -17,7 +13,8 @@ COMMENT= Perl class to interface generic modems (AT-compliant)
BUILD_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
RUN_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Device::Modem.3 \
Device::Modem::FAQ.3 \
diff --git a/comms/p5-Device-SerialPort/Makefile b/comms/p5-Device-SerialPort/Makefile
index 548a0c956d41..a44d523fcdd2 100644
--- a/comms/p5-Device-SerialPort/Makefile
+++ b/comms/p5-Device-SerialPort/Makefile
@@ -11,7 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module for simple serial port control
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= modemtest.1
MAN3= Device::SerialPort.3
diff --git a/comms/p5-Fax-Hylafax-Client/Makefile b/comms/p5-Fax-Hylafax-Client/Makefile
index 8f57c4ae5e84..3e6f751e9733 100644
--- a/comms/p5-Fax-Hylafax-Client/Makefile
+++ b/comms/p5-Fax-Hylafax-Client/Makefile
@@ -13,7 +13,8 @@ COMMENT= Simple Perl client for the HylaFAX fax server
BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Fax::Hylafax::Client.3
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index 19d9eed9ac22..6df0545e8ab4 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -14,7 +14,8 @@ COMMENT= Fully-featured shell-like command line environment
BUILD_DEPENDS= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
RUN_DEPENDS= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Term::ShellUI.3 \
Text::Shellwords::Cursor.3
diff --git a/shells/zoidberg/Makefile b/shells/zoidberg/Makefile
index dbff47923069..bfdd9bef4b53 100644
--- a/shells/zoidberg/Makefile
+++ b/shells/zoidberg/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Exporter-Tidy>=0:${PORTSDIR}/devel/p5-Exporter-Tidy \
p5-Term-ReadLine-Zoid>=0:${PORTSDIR}/devel/p5-Term-ReadLine-Zoid \
p5-Env-PS1>=0:${PORTSDIR}/devel/p5-Env-PS1
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
CONFIGURE_ARGS= install_path=share="${DATADIR}" \
install_path=share="${ETCDIR}"
diff --git a/x11-fonts/p5-Font-AFM/Makefile b/x11-fonts/p5-Font-AFM/Makefile
index e46281187572..003291d15bd8 100644
--- a/x11-fonts/p5-Font-AFM/Makefile
+++ b/x11-fonts/p5-Font-AFM/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to Adobe font metrics files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Font::AFM.3
diff --git a/x11-fonts/p5-Font-TTF/Makefile b/x11-fonts/p5-Font-TTF/Makefile
index ba80f6d9b892..d055854f27de 100644
--- a/x11-fonts/p5-Font-TTF/Makefile
+++ b/x11-fonts/p5-Font-TTF/Makefile
@@ -14,7 +14,8 @@ LICENSE= ART20
BUILD_DEPENDS= p5-IO-String>0:${PORTSDIR}/devel/p5-IO-String
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= \
Font::TTF.3 \
diff --git a/x11-fonts/p5-Font-TTFMetrics/Makefile b/x11-fonts/p5-Font-TTFMetrics/Makefile
index 1a9fe2a6e132..4499f9795c33 100644
--- a/x11-fonts/p5-Font-TTFMetrics/Makefile
+++ b/x11-fonts/p5-Font-TTFMetrics/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Font-TTFMetrics
-# Date created: 18 Mar 2007
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Font-TTFMetrics
PORTVERSION= 0.1
@@ -16,6 +12,7 @@ COMMENT= A parser for the TTF file
MAN3= Font::TTFMetrics.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/x11/bricons/Makefile b/x11/bricons/Makefile
index 0bce7f4e6984..2a7ec5147d99 100644
--- a/x11/bricons/Makefile
+++ b/x11/bricons/Makefile
@@ -14,8 +14,8 @@ COMMENT= Quick start up utility for applications on an X display
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= imake
-USE_PERL5_BUILD=yes
+USES= imake perl5
+USE_PERL5= build
USE_XORG= xaw
MAKE_JOBS_SAFE= yes
diff --git a/x11/p5-X11-GUITest/Makefile b/x11/p5-X11-GUITest/Makefile
index 163b16d0080d..53d4e30d3d07 100644
--- a/x11/p5-X11-GUITest/Makefile
+++ b/x11/p5-X11-GUITest/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: X11-GUITest
-# Date created: Oct 28, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= X11-GUITest
PORTVERSION= 0.25
@@ -16,7 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Provides GUI testing/interaction facilities
USE_XORG= x11 xt xext xtst
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= X11::GUITest.3
diff --git a/x11/p5-X11-Protocol/Makefile b/x11/p5-X11-Protocol/Makefile
index 7dfb1bfbde47..6bcadb942909 100644
--- a/x11/p5-X11-Protocol/Makefile
+++ b/x11/p5-X11-Protocol/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: X11-Protocol
-# Date created: Mon Jan 1 21:49:44 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= X11-Protocol
PORTVERSION= 0.56
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module that provides an interface roughly equivalent to Xlib
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= X11::Auth.3 \
X11::Keysyms.3 \