aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-Encoding/Makefile28
-rw-r--r--devel/p5-Term-Encoding/distinfo3
-rw-r--r--devel/p5-Term-Encoding/pkg-descr6
-rw-r--r--devel/p5-Term-Encoding/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eee3e63b11e3..103100b7fb5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1289,6 +1289,7 @@
SUBDIR += p5-Term-ANSIScreen
SUBDIR += p5-Term-Animation
SUBDIR += p5-Term-CallEditor
+ SUBDIR += p5-Term-Encoding
SUBDIR += p5-Term-ProgressBar
SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
diff --git a/devel/p5-Term-Encoding/Makefile b/devel/p5-Term-Encoding/Makefile
new file mode 100644
index 000000000000..461ee1b08b2c
--- /dev/null
+++ b/devel/p5-Term-Encoding/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Term-Encoding
+# Date created: 2006-07-13
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Encoding
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Detect encoding of the current terminal
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Encoding.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+IGNORE= requires perl 5.7.2 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Term-Encoding/distinfo b/devel/p5-Term-Encoding/distinfo
new file mode 100644
index 000000000000..283ec03fb748
--- /dev/null
+++ b/devel/p5-Term-Encoding/distinfo
@@ -0,0 +1,3 @@
+MD5 (Term-Encoding-0.01.tar.gz) = b202cccb3a559eea63114e889a495b48
+SHA256 (Term-Encoding-0.01.tar.gz) = 098fad4fbcf12487bb3d792dc0ccea8ab901134512d7c9e834d6559fcefc0b3d
+SIZE (Term-Encoding-0.01.tar.gz) = 11272
diff --git a/devel/p5-Term-Encoding/pkg-descr b/devel/p5-Term-Encoding/pkg-descr
new file mode 100644
index 000000000000..e4afd9f1fb5b
--- /dev/null
+++ b/devel/p5-Term-Encoding/pkg-descr
@@ -0,0 +1,6 @@
+Term::Encoding is a simple module to detect an encoding the current
+terminal expects, in various ways.
+
+Author: Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+ Audrey Tang <audreyt@audreyt.org>
+WWW: http://search.cpan.org/dist/Term-Encoding/
diff --git a/devel/p5-Term-Encoding/pkg-plist b/devel/p5-Term-Encoding/pkg-plist
new file mode 100644
index 000000000000..47de73e66418
--- /dev/null
+++ b/devel/p5-Term-Encoding/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Encoding/.packlist
+%%SITE_PERL%%/Term/Encoding.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Encoding
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term
+@dirrmtry %%SITE_PERL%%/Term