aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libevent/Makefile8
-rw-r--r--www/mod_auth_kerb/Makefile4
-rw-r--r--www/mod_auth_kerb2/Makefile4
3 files changed, 15 insertions, 1 deletions
diff --git a/devel/libevent/Makefile b/devel/libevent/Makefile
index 7b409e9686a3..3dfa18109149 100644
--- a/devel/libevent/Makefile
+++ b/devel/libevent/Makefile
@@ -37,7 +37,13 @@ MLINKS= event.3 event_init.3 event.3 event_dispatch.3 event.3 event_loop.3 \
event.3 evbuffer_add_printf.3 event.3 evbuffer_drain.3 \
event.3 evbuffer_write.3 event.3 evbuffer_read.3 event.3 evbuffer_find.3
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700014
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,CFLAGS =,CFLAGS +=,' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
index aa18a416c1f2..4c03da6334dd 100644
--- a/www/mod_auth_kerb/Makefile
+++ b/www/mod_auth_kerb/Makefile
@@ -38,6 +38,10 @@ OPTIONS+= off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700014
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
.if exists(${PREFIX}/sbin/apxs)
APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
.else
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index aa18a416c1f2..4c03da6334dd 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -38,6 +38,10 @@ OPTIONS+= off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700014
+BROKEN= "Does not compile on FreeBSD >= 7.0"
+.endif
+
.if exists(${PREFIX}/sbin/apxs)
APACHE_MODULE_DIR!=${PREFIX}/sbin/apxs -q LIBEXECDIR
.else