aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-simple-rss/Makefile20
-rw-r--r--www/rubygem-simple-rss/distinfo3
-rw-r--r--www/rubygem-simple-rss/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 16b7942efb7e..67a7761009ea 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1392,6 +1392,7 @@
SUBDIR += rubygem-rubyfulsoup
SUBDIR += rubygem-scrapi
SUBDIR += rubygem-scrubyt
+ SUBDIR += rubygem-simple-rss
SUBDIR += rubygem-sinatra
SUBDIR += rubygem-staticmatic
SUBDIR += rubygem-taggable
diff --git a/www/rubygem-simple-rss/Makefile b/www/rubygem-simple-rss/Makefile
new file mode 100644
index 000000000000..820b9dff80d0
--- /dev/null
+++ b/www/rubygem-simple-rss/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: rubygem-simple-rss
+# Date created: 2009-07-13
+# Whom: TERAMOTO Masahiro <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simple-rss
+PORTVERSION= 1.2
+CATEGORIES= www textproc rubygems
+MASTER_SITES= RF
+
+MAINTAINER= markun@onohara.to
+COMMENT= A simple, flexible, extensible, and liberal RSS and Atom reader for Ruby.
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-simple-rss/distinfo b/www/rubygem-simple-rss/distinfo
new file mode 100644
index 000000000000..d7e2d7b8893e
--- /dev/null
+++ b/www/rubygem-simple-rss/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/simple-rss-1.2.gem) = f7213fa4a573d81d3d72d2b6f7cd97fb
+SHA256 (rubygem/simple-rss-1.2.gem) = f24a034d4d6c98367d5240eb9bcdeb71df6078516a615ada4210ea58538a089b
+SIZE (rubygem/simple-rss-1.2.gem) = 31232
diff --git a/www/rubygem-simple-rss/pkg-descr b/www/rubygem-simple-rss/pkg-descr
new file mode 100644
index 000000000000..796dea3c8298
--- /dev/null
+++ b/www/rubygem-simple-rss/pkg-descr
@@ -0,0 +1,5 @@
+Simple RSS is a simple, flexible, extensible, and liberal RSS and Atom reader
+for Ruby. It is designed to be backwards compatible with the standard RSS
+parser, but will never do RSS generation.
+
+WWW: http://rubyforge.org/projects/simple-rss/