aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Lexical-Persistence/Makefile32
-rw-r--r--devel/p5-Lexical-Persistence/distinfo3
-rw-r--r--devel/p5-Lexical-Persistence/pkg-descr19
-rw-r--r--devel/p5-Lexical-Persistence/pkg-plist5
5 files changed, 60 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8f5e2c421455..f488486ad364 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1195,6 +1195,7 @@
SUBDIR += p5-Iterator-Misc
SUBDIR += p5-Iterator-Util
SUBDIR += p5-Java
+ SUBDIR += p5-Lexical-Persistence
SUBDIR += p5-List-Cycle
SUBDIR += p5-List-Group
SUBDIR += p5-List-Permutor
diff --git a/devel/p5-Lexical-Persistence/Makefile b/devel/p5-Lexical-Persistence/Makefile
new file mode 100644
index 000000000000..0eb13b0e7bea
--- /dev/null
+++ b/devel/p5-Lexical-Persistence/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Lexical-Persistence
+# Date created: 01 Jan 2007
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lexical-Persistence
+PORTVERSION= 0.96
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lexical
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Persistent lexical variable values for arbitrary calls
+
+BUILD_DEPENDS= p5-Devel-LexAlias>=0.04:${PORTSDIR}/devel/p5-Devel-LexAlias \
+ p5-PadWalker>=1.1:${PORTSDIR}/devel/p5-PadWalker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Lexical::Persistence.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Lexical-Persistence/distinfo b/devel/p5-Lexical-Persistence/distinfo
new file mode 100644
index 000000000000..1963af5a1546
--- /dev/null
+++ b/devel/p5-Lexical-Persistence/distinfo
@@ -0,0 +1,3 @@
+MD5 (Lexical-Persistence-0.96.tar.gz) = fba4489039f674e5b164abc97b30ca60
+SHA256 (Lexical-Persistence-0.96.tar.gz) = 14b824382aece07261379d0ceb34d466cb6f64e1eebd0ea1258d624da7b8de5f
+SIZE (Lexical-Persistence-0.96.tar.gz) = 9645
diff --git a/devel/p5-Lexical-Persistence/pkg-descr b/devel/p5-Lexical-Persistence/pkg-descr
new file mode 100644
index 000000000000..d24326c5ccfc
--- /dev/null
+++ b/devel/p5-Lexical-Persistence/pkg-descr
@@ -0,0 +1,19 @@
+Lexical::Persistence does a few things, all related. Note that all the
+behaviors listed here are the defaults. Subclasses can override nearly
+every aspect of Lexical::Persistence's behavior.
+
+Lexical::Persistence lets your code access persistent data through lexical
+variables. This example prints "some value" because the value of $x
+perists in the $lp object between setter() and getter().
+
+ use Lexical::Persistence;
+
+ my $lp = Lexical::Persistence->new();
+ $lp->call(\&setter);
+ $lp->call(\&getter);
+
+ sub setter { my $x = "some value" }
+ sub getter { print my $x, "\n" }
+
+WWW: http://search.cpan.org/dist/Lexical-Persistence
+Author: Rocco Caputo <rcaputo@cpan.org>
diff --git a/devel/p5-Lexical-Persistence/pkg-plist b/devel/p5-Lexical-Persistence/pkg-plist
new file mode 100644
index 000000000000..3bdc29669f37
--- /dev/null
+++ b/devel/p5-Lexical-Persistence/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Lexical/Persistence.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Lexical/Persistence/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lexical/Persistence
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Lexical
+@dirrmtry %%SITE_PERL%%/Lexical