aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gettext/Makefile17
-rw-r--r--devel/gettext/distinfo2
-rw-r--r--devel/gettext/files/patch-Makefile.in11
-rw-r--r--devel/gettext/files/patch-ad18
-rw-r--r--devel/gettext/files/patch-ae22
-rw-r--r--devel/gettext/files/patch-ak4
-rw-r--r--devel/gettext/files/patch-config_ltmain.sh51
-rw-r--r--devel/gettext/files/patch-doc::Makefile.in14
-rw-r--r--devel/gettext/files/patch-gettext-runtime_configure11
-rw-r--r--devel/gettext/files/patch-gettext-runtime_intl_Makefile.in (renamed from devel/gettext/files/patch-intl::Makefile.in)27
-rw-r--r--devel/gettext/files/patch-gettext-tools_Makefile.in11
-rw-r--r--devel/gettext/files/patch-gettext-tools_configure11
-rw-r--r--devel/gettext/files/patch-gettext-tools_lib_Makefile.in29
-rw-r--r--devel/gettext/files/patch-gettext-tools_src_Makefile.in (renamed from devel/gettext/files/patch-src::Makefile.in)41
-rw-r--r--devel/gettext/files/patch-lib::Makefile.in50
-rw-r--r--devel/gettext/files/patch-man::Makefile.in7
-rw-r--r--devel/gettext/pkg-descr2
-rw-r--r--devel/gettext/pkg-plist264
18 files changed, 343 insertions, 249 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 66d14229e2cc..20e40d50a8ed 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gettext
-PORTVERSION= 0.11.5
-PORTREVISION= 1
+PORTVERSION= 0.12.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
@@ -18,7 +17,7 @@ COMMENT= GNU gettext package
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
expat.4:${PORTSDIR}/textproc/expat2
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= ACLOCAL="${TRUE}" \
AUTOCONF="${TRUE}" \
@@ -27,7 +26,8 @@ CONFIGURE_ENV= ACLOCAL="${TRUE}" \
MAKEINFO="makeinfo --no-split" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib \
+ --mandir=${PREFIX}/man
INSTALLS_SHLIB= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
@@ -41,14 +41,11 @@ MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
textdomain.3
-pre-configure:
- ${RM} ${WRKSRC}/doc/gettext.info*
+INFO= autosprintf gettext
post-install:
- @install-info ${PREFIX}/info/gettext.info ${PREFIX}/info/dir
- ${MKDIR} ${PREFIX}/share/emacs/site-lisp
-.for file in po-compat.el po-mode.el
- ${INSTALL_DATA} ${WRKSRC}/misc/${file} ${PREFIX}/share/emacs/site-lisp
+.for f in po-compat.el po-mode.el
+ ${INSTALL_DATA} ${WRKSRC}/gettext-tools/misc/${f} ${PREFIX}/share/emacs/site-lisp
.endfor
${MKDIR} ${X11BASE}/share/locale
diff --git a/devel/gettext/distinfo b/devel/gettext/distinfo
index 36580c1b199a..7b745d693668 100644
--- a/devel/gettext/distinfo
+++ b/devel/gettext/distinfo
@@ -1 +1 @@
-MD5 (gettext-0.11.5.tar.gz) = b7c1fe238dc8087da035b071c3b425b4
+MD5 (gettext-0.12.1.tar.gz) = 5d4bddd300072315e668247e5b7d5bdb
diff --git a/devel/gettext/files/patch-Makefile.in b/devel/gettext/files/patch-Makefile.in
deleted file mode 100644
index 22d10ad84344..000000000000
--- a/devel/gettext/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Jul 17 20:45:19 2002
-+++ Makefile.in Fri Jul 19 03:41:08 2002
-@@ -155,7 +155,7 @@
- gettextsrc_DATA = ABOUT-NLS
- gettextsrc_SCRIPTS = config.rpath mkinstalldirs
-
--SUBDIRS = doc intl intl-java lib libuniname src po projects misc man m4 tests
-+SUBDIRS = doc intl lib libuniname src po projects misc man m4 tests
-
- EXTRA_DIST = config.rpath BUGS DISCLAIM PACKAGING README.gemtext \
- djgpp/COPYING.DJ djgpp/Makefile.maint djgpp/README.DJ \
diff --git a/devel/gettext/files/patch-ad b/devel/gettext/files/patch-ad
index 1e938c8ca395..40bec14d6b97 100644
--- a/devel/gettext/files/patch-ad
+++ b/devel/gettext/files/patch-ad
@@ -1,9 +1,13 @@
---- misc/Makefile.in.orig Tue Mar 12 13:04:40 2002
-+++ misc/Makefile.in Fri Mar 15 17:33:23 2002
-@@ -223,6 +223,4 @@
- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(lispdir)/$$f"; \
-- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(lispdir)/$$f; \
+--- gettext-tools/misc/Makefile.in.orig Thu May 22 09:41:22 2003
++++ gettext-tools/misc/Makefile.in Wed Jun 11 14:00:52 2003
+@@ -332,10 +332,8 @@
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ echo " $(lispLISP_INSTALL) $$d$$p $(DESTDIR)$(lispdir)/$$f"; \
+- $(lispLISP_INSTALL) $$d$$p $(DESTDIR)$(lispdir)/$$f; \
if test -f $${p}c; then \
- echo " $(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c"; \
-- $(INSTALL_DATA) $${p}c $(DESTDIR)$(lispdir)/$${f}c; \
+ echo " $(lispLISP_INSTALL) $${p}c $(DESTDIR)$(lispdir)/$${f}c"; \
+- $(lispLISP_INSTALL) $${p}c $(DESTDIR)$(lispdir)/$${f}c; \
else : ; fi; \
+ done; \
+ else : ; fi
diff --git a/devel/gettext/files/patch-ae b/devel/gettext/files/patch-ae
deleted file mode 100644
index c708e9d3c3f4..000000000000
--- a/devel/gettext/files/patch-ae
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig Wed Jul 17 20:45:27 2002
-+++ configure Fri Jul 19 03:44:17 2002
-@@ -7576,6 +7576,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -14782,7 +14783,7 @@
-
- fi
- fi
--EMACS=$ac_cv_prog_EMACS
-+EMACS=no
- if test -n "$EMACS"; then
- echo "$as_me:14787: result: $EMACS" >&5
- echo "${ECHO_T}$EMACS" >&6
diff --git a/devel/gettext/files/patch-ak b/devel/gettext/files/patch-ak
index 3cc93a5361fd..f7ce579bbf8d 100644
--- a/devel/gettext/files/patch-ak
+++ b/devel/gettext/files/patch-ak
@@ -1,5 +1,5 @@
---- misc/po-mode.el.orig Sun Jan 23 22:35:10 2000
-+++ misc/po-mode.el Sun Jan 23 22:35:39 2000
+--- gettext-tools/misc/po-mode.el.orig Sun Jan 23 22:35:10 2000
++++ gettext-tools/misc/po-mode.el Sun Jan 23 22:35:39 2000
@@ -330,7 +330,7 @@
:type 'face
:group 'po)
diff --git a/devel/gettext/files/patch-config_ltmain.sh b/devel/gettext/files/patch-config_ltmain.sh
new file mode 100644
index 000000000000..b6203b589dea
--- /dev/null
+++ b/devel/gettext/files/patch-config_ltmain.sh
@@ -0,0 +1,51 @@
+--- config/ltmain.sh.orig Tue Apr 15 19:22:56 2003
++++ config/ltmain.sh Wed Jun 11 14:15:07 2003
+@@ -1279,7 +1279,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1289,8 +1289,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3001,6 +3009,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5429,10 +5440,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/gettext/files/patch-doc::Makefile.in b/devel/gettext/files/patch-doc::Makefile.in
deleted file mode 100644
index e0aec523d31b..000000000000
--- a/devel/gettext/files/patch-doc::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD: /tmp/pcvs/ports/devel/gettext/files/Attic/patch-doc::Makefile.in,v 1.2 2002-08-01 02:30:59 ade Exp $
-
---- doc/Makefile.in.orig Wed May 23 23:48:53 2001
-+++ doc/Makefile.in Tue May 29 11:38:28 2001
-@@ -97,7 +97,7 @@
- aclocaldir = @aclocaldir@
- lispdir = @lispdir@
-
--docdir = $(prefix)/doc/@PACKAGE@
-+docdir = $(prefix)/share/doc/@PACKAGE@
- dvidir = $(docdir)
- psdir = $(docdir)
- pdfdir = $(docdir)
diff --git a/devel/gettext/files/patch-gettext-runtime_configure b/devel/gettext/files/patch-gettext-runtime_configure
new file mode 100644
index 000000000000..030d7bd9db50
--- /dev/null
+++ b/devel/gettext/files/patch-gettext-runtime_configure
@@ -0,0 +1,11 @@
+--- gettext-runtime/configure.orig Wed Jun 11 17:21:41 2003
++++ gettext-runtime/configure Wed Jun 11 17:21:56 2003
+@@ -1875,7 +1875,7 @@
+ ac_config_headers="$ac_config_headers config.h"
+
+
+-test "$mandir" != '${prefix}/man' || mandir='${datadir}/man'
++test "$mandir" != '${prefix}/man' || mandir='${prefix}/man'
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
diff --git a/devel/gettext/files/patch-intl::Makefile.in b/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in
index d303723cb429..abab12d951a2 100644
--- a/devel/gettext/files/patch-intl::Makefile.in
+++ b/devel/gettext/files/patch-gettext-runtime_intl_Makefile.in
@@ -1,27 +1,24 @@
-
-$FreeBSD$
-
---- intl/Makefile.in.orig Thu Jan 31 16:11:48 2002
-+++ intl/Makefile.in Tue Apr 30 11:18:46 2002
+--- gettext-runtime/intl/Makefile.in.orig Wed May 21 06:55:18 2003
++++ gettext-runtime/intl/Makefile.in Wed Jun 11 14:28:58 2003
@@ -52,7 +52,7 @@
YFLAGS = --name-prefix=__gettext
DEFS = -DLOCALEDIR=\"$(localedir)\" -DLOCALE_ALIAS_PATH=\"$(aliaspath)\" \
---DLIBDIR=\"$(libdir)\" -DIN_LIBINTL @DEFS@
-+-DLIBDIR=\"$(prefix)/libdata\" -DIN_LIBINTL @DEFS@
- CPPFLAGS = @CPPFLAGS@
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
-@@ -119,7 +119,7 @@
+--DLIBDIR=\"$(libdir)\" -DIN_LIBINTL \
++-DLIBDIR=\"$(prefix)/libdata\" -DIN_LIBINTL \
+ -DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
+ -Dset_relocation_prefix=libintl_set_relocation_prefix \
+ -Drelocate=libintl_relocate \
+@@ -145,7 +145,7 @@
libintl.la libgnuintl.la: $(OBJECTS)
$(LIBTOOL) --mode=link \
$(CC) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS) $(LDFLAGS) -o $@ \
-- $(OBJECTS) @LTLIBICONV@ -lc \
-+ $(OBJECTS) @LTLIBICONV@ \
+- $(OBJECTS) @LTLIBICONV@ $(LIBS) -lc \
++ $(OBJECTS) @LTLIBICONV@ $(LIBS) \
-version-info $(LTV_CURRENT):$(LTV_REVISION):$(LTV_AGE) \
-rpath $(libdir) \
-no-undefined
-@@ -153,22 +153,6 @@
+@@ -270,22 +270,6 @@
: ; \
fi
if test '@USE_INCLUDED_LIBINTL@' = yes; then \
@@ -44,7 +41,7 @@ $FreeBSD$
$(mkinstalldirs) $(DESTDIR)$(localedir); \
test -f $(DESTDIR)$(localedir)/locale.alias \
&& orig=$(DESTDIR)$(localedir)/locale.alias \
-@@ -240,9 +224,9 @@
+@@ -369,9 +353,9 @@
: ; \
fi
if test '@USE_INCLUDED_LIBINTL@' = yes; then \
diff --git a/devel/gettext/files/patch-gettext-tools_Makefile.in b/devel/gettext/files/patch-gettext-tools_Makefile.in
new file mode 100644
index 000000000000..b4b4bbbde36a
--- /dev/null
+++ b/devel/gettext/files/patch-gettext-tools_Makefile.in
@@ -0,0 +1,11 @@
+--- gettext-tools/Makefile.in.orig Wed Jun 11 13:55:17 2003
++++ gettext-tools/Makefile.in Wed Jun 11 13:55:27 2003
+@@ -207,7 +207,7 @@
+ AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+ ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../config/m4
+
+-SUBDIRS = doc intl lib libuniname src po projects misc man m4 tests
++SUBDIRS = doc intl lib libuniname src po projects misc man m4
+
+ # vms_jackets.h is a header that comes with Compaq's "porting library".
+ # KEEP_CRTL_SETLOCALE tells it to not override the native locale support.
diff --git a/devel/gettext/files/patch-gettext-tools_configure b/devel/gettext/files/patch-gettext-tools_configure
new file mode 100644
index 000000000000..48c0edf92bac
--- /dev/null
+++ b/devel/gettext/files/patch-gettext-tools_configure
@@ -0,0 +1,11 @@
+--- gettext-tools/configure.orig Wed Jun 11 17:11:46 2003
++++ gettext-tools/configure Wed Jun 11 17:12:02 2003
+@@ -1887,7 +1887,7 @@
+ ac_config_headers="$ac_config_headers config.h"
+
+
+-test "$mandir" != '${prefix}/man' || mandir='${datadir}/man'
++test "$mandir" != '${prefix}/man' || mandir='${prefix}/man'
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
diff --git a/devel/gettext/files/patch-gettext-tools_lib_Makefile.in b/devel/gettext/files/patch-gettext-tools_lib_Makefile.in
new file mode 100644
index 000000000000..a3a1b1fa8595
--- /dev/null
+++ b/devel/gettext/files/patch-gettext-tools_lib_Makefile.in
@@ -0,0 +1,29 @@
+--- gettext-tools/lib/Makefile.in.orig Thu May 22 09:41:20 2003
++++ gettext-tools/lib/Makefile.in Wed Jun 11 14:05:44 2003
+@@ -67,7 +67,7 @@
+ CYGPATH_W = @CYGPATH_W@
+ DATADIRNAME = @DATADIRNAME@
+
+-DEFS = -DEXEEXT=\"$(EXEEXT)\" -DDEPENDS_ON_LIBINTL=1 -DDEPENDS_ON_LIBICONV=1 @DEFS@ -DLIBDIR=\"$(libdir)\"
++DEFS = -DEXEEXT=\"$(EXEEXT)\" -DDEPENDS_ON_LIBINTL=1 -DDEPENDS_ON_LIBICONV=1 @DEFS@ -DLIBDIR=\"$(prefix)/libdata\"
+ DEPDIR = @DEPDIR@
+ DLLTOOL = @DLLTOOL@
+ DVIPS = @DVIPS@
+@@ -317,7 +317,7 @@
+ # Need @LTLIBICONV@ because linebreak.c uses iconv().
+ libgettextlib_la_LDFLAGS = \
+ -release @VERSION@ \
+- @LTLIBINTL@ @LTLIBICONV@ -lc -no-undefined
++ @LTLIBINTL@ @LTLIBICONV@ -no-undefined
+
+
+
+@@ -599,7 +599,7 @@
+
+ install-data-am: install-gettextsrcDATA
+
+-install-exec-am: install-exec-local install-libLTLIBRARIES
++install-exec-am: install-libLTLIBRARIES
+
+ install-info: install-info-am
+
diff --git a/devel/gettext/files/patch-src::Makefile.in b/devel/gettext/files/patch-gettext-tools_src_Makefile.in
index 65af8a8c3173..7702c306e4a9 100644
--- a/devel/gettext/files/patch-src::Makefile.in
+++ b/devel/gettext/files/patch-gettext-tools_src_Makefile.in
@@ -1,18 +1,15 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Wed Jul 17 20:46:11 2002
-+++ src/Makefile.in Fri Jul 19 03:51:12 2002
-@@ -181,7 +181,7 @@
+--- gettext-tools/src/Makefile.in.orig Thu May 22 09:41:24 2003
++++ gettext-tools/src/Makefile.in Wed Jun 11 14:10:48 2003
+@@ -72,7 +72,7 @@
+ -DUSEJEXE=$(USEJEXE) \
+ -DGETTEXTJEXEDIR=\"$(pkglibdir)\" \
+ -DGETTEXTJAR=\"$(jardir)/gettext.jar\" \
+- -DLIBDIR=\"$(libdir)\" \
++ -DLIBDIR=\"$(prefix)/libdata\" \
+ -DGETTEXTDATADIR=\"$(pkgdatadir)\" \
+ -DPROJECTSDIR=\"$(projectsdir)\" @DEFS@
- DEFS = -DLOCALEDIR=\"$(localedir)\" -DUSEJEXE=$(USEJEXE) \
- -DGETTEXTJEXEDIR=\"$(pkglibdir)\" -DGETTEXTJAR=\"$(jardir)/gettext.jar\" \
---DLIBDIR=\"$(libdir)\" -DGETTEXTDATADIR=\"$(pkgdatadir)\" \
-+-DLIBDIR=\"$(prefix)/libdata\" -DGETTEXTDATADIR=\"$(pkgdatadir)\" \
- -DPROJECTSDIR=\"$(projectsdir)\" @DEFS@
-
- LDADD = ../lib/libgettextlib.la @LTLIBINTL@
-@@ -248,7 +248,7 @@
+@@ -336,7 +336,7 @@
# use iconv().
libgettextsrc_la_LDFLAGS = \
-release @VERSION@ \
@@ -20,16 +17,16 @@ $FreeBSD$
+ ../lib/libgettextlib.la @LTLIBINTL@ @LTLIBICONV@ -no-undefined
- # Link dependencies.
-@@ -747,11 +747,11 @@
+ # How to build libgettextpo.la.
+@@ -1316,11 +1316,11 @@
# Special rules for installation of auxiliary programs.
install-exec-local:
-- $(mkinstalldirs) $(DESTDIR)$(libdir)/$(PACKAGE)
-- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) hostname$(EXEEXT) $(DESTDIR)$(libdir)/$(PACKAGE)/hostname$(EXEEXT)
-- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) urlget$(EXEEXT) $(DESTDIR)$(libdir)/$(PACKAGE)/urlget$(EXEEXT)
-- $(INSTALL_SCRIPT) user-email $(DESTDIR)$(libdir)/$(PACKAGE)/user-email
-- $(INSTALL_SCRIPT) $(srcdir)/project-id $(DESTDIR)$(libdir)/$(PACKAGE)/project-id
+- $(mkinstalldirs) $(DESTDIR)$(pkglibdir)
+- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) hostname$(EXEEXT) $(DESTDIR)$(pkglibdir)/hostname$(EXEEXT)
+- $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) urlget$(EXEEXT) $(DESTDIR)$(pkglibdir)/urlget$(EXEEXT)
+- $(INSTALL_SCRIPT) user-email $(DESTDIR)$(pkglibdir)/user-email
+- $(INSTALL_SCRIPT) $(srcdir)/project-id $(DESTDIR)$(pkglibdir)/project-id
+ $(mkinstalldirs) $(DESTDIR)$(prefix)/libdata/$(PACKAGE)
+ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) hostname$(EXEEXT) $(DESTDIR)$(prefix)/libdata/$(PACKAGE)/hostname$(EXEEXT)
+ $(INSTALL_PROGRAM_ENV) $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) urlget$(EXEEXT) $(DESTDIR)$(prefix)/libdata/$(PACKAGE)/urlget$(EXEEXT)
@@ -37,4 +34,4 @@ $FreeBSD$
+ $(INSTALL_SCRIPT) $(srcdir)/project-id $(DESTDIR)$(prefix)/libdata/$(PACKAGE)/project-id
installdirs-local:
- $(mkinstalldirs) $(DESTDIR)$(libdir)/$(PACKAGE)
+ $(mkinstalldirs) $(DESTDIR)$(pkglibdir)
diff --git a/devel/gettext/files/patch-lib::Makefile.in b/devel/gettext/files/patch-lib::Makefile.in
deleted file mode 100644
index a327eb023672..000000000000
--- a/devel/gettext/files/patch-lib::Makefile.in
+++ /dev/null
@@ -1,50 +0,0 @@
-
-$FreeBSD$
-
---- lib/Makefile.in.orig Fri Jul 19 03:46:30 2002
-+++ lib/Makefile.in Fri Jul 19 03:47:55 2002
-@@ -227,7 +227,7 @@
- # Need @LTLIBICONV@ because linebreak.c uses iconv().
- libgettextlib_la_LDFLAGS = \
- -release @VERSION@ \
-- @LTLIBINTL@ @LTLIBICONV@ -lc -no-undefined
-+ @LTLIBINTL@ @LTLIBICONV@ -no-undefined
-
-
-
-@@ -245,14 +245,14 @@
- gen-lbrkprop.c 3level.h Combining.txt
-
-
--DEFS = -DLIBDIR=\"$(libdir)\" -DEXEEXT=\"$(EXEEXT)\" @DEFS@
-+DEFS = -DLIBDIR=\"$(prefix)/libdata\" -DEXEEXT=\"$(EXEEXT)\" @DEFS@
- INCLUDES = -I. -I$(srcdir) -I.. -I../intl -I$(top_srcdir)/intl
-
- DISTCLEANFILES = fnmatch.h
- MOSTLYCLEANFILES = @STDBOOL_H@
-
--charset_alias = $(DESTDIR)$(libdir)/charset.alias
--charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
-+charset_alias = $(DESTDIR)$(prefix)/libdata/charset.alias
-+charset_tmp = $(DESTDIR)$(prefix)/libdata/charset.tmp
-
- SUFFIXES = .sed .sin
-
-@@ -482,7 +482,7 @@
-
- install-data-am: install-gettextsrcDATA
-
--install-exec-am: install-exec-local install-libLTLIBRARIES
-+install-exec-am: install-libLTLIBRARIES
-
- install-info: install-info-am
-
-@@ -534,7 +534,7 @@
-
- all-local: charset.alias ref-add.sed ref-del.sed
- install-exec-local: all-local
-- $(mkinstalldirs) $(DESTDIR)$(libdir)
-+ $(mkinstalldirs) $(DESTDIR)$(prefix)/libdata
- if test -f $(charset_alias); then \
- sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
- $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
diff --git a/devel/gettext/files/patch-man::Makefile.in b/devel/gettext/files/patch-man::Makefile.in
deleted file mode 100644
index a66663686eb2..000000000000
--- a/devel/gettext/files/patch-man::Makefile.in
+++ /dev/null
@@ -1,7 +0,0 @@
---- man/Makefile.in.orig Tue Mar 12 13:04:22 2002
-+++ man/Makefile.in Fri Mar 15 17:41:43 2002
-@@ -144,3 +144,3 @@
- VERSION = @VERSION@
--docdir = $(prefix)/doc/@PACKAGE@
-+docdir = $(prefix)/share/doc/@PACKAGE@
- htmldir = $(docdir)
diff --git a/devel/gettext/pkg-descr b/devel/gettext/pkg-descr
index 24fee26e0c26..38165c0868e7 100644
--- a/devel/gettext/pkg-descr
+++ b/devel/gettext/pkg-descr
@@ -3,3 +3,5 @@ maintainers of other packages or programs which they want to see
internationalized. As one step the handling of messages in different
languages should be implemented. For this task GNU gettext provides
the needed tools and library functions.
+
+WWW: http://www.gnu.org/software/gettext/
diff --git a/devel/gettext/pkg-plist b/devel/gettext/pkg-plist
index 36cac4a3689d..554390f9c73a 100644
--- a/devel/gettext/pkg-plist
+++ b/devel/gettext/pkg-plist
@@ -17,21 +17,26 @@ bin/msgunfmt
bin/msguniq
bin/ngettext
bin/xgettext
+include/autosprintf.h
+include/gettext-po.h
include/libintl.h
-@unexec install-info --delete %D/info/gettext.info %D/info/dir
-info/gettext.info
-@exec install-info %D/info/gettext.info %D/info/dir
+lib/libasprintf.a
+lib/libasprintf.so
+lib/libasprintf.so.0
lib/libgettextlib-%%VERSION%%.so
lib/libgettextlib.so
+lib/libgettextpo.a
+lib/libgettextpo.so
+lib/libgettextpo.so.0
lib/libgettextsrc-%%VERSION%%.so
lib/libgettextsrc.so
lib/libintl.a
lib/libintl.so
-lib/libintl.so.4
-libdata/gettext/hostname
-libdata/gettext/project-id
-libdata/gettext/urlget
-libdata/gettext/user-email
+lib/libintl.so.5
+libdata/gettext-tools/hostname
+libdata/gettext-tools/project-id
+libdata/gettext-tools/urlget
+libdata/gettext-tools/user-email
share/aclocal/codeset.m4
share/aclocal/gettext.m4
share/aclocal/glibc21.m4
@@ -45,58 +50,102 @@ share/aclocal/lcmessage.m4
share/aclocal/lib-ld.m4
share/aclocal/lib-link.m4
share/aclocal/lib-prefix.m4
+share/aclocal/nls.m4
+share/aclocal/po.m4
share/aclocal/progtest.m4
share/aclocal/stdint_h.m4
share/aclocal/uintmax_t.m4
share/aclocal/ulonglong.m4
-share/doc/gettext/autopoint.1.html
-share/doc/gettext/bind_textdomain_codeset.3.html
-share/doc/gettext/bindtextdomain.3.html
-share/doc/gettext/gettext.1.html
-share/doc/gettext/gettext.3.html
-share/doc/gettext/gettext_1.html
-share/doc/gettext/gettext_10.html
-share/doc/gettext/gettext_11.html
-share/doc/gettext/gettext_12.html
-share/doc/gettext/gettext_13.html
-share/doc/gettext/gettext_14.html
-share/doc/gettext/gettext_15.html
-share/doc/gettext/gettext_16.html
-share/doc/gettext/gettext_17.html
-share/doc/gettext/gettext_18.html
-share/doc/gettext/gettext_19.html
-share/doc/gettext/gettext_2.html
-share/doc/gettext/gettext_20.html
-share/doc/gettext/gettext_21.html
-share/doc/gettext/gettext_22.html
-share/doc/gettext/gettext_3.html
-share/doc/gettext/gettext_4.html
-share/doc/gettext/gettext_5.html
-share/doc/gettext/gettext_6.html
-share/doc/gettext/gettext_7.html
-share/doc/gettext/gettext_8.html
-share/doc/gettext/gettext_9.html
-share/doc/gettext/gettext_foot.html
-share/doc/gettext/gettext_toc.html
-share/doc/gettext/gettextize.1.html
-share/doc/gettext/msgattrib.1.html
-share/doc/gettext/msgcat.1.html
-share/doc/gettext/msgcmp.1.html
-share/doc/gettext/msgcomm.1.html
-share/doc/gettext/msgconv.1.html
-share/doc/gettext/msgen.1.html
-share/doc/gettext/msgexec.1.html
-share/doc/gettext/msgfilter.1.html
-share/doc/gettext/msgfmt.1.html
-share/doc/gettext/msggrep.1.html
-share/doc/gettext/msginit.1.html
-share/doc/gettext/msgmerge.1.html
-share/doc/gettext/msgunfmt.1.html
-share/doc/gettext/msguniq.1.html
-share/doc/gettext/ngettext.1.html
-share/doc/gettext/ngettext.3.html
-share/doc/gettext/textdomain.3.html
-share/doc/gettext/xgettext.1.html
+%%DOCSDIR%%/autopoint.1.html
+%%DOCSDIR%%/bind_textdomain_codeset.3.html
+%%DOCSDIR%%/bindtextdomain.3.html
+%%DOCSDIR%%/gettext.1.html
+%%DOCSDIR%%/gettext.3.html
+%%DOCSDIR%%/gettext_1.html
+%%DOCSDIR%%/gettext_10.html
+%%DOCSDIR%%/gettext_11.html
+%%DOCSDIR%%/gettext_12.html
+%%DOCSDIR%%/gettext_13.html
+%%DOCSDIR%%/gettext_14.html
+%%DOCSDIR%%/gettext_15.html
+%%DOCSDIR%%/gettext_16.html
+%%DOCSDIR%%/gettext_17.html
+%%DOCSDIR%%/gettext_18.html
+%%DOCSDIR%%/gettext_19.html
+%%DOCSDIR%%/gettext_2.html
+%%DOCSDIR%%/gettext_20.html
+%%DOCSDIR%%/gettext_21.html
+%%DOCSDIR%%/gettext_22.html
+%%DOCSDIR%%/gettext_3.html
+%%DOCSDIR%%/gettext_4.html
+%%DOCSDIR%%/gettext_5.html
+%%DOCSDIR%%/gettext_6.html
+%%DOCSDIR%%/gettext_7.html
+%%DOCSDIR%%/gettext_8.html
+%%DOCSDIR%%/gettext_9.html
+%%DOCSDIR%%/gettext_foot.html
+%%DOCSDIR%%/gettext_toc.html
+%%DOCSDIR%%/gettextize.1.html
+%%DOCSDIR%%/javadoc1/AllNames.html
+%%DOCSDIR%%/javadoc1/gnu.gettext.GettextResource.html
+%%DOCSDIR%%/javadoc1/images/blue-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/blue-ball.gif
+%%DOCSDIR%%/javadoc1/images/class-index.gif
+%%DOCSDIR%%/javadoc1/images/constructor-index.gif
+%%DOCSDIR%%/javadoc1/images/constructors.gif
+%%DOCSDIR%%/javadoc1/images/cyan-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/cyan-ball.gif
+%%DOCSDIR%%/javadoc1/images/error-index.gif
+%%DOCSDIR%%/javadoc1/images/exception-index.gif
+%%DOCSDIR%%/javadoc1/images/green-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/green-ball.gif
+%%DOCSDIR%%/javadoc1/images/interface-index.gif
+%%DOCSDIR%%/javadoc1/images/magenta-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/magenta-ball.gif
+%%DOCSDIR%%/javadoc1/images/method-index.gif
+%%DOCSDIR%%/javadoc1/images/methods.gif
+%%DOCSDIR%%/javadoc1/images/package-index.gif
+%%DOCSDIR%%/javadoc1/images/red-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/red-ball.gif
+%%DOCSDIR%%/javadoc1/images/variable-index.gif
+%%DOCSDIR%%/javadoc1/images/variables.gif
+%%DOCSDIR%%/javadoc1/images/yellow-ball-small.gif
+%%DOCSDIR%%/javadoc1/images/yellow-ball.gif
+%%DOCSDIR%%/javadoc1/packages.html
+%%DOCSDIR%%/javadoc1/tree.html
+%%DOCSDIR%%/javadoc2/allclasses-frame.html
+%%DOCSDIR%%/javadoc2/deprecated-list.html
+%%DOCSDIR%%/javadoc2/gnu/gettext/GettextResource.html
+%%DOCSDIR%%/javadoc2/gnu/gettext/package-frame.html
+%%DOCSDIR%%/javadoc2/gnu/gettext/package-summary.html
+%%DOCSDIR%%/javadoc2/gnu/gettext/package-tree.html
+%%DOCSDIR%%/javadoc2/help-doc.html
+%%DOCSDIR%%/javadoc2/index-all.html
+%%DOCSDIR%%/javadoc2/index.html
+%%DOCSDIR%%/javadoc2/overview-tree.html
+%%DOCSDIR%%/javadoc2/package-list
+%%DOCSDIR%%/javadoc2/packages.html
+%%DOCSDIR%%/javadoc2/serialized-form.html
+%%DOCSDIR%%/javadoc2/stylesheet.css
+%%DOCSDIR%%/msgattrib.1.html
+%%DOCSDIR%%/msgcat.1.html
+%%DOCSDIR%%/msgcmp.1.html
+%%DOCSDIR%%/msgcomm.1.html
+%%DOCSDIR%%/msgconv.1.html
+%%DOCSDIR%%/msgen.1.html
+%%DOCSDIR%%/msgexec.1.html
+%%DOCSDIR%%/msgfilter.1.html
+%%DOCSDIR%%/msgfmt.1.html
+%%DOCSDIR%%/msggrep.1.html
+%%DOCSDIR%%/msginit.1.html
+%%DOCSDIR%%/msgmerge.1.html
+%%DOCSDIR%%/msgunfmt.1.html
+%%DOCSDIR%%/msguniq.1.html
+%%DOCSDIR%%/ngettext.1.html
+%%DOCSDIR%%/ngettext.3.html
+%%DOCSDIR%%/textdomain.3.html
+%%DOCSDIR%%/xgettext.1.html
+share/doc/libasprintf/autosprintf.html
share/emacs/site-lisp/po-compat.el
share/emacs/site-lisp/po-mode.el
share/gettext/ABOUT-NLS
@@ -124,13 +173,15 @@ share/gettext/intl/gmo.h
share/gettext/intl/hash-string.h
share/gettext/intl/intl-compat.c
share/gettext/intl/l10nflist.c
-share/gettext/intl/libgnuintl.h
+share/gettext/intl/libgnuintl.h.in
share/gettext/intl/loadinfo.h
share/gettext/intl/loadmsgcat.c
share/gettext/intl/localcharset.c
+share/gettext/intl/localcharset.h
share/gettext/intl/locale.alias
share/gettext/intl/localealias.c
share/gettext/intl/localename.c
+share/gettext/intl/log.c
share/gettext/intl/ngettext.c
share/gettext/intl/os2compat.c
share/gettext/intl/os2compat.h
@@ -141,11 +192,13 @@ share/gettext/intl/plural.c
share/gettext/intl/plural.y
share/gettext/intl/ref-add.sin
share/gettext/intl/ref-del.sin
+share/gettext/intl/relocatable.c
+share/gettext/intl/relocatable.h
share/gettext/intl/textdomain.c
share/gettext/mkinstalldirs
share/gettext/msgunfmt.tcl
share/gettext/po/Makefile.in.in
-share/gettext/po/Makevars
+share/gettext/po/Makevars.template
share/gettext/po/Rules-quot
share/gettext/po/boldquot.sed
share/gettext/po/en@boldquot.header
@@ -167,36 +220,65 @@ share/gettext/projects/TP/teams.url
share/gettext/projects/TP/trigger
share/gettext/projects/index
share/gettext/projects/team-address
-share/locale/be/LC_MESSAGES/gettext.mo
-share/locale/ca/LC_MESSAGES/gettext.mo
-share/locale/cs/LC_MESSAGES/gettext.mo
-share/locale/da/LC_MESSAGES/gettext.mo
-share/locale/de/LC_MESSAGES/gettext.mo
-share/locale/el/LC_MESSAGES/gettext.mo
-share/locale/en@boldquot/LC_MESSAGES/gettext.mo
-share/locale/en@quot/LC_MESSAGES/gettext.mo
-share/locale/es/LC_MESSAGES/gettext.mo
-share/locale/et/LC_MESSAGES/gettext.mo
-share/locale/fi/LC_MESSAGES/gettext.mo
-share/locale/fr/LC_MESSAGES/gettext.mo
-share/locale/gl/LC_MESSAGES/gettext.mo
-share/locale/id/LC_MESSAGES/gettext.mo
-share/locale/it/LC_MESSAGES/gettext.mo
-share/locale/ja/LC_MESSAGES/gettext.mo
-share/locale/ko/LC_MESSAGES/gettext.mo
+share/locale/be/LC_MESSAGES/gettext-runtime.mo
+share/locale/be/LC_MESSAGES/gettext-tools.mo
+share/locale/ca/LC_MESSAGES/gettext-runtime.mo
+share/locale/ca/LC_MESSAGES/gettext-tools.mo
+share/locale/cs/LC_MESSAGES/gettext-runtime.mo
+share/locale/cs/LC_MESSAGES/gettext-tools.mo
+share/locale/da/LC_MESSAGES/gettext-runtime.mo
+share/locale/da/LC_MESSAGES/gettext-tools.mo
+share/locale/de/LC_MESSAGES/gettext-runtime.mo
+share/locale/de/LC_MESSAGES/gettext-tools.mo
+share/locale/el/LC_MESSAGES/gettext-runtime.mo
+share/locale/el/LC_MESSAGES/gettext-tools.mo
+share/locale/en@boldquot/LC_MESSAGES/gettext-runtime.mo
+share/locale/en@boldquot/LC_MESSAGES/gettext-tools.mo
+share/locale/en@quot/LC_MESSAGES/gettext-runtime.mo
+share/locale/en@quot/LC_MESSAGES/gettext-tools.mo
+share/locale/es/LC_MESSAGES/gettext-runtime.mo
+share/locale/es/LC_MESSAGES/gettext-tools.mo
+share/locale/et/LC_MESSAGES/gettext-runtime.mo
+share/locale/et/LC_MESSAGES/gettext-tools.mo
+share/locale/fi/LC_MESSAGES/gettext-runtime.mo
+share/locale/fi/LC_MESSAGES/gettext-tools.mo
+share/locale/fr/LC_MESSAGES/gettext-runtime.mo
+share/locale/fr/LC_MESSAGES/gettext-tools.mo
+share/locale/gl/LC_MESSAGES/gettext-runtime.mo
+share/locale/gl/LC_MESSAGES/gettext-tools.mo
+share/locale/id/LC_MESSAGES/gettext-runtime.mo
+share/locale/id/LC_MESSAGES/gettext-tools.mo
+share/locale/it/LC_MESSAGES/gettext-runtime.mo
+share/locale/it/LC_MESSAGES/gettext-tools.mo
+share/locale/ja/LC_MESSAGES/gettext-runtime.mo
+share/locale/ja/LC_MESSAGES/gettext-tools.mo
+share/locale/ko/LC_MESSAGES/gettext-runtime.mo
+share/locale/ko/LC_MESSAGES/gettext-tools.mo
share/locale/locale.alias
-share/locale/nl/LC_MESSAGES/gettext.mo
-share/locale/nn/LC_MESSAGES/gettext.mo
-share/locale/no/LC_MESSAGES/gettext.mo
-share/locale/pl/LC_MESSAGES/gettext.mo
-share/locale/pt/LC_MESSAGES/gettext.mo
-share/locale/pt_BR/LC_MESSAGES/gettext.mo
-share/locale/ru/LC_MESSAGES/gettext.mo
-share/locale/sk/LC_MESSAGES/gettext.mo
-share/locale/sl/LC_MESSAGES/gettext.mo
-share/locale/sv/LC_MESSAGES/gettext.mo
-share/locale/tr/LC_MESSAGES/gettext.mo
-share/locale/zh_TW/LC_MESSAGES/gettext.mo
+share/locale/nl/LC_MESSAGES/gettext-runtime.mo
+share/locale/nl/LC_MESSAGES/gettext-tools.mo
+share/locale/nn/LC_MESSAGES/gettext-runtime.mo
+share/locale/nn/LC_MESSAGES/gettext-tools.mo
+share/locale/no/LC_MESSAGES/gettext-runtime.mo
+share/locale/no/LC_MESSAGES/gettext-tools.mo
+share/locale/pl/LC_MESSAGES/gettext-runtime.mo
+share/locale/pl/LC_MESSAGES/gettext-tools.mo
+share/locale/pt/LC_MESSAGES/gettext-runtime.mo
+share/locale/pt/LC_MESSAGES/gettext-tools.mo
+share/locale/pt_BR/LC_MESSAGES/gettext-runtime.mo
+share/locale/pt_BR/LC_MESSAGES/gettext-tools.mo
+share/locale/ru/LC_MESSAGES/gettext-runtime.mo
+share/locale/ru/LC_MESSAGES/gettext-tools.mo
+share/locale/sk/LC_MESSAGES/gettext-runtime.mo
+share/locale/sk/LC_MESSAGES/gettext-tools.mo
+share/locale/sl/LC_MESSAGES/gettext-runtime.mo
+share/locale/sl/LC_MESSAGES/gettext-tools.mo
+share/locale/sv/LC_MESSAGES/gettext-runtime.mo
+share/locale/sv/LC_MESSAGES/gettext-tools.mo
+share/locale/tr/LC_MESSAGES/gettext-runtime.mo
+share/locale/tr/LC_MESSAGES/gettext-tools.mo
+share/locale/zh_TW/LC_MESSAGES/gettext-runtime.mo
+share/locale/zh_TW/LC_MESSAGES/gettext-tools.mo
@dirrm share/gettext/projects/TP
@dirrm share/gettext/projects/KDE
@dirrm share/gettext/projects/GNOME
@@ -204,8 +286,14 @@ share/locale/zh_TW/LC_MESSAGES/gettext.mo
@dirrm share/gettext/po
@dirrm share/gettext/intl
@dirrm share/gettext
+@dirrm share/doc/libasprintf
+@dirrm %%DOCSDIR%%/javadoc2/gnu/gettext
+@dirrm %%DOCSDIR%%/javadoc2/gnu
+@dirrm %%DOCSDIR%%/javadoc2
+@dirrm %%DOCSDIR%%/javadoc1/images
+@dirrm %%DOCSDIR%%/javadoc1
@dirrm share/doc/gettext
-@dirrm libdata/gettext
+@dirrm libdata/gettext-tools
@unexec rmdir %D/share/locale/*/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/* 2>/dev/null || true
@unexec rmdir %D/share/locale 2>/dev/null || true