aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/arora/Makefile35
-rw-r--r--www/arora/pkg-plist4
-rw-r--r--www/cutycapt/Makefile11
3 files changed, 19 insertions, 31 deletions
diff --git a/www/arora/Makefile b/www/arora/Makefile
index 0b7a14300465..24a4609db6de 100644
--- a/www/arora/Makefile
+++ b/www/arora/Makefile
@@ -8,32 +8,23 @@ CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
MAINTAINER= shanjobe@gmail.com
-COMMENT= Simple Qt4 based browser
+COMMENT= Simple Qt 4 based browser
LICENSE= GPLv3
-USE_QT4= network webkit qmake_build moc_build uic_build rcc_build \
- imageformats gui script sql
-HAS_CONFIGURE= yes
-QMAKE_ARGS+= -unix -recursive PREFIX=${PREFIX}
+USES= desktop-file-utils qmake
+USE_QT4= network webkit moc_build uic_build rcc_build \
+ imageformats_run gui script sql
-MAN1= arora.1 arora-cacheinfo.1 arora-placesimport.1 htmlToXBel.1
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USE= QT4=linguist_build
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == ia64
-BROKEN= core dump on application startup
-.endif
+BROKEN_ia64= core dump on application startup
-.if ! ${PORT_OPTIONS:MNLS}
-PLIST_SUB+= NLS="@comment "
-.else
-USE_QT4+= linguist_build
-PLIST_SUB+= NLS=""
-.endif
+.include <bsd.port.options.mk>
-do-configure:
+pre-configure:
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e "/INSTALLS/s|translations||" \
${WRKSRC}/src/src.pro
@@ -49,12 +40,8 @@ do-configure:
${WRKSRC}/src/locale/locale.pri
@${REINPLACE_CMD} "/pkg-config/d" \
${WRKSRC}/src/src.pro
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS}
post-configure:
- @${REINPLACE_CMD} -e \
- 's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|' \
- ${WRKSRC}/src/Makefile
@${REINPLACE_CMD} 's|raster||' ${WRKSRC}/src/main.cpp
post-install:
@@ -62,6 +49,6 @@ post-install:
${WRKSRC}/tools/cacheinfo/data/arora-cacheinfo.1 \
${WRKSRC}/tools/htmlToXBel/data/htmlToXBel.1 \
${WRKSRC}/tools/placesimport/data/arora-placesimport.1 \
- ${PREFIX}/man/man1
+ ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/www/arora/pkg-plist b/www/arora/pkg-plist
index cbb2bfa80363..a072546f6ae9 100644
--- a/www/arora/pkg-plist
+++ b/www/arora/pkg-plist
@@ -2,6 +2,10 @@ bin/arora
bin/arora-cacheinfo
bin/arora-placesimport
bin/htmlToXBel
+man/man1/arora.1.gz
+man/man1/arora-cacheinfo.1.gz
+man/man1/arora-placesimport.1.gz
+man/man1/htmlToXBel.1.gz
share/applications/arora.desktop
%%NLS%%share/arora/locale/ast.qm
%%NLS%%share/arora/locale/ca.qm
diff --git a/www/cutycapt/Makefile b/www/cutycapt/Makefile
index 62db557d2571..7dab1ae0ad3f 100644
--- a/www/cutycapt/Makefile
+++ b/www/cutycapt/Makefile
@@ -8,21 +8,18 @@ CATEGORIES= www
MASTER_SITES= http://bsd.e-shell.net/local/
MAINTAINER= loox@e-shell.net
-COMMENT= A command-line utility to capture WebKit's rendering of a web page
+COMMENT= Command-line utility to capture WebKit's rendering of a web page
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/CutyCapt
-USE_QT4= qmake_build moc_build imageformats webkit
+USES= qmake
+USE_QT4= moc_build imageformats_run webkit
PLIST_FILES= bin/CutyCapt
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE}
-
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/CutyCapt ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/CutyCapt ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>