aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/tcptrack/Makefile30
-rw-r--r--net-mgmt/tcptrack/distinfo2
-rw-r--r--net-mgmt/tcptrack/pkg-descr11
4 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index f8b1d4aa9fad..77ce78a97a12 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -150,6 +150,7 @@
SUBDIR += sysmon
SUBDIR += tas
SUBDIR += tcpreplay
+ SUBDIR += tcptrack
SUBDIR += trafd
SUBDIR += whatmask
SUBDIR += wide-dhcp
diff --git a/net-mgmt/tcptrack/Makefile b/net-mgmt/tcptrack/Makefile
new file mode 100644
index 000000000000..2a8a10b3151d
--- /dev/null
+++ b/net-mgmt/tcptrack/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tcptrack
+# Date created: 2004-10-11
+# Whom: Tor Halvard "Squat" Furulund <squat@squat.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcptrack
+PORTVERSION= 1.1.4
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.rhythm.cx/~steve/devel/tcptrack/
+MASTER_SITE_SUBDIR= release/${PORTVERSION}/source/
+
+MAINTAINER= squat@squat.no
+COMMENT= Packet sniffer which displays TCP information like top(1)
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PLIST_FILES= bin/tcptrack
+MAN1= tcptrack.1
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/tcptrack/distinfo b/net-mgmt/tcptrack/distinfo
new file mode 100644
index 000000000000..d18dd79ae80c
--- /dev/null
+++ b/net-mgmt/tcptrack/distinfo
@@ -0,0 +1,2 @@
+MD5 (tcptrack-1.1.4.tar.gz) = a4e2b556b8ea607d8bfd786e3f78f8f7
+SIZE (tcptrack-1.1.4.tar.gz) = 111945
diff --git a/net-mgmt/tcptrack/pkg-descr b/net-mgmt/tcptrack/pkg-descr
new file mode 100644
index 000000000000..aac8d4f68170
--- /dev/null
+++ b/net-mgmt/tcptrack/pkg-descr
@@ -0,0 +1,11 @@
+tcptrack is a sniffer which displays information about TCP connections it
+sees on a network interface. It passively watches for connections on the
+network interface, keeps track of their state and displays a list of
+connections in a manner similar to the unix 'top' command. It displays
+source and destination addresses and ports, connection state, idle time, and
+bandwidth usage.
+
+WWW: http://www.rhythm.cx/~steve/devel/tcptrack
+
+- Squat
+squat@squat.no