aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/py-GeoIP/Makefile41
-rw-r--r--net/py-GeoIP/distinfo2
-rw-r--r--net/py-GeoIP/pkg-descr4
4 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 84ecd8cc615b..b7ec4777cbf9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -498,6 +498,7 @@
SUBDIR += pvm
SUBDIR += pvm++
SUBDIR += pxe
+ SUBDIR += py-GeoIP
SUBDIR += py-bittorrent
SUBDIR += py-bittorrent-core
SUBDIR += py-fngrab
diff --git a/net/py-GeoIP/Makefile b/net/py-GeoIP/Makefile
new file mode 100644
index 000000000000..a8ebd9df309e
--- /dev/null
+++ b/net/py-GeoIP/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-GeoIP
+# Date created: 27 February 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GeoIP
+PORTVERSION= 1.2.0
+CATEGORIES= net python
+MASTER_SITES= http://www.maxmind.com/download/geoip/api/python/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-Python-${PORTVERSION}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Mapping of IP addresses/hostnames to country names in Python
+
+LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+EXAMPLE_FILES= README test.py test_city.py test_org.py
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/GeoIP.so \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/README \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test.py \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test_city.py \
+ %%PORTDOCS%%%%EXAMPLESDIR%%/test_org.py
+PLIST_DIRS= %%PORTDOCS%%%%EXAMPLESDIR%%
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in ${EXAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/py-GeoIP/distinfo b/net/py-GeoIP/distinfo
new file mode 100644
index 000000000000..b41f5b7c1be0
--- /dev/null
+++ b/net/py-GeoIP/distinfo
@@ -0,0 +1,2 @@
+MD5 (GeoIP-Python-1.2.0.tar.gz) = ec40f604fb64971035b1ab72866d8fc1
+SIZE (GeoIP-Python-1.2.0.tar.gz) = 9622
diff --git a/net/py-GeoIP/pkg-descr b/net/py-GeoIP/pkg-descr
new file mode 100644
index 000000000000..d5b9ff7d0a47
--- /dev/null
+++ b/net/py-GeoIP/pkg-descr
@@ -0,0 +1,4 @@
+Python API to the GeoIP library for obtaining the country, region, city,
+latitude, and longitude of any IP address.
+
+WWW: http://www.maxmind.com/app/python