aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/libpcap/Makefile33
-rw-r--r--net/libpcap/distinfo1
-rw-r--r--net/libpcap/pkg-descr9
-rw-r--r--net/libpcap/pkg-plist4
5 files changed, 48 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7c521506cac9..761af3a57f8b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -287,6 +287,7 @@
SUBDIR += libnss-mysql
SUBDIR += libosip
SUBDIR += libosip2
+ SUBDIR += libpcap
SUBDIR += librsync
SUBDIR += libsmi
SUBDIR += libsocket++
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
new file mode 100644
index 000000000000..8b2895edeb13
--- /dev/null
+++ b/net/libpcap/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libpcap
+# Date created: 10 December 2003
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpcap
+PORTVERSION= 0.8.1
+CATEGORIES= net
+MASTER_SITES= http://www.tcpdump.org/beta/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-316
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Ubiquitous network traffic capture library
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/bison:${PORTSDIR}/devel/bison
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN3= pcap.3
+
+GNU_CONFIGURE= yes
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+.if !defined(WITH_DAG)
+CONFIGURE_ARGS+= --without-dag
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/libpcap/distinfo b/net/libpcap/distinfo
new file mode 100644
index 000000000000..419564f4b861
--- /dev/null
+++ b/net/libpcap/distinfo
@@ -0,0 +1 @@
+MD5 (libpcap-0.8.1-316.tar.gz) = ab8f17ca785b9e0272f98010dc16e13b
diff --git a/net/libpcap/pkg-descr b/net/libpcap/pkg-descr
new file mode 100644
index 000000000000..1002712f7cb6
--- /dev/null
+++ b/net/libpcap/pkg-descr
@@ -0,0 +1,9 @@
+libpcap is a ubiquitous network traffic capture library used by a wide
+variety of BSD, Linux and UN*X applications.
+
+Whilst FreeBSD has a vendor branch import of libpcap in its source tree,
+the purpose of the port is to provide a means of offering additional,
+bleeding-edge features which might not make it into the tree.
+
+Bruce
+bms@FreeBSD.org
diff --git a/net/libpcap/pkg-plist b/net/libpcap/pkg-plist
new file mode 100644
index 000000000000..209925c86e06
--- /dev/null
+++ b/net/libpcap/pkg-plist
@@ -0,0 +1,4 @@
+lib/libpcap.a
+include/pcap.h
+include/pcap-namedb.h
+include/pcap-bpf.h