aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/dwm/Makefile13
-rw-r--r--x11-wm/dwm/distinfo6
-rw-r--r--x11-wm/dwm/files/patch-config.mk13
3 files changed, 21 insertions, 11 deletions
diff --git a/x11-wm/dwm/Makefile b/x11-wm/dwm/Makefile
index fa6421b4290c..813c6d040b38 100644
--- a/x11-wm/dwm/Makefile
+++ b/x11-wm/dwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dwm
-PORTVERSION= 4.3
+PORTVERSION= 4.4
CATEGORIES= x11-wm
MASTER_SITES= http://www.suckless.org/download/ \
http://schot.a-eskwadraat.nl/files/
@@ -18,11 +18,12 @@ USE_XLIB= yes
MAN1= dwm.1
PLIST_FILES= bin/dwm
+PORTDOCS= LICENSE README
pre-everything::
@${ECHO_MSG} "You can build dwm with your own config.h using the DWM_CONF knob:"
@${ECHO_MSG} "make DWM_CONF=/path/to/dwm/config.h install clean"
- @${ECHO_MSG} "Note: Pre-4.1 config.h-files no longer work."
+ @${ECHO_MSG} "Note: Pre-4.4 config.h-files no longer work."
post-extract:
.if defined(DWM_CONF)
@@ -30,4 +31,12 @@ post-extract:
@${CP} ${DWM_CONF} ${WRKSRC}/config.h
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-wm/dwm/distinfo b/x11-wm/dwm/distinfo
index 764e8b9eed7e..678ebcbb446d 100644
--- a/x11-wm/dwm/distinfo
+++ b/x11-wm/dwm/distinfo
@@ -1,3 +1,3 @@
-MD5 (dwm-4.3.tar.gz) = b33c29ec68399b7f3e3e145c0107a452
-SHA256 (dwm-4.3.tar.gz) = ff7919da06fb9b5e995b6af9df87a24045cd747efc3c774b8c287e50e1a8e7a1
-SIZE (dwm-4.3.tar.gz) = 18658
+MD5 (dwm-4.4.tar.gz) = 8e234602b0c878f364de59eff591e158
+SHA256 (dwm-4.4.tar.gz) = 1320cc1730fce2a4c10f215597dba49338eaf596ae5a5f392d1111b69d69ffb8
+SIZE (dwm-4.4.tar.gz) = 19089
diff --git a/x11-wm/dwm/files/patch-config.mk b/x11-wm/dwm/files/patch-config.mk
index b7c310701574..9aefee3dce5f 100644
--- a/x11-wm/dwm/files/patch-config.mk
+++ b/x11-wm/dwm/files/patch-config.mk
@@ -1,7 +1,7 @@
---- config.mk.orig Mon May 21 14:37:17 2007
-+++ config.mk Mon May 21 18:20:11 2007
-@@ -4,18 +4,18 @@
- # Customize below to fit your system
+--- config.mk.orig Mon Aug 20 00:36:39 2007
++++ config.mk Mon Aug 20 00:48:16 2007
+@@ -7,19 +7,19 @@
+ SRC = tile.c
# paths
-PREFIX = /usr/local
@@ -20,12 +20,13 @@
# flags
-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
-+CFLAGS+= ${INCS} -DVERSION=\"${VERSION}\"
-LDFLAGS = -s ${LIBS}
++CFLAGS+= ${INCS} -DVERSION=\"${VERSION}\"
+LDFLAGS+= ${LIBS}
#CFLAGS = -g -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
#LDFLAGS = -g ${LIBS}
-@@ -26,4 +26,4 @@
+
+@@ -29,4 +29,4 @@
#CFLAGS += -xtarget=ultra
# compiler and linker