aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/db48/Makefile2
-rw-r--r--databases/db5/Makefile2
-rw-r--r--databases/db6/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index d8e5c39b1085..3e010b76e8f9 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -35,7 +35,7 @@ USE_LDCONFIG= yes
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db48 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db5/Makefile b/databases/db5/Makefile
index 822a53846031..95187b664bc1 100644
--- a/databases/db5/Makefile
+++ b/databases/db5/Makefile
@@ -39,7 +39,7 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db5 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif
diff --git a/databases/db6/Makefile b/databases/db6/Makefile
index 2c9f3312a047..f5d648573d6f 100644
--- a/databases/db6/Makefile
+++ b/databases/db6/Makefile
@@ -40,7 +40,7 @@ SQL_DESC= Enable SQL API (EXPERIMENTAL)
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6"
+.if ${ARCH} == "aarch64" || ${ARCH} == "armv6"
# db6 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
CONFIGURE_ARGS+= --enable-posixmutexes
.endif