aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/ion-2/Makefile20
-rw-r--r--x11-wm/ion-2/distinfo1
-rw-r--r--x11-wm/ion-2/files/patch-ion-edit9
-rw-r--r--x11-wm/ion-2/files/patch-ion-view18
-rw-r--r--x11-wm/ion-2/files/patch-system.mk49
-rw-r--r--x11-wm/ion-2/pkg-comment1
-rw-r--r--x11-wm/ion-2/pkg-descr23
-rw-r--r--x11-wm/ion-2/pkg-plist22
-rw-r--r--x11-wm/ion-devel/Makefile20
-rw-r--r--x11-wm/ion-devel/distinfo1
-rw-r--r--x11-wm/ion-devel/files/patch-ion-edit9
-rw-r--r--x11-wm/ion-devel/files/patch-ion-view18
-rw-r--r--x11-wm/ion-devel/files/patch-system.mk49
-rw-r--r--x11-wm/ion-devel/pkg-comment1
-rw-r--r--x11-wm/ion-devel/pkg-descr23
-rw-r--r--x11-wm/ion-devel/pkg-plist22
-rw-r--r--x11-wm/ion/Makefile20
-rw-r--r--x11-wm/ion/distinfo1
-rw-r--r--x11-wm/ion/files/patch-ion-edit9
-rw-r--r--x11-wm/ion/files/patch-ion-view18
-rw-r--r--x11-wm/ion/files/patch-system.mk49
-rw-r--r--x11-wm/ion/pkg-comment1
-rw-r--r--x11-wm/ion/pkg-descr23
-rw-r--r--x11-wm/ion/pkg-plist22
-rw-r--r--x11-wm/ion3/Makefile20
-rw-r--r--x11-wm/ion3/distinfo1
-rw-r--r--x11-wm/ion3/files/patch-ion-edit9
-rw-r--r--x11-wm/ion3/files/patch-ion-view18
-rw-r--r--x11-wm/ion3/files/patch-system.mk49
-rw-r--r--x11-wm/ion3/pkg-comment1
-rw-r--r--x11-wm/ion3/pkg-descr23
-rw-r--r--x11-wm/ion3/pkg-plist22
33 files changed, 573 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index a413f51dbd0e..3f979d14a8c4 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -28,6 +28,7 @@
SUBDIR += gwm
SUBDIR += icepref
SUBDIR += icewm
+ SUBDIR += ion
SUBDIR += larswm
SUBDIR += libdockapp
SUBDIR += libepplet
diff --git a/x11-wm/ion-2/Makefile b/x11-wm/ion-2/Makefile
new file mode 100644
index 000000000000..6a4fcc1a265c
--- /dev/null
+++ b/x11-wm/ion-2/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ion
+# Date created: 20 January 2001
+# Whom: ricci@cs.utah.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ion
+PORTVERSION= 20010106
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.students.tut.fi/~tuomov/dl/
+
+MAINTAINER= ricci@cs.utah.edu
+
+MAN1= ion.1x
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ion-2/distinfo b/x11-wm/ion-2/distinfo
new file mode 100644
index 000000000000..644c4f8c0ab9
--- /dev/null
+++ b/x11-wm/ion-2/distinfo
@@ -0,0 +1 @@
+MD5 (ion-20010106.tar.gz) = d192a99e71491f4d4e5e9432e1b003c3
diff --git a/x11-wm/ion-2/files/patch-ion-edit b/x11-wm/ion-2/files/patch-ion-edit
new file mode 100644
index 000000000000..b1313ff1a951
--- /dev/null
+++ b/x11-wm/ion-2/files/patch-ion-edit
@@ -0,0 +1,9 @@
+*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
+--- scripts/ion-edit Sat Jan 20 01:51:17 2001
+***************
+*** 1,2 ****
+ #!/bin/sh
+! exec run-mailcap --action=edit "$1" > /dev/null
+--- 1,2 ----
+ #!/bin/sh
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion-2/files/patch-ion-view b/x11-wm/ion-2/files/patch-ion-view
new file mode 100644
index 000000000000..689e8a514757
--- /dev/null
+++ b/x11-wm/ion-2/files/patch-ion-view
@@ -0,0 +1,18 @@
+*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
+--- scripts/ion-view Sat Jan 20 01:55:39 2001
+***************
+*** 1,7 ****
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape-remote "$1"
+ else
+! exec run-mailcap --action=view "$1" > /dev/null
+ fi
+
+--- 1,7 ----
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape "$1"
+ else
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
+ fi
diff --git a/x11-wm/ion-2/files/patch-system.mk b/x11-wm/ion-2/files/patch-system.mk
new file mode 100644
index 000000000000..b4356a1ab07f
--- /dev/null
+++ b/x11-wm/ion-2/files/patch-system.mk
@@ -0,0 +1,49 @@
+--- system.mk.orig Thu Dec 28 21:42:07 2000
++++ system.mk Sun Jan 21 05:24:15 2001
+@@ -7,13 +7,13 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # No need to modify these usually
+ BINDIR=$(PREFIX)/bin
+ ETCDIR=$(PREFIX)/etc
+ MANDIR=$(PREFIX)/man
+-DOCDIR=$(PREFIX)/doc
++DOCDIR=$(PREFIX)/share/doc
+ # Not used
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib
+@@ -23,7 +23,7 @@
+ ## X libraries, includes and options
+ ##
+
+-X11_PREFIX=/usr/X11R6
++X11_PREFIX=$(X11BASE)
+
+ # SunOS/Solaris
+ #X11_PREFIX=/usr/openwin
+@@ -78,8 +78,8 @@
+ -Wparentheses -pedantic-errors -Wuninitialized
+
+
+-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+
+
+ ##
+@@ -104,9 +104,9 @@
+ ##
+
+ # Should work almost everywhere
+-INSTALL=install
++#INSTALL=install
+ # On a system with pure BSD install, -c might be preferred
+-#INSTALL=install -c
++INSTALL=install -c
+
+ INSTALLDIR=mkdir -p
diff --git a/x11-wm/ion-2/pkg-comment b/x11-wm/ion-2/pkg-comment
new file mode 100644
index 000000000000..da99ae290dd5
--- /dev/null
+++ b/x11-wm/ion-2/pkg-comment
@@ -0,0 +1 @@
+A window manager with a text-editorish, keyboard friendly interface
diff --git a/x11-wm/ion-2/pkg-descr b/x11-wm/ion-2/pkg-descr
new file mode 100644
index 000000000000..6836b64dbe47
--- /dev/null
+++ b/x11-wm/ion-2/pkg-descr
@@ -0,0 +1,23 @@
+Ion (based on PWM) is a new kind of window manager that brings a
+text-editorish, keyboard friendly user interface to window management.
+
+Modern GUIs are unusable. Overlapping windows are hard to manage, especially
+from the keyboard, and the user often ends up in a jungle. Not to mention the
+application programs, which are even worse. Mouse-based search-and-click
+interfaces are slow - keyboard is fast having learnt the commands. Ion (the
+last three letters of vision =-) was written as an example and an experiment of
+something presumably better (just the window manager, though).
+
+Ion simply divides the screen into frames that take the whole screen. Big
+displays have so much space that this is convenient and smaller displays
+couldn't show more than one window at a time anyway. The frames can be split
+and growing the size of one will shrink others. Alike in PWM, clients can be
+moved between frames and multiple clients can be attached to one frame.
+
+With Ion you will hardly ever have to touch the mouse again for navigation
+between windows and the windows are always in order.
+
+WWW: http://www.students.tut.fi/~tuomov/ion/
+
+-- Robert Ricci
+ ricci@cs.utah.edu
diff --git a/x11-wm/ion-2/pkg-plist b/x11-wm/ion-2/pkg-plist
new file mode 100644
index 000000000000..58d5e79a687b
--- /dev/null
+++ b/x11-wm/ion-2/pkg-plist
@@ -0,0 +1,22 @@
+bin/ion
+bin/ion-edit
+bin/ion-man
+bin/ion-runinxterm
+bin/ion-ssh
+bin/ion-view
+etc/ion/bindings-default.conf
+etc/ion/bindings-sun.conf
+etc/ion/kludges.conf
+etc/ion/look-brownsteel.conf
+etc/ion/look-greyviolet.conf
+etc/ion/look-simpleblue.conf
+etc/ion/look-wheat.conf
+etc/ion/sample.conf
+etc/ion/ion.conf
+%%PORTDOCS%%share/doc/ion/README
+%%PORTDOCS%%share/doc/ion/LICENSE
+%%PORTDOCS%%share/doc/ion/ChangeLog
+%%PORTDOCS%%share/doc/ion/config.txt
+%%PORTDOCS%%share/doc/ion/functions.txt
+%%PORTDOCS%%@dirrm share/doc/ion
+@dirrm etc/ion
diff --git a/x11-wm/ion-devel/Makefile b/x11-wm/ion-devel/Makefile
new file mode 100644
index 000000000000..6a4fcc1a265c
--- /dev/null
+++ b/x11-wm/ion-devel/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ion
+# Date created: 20 January 2001
+# Whom: ricci@cs.utah.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ion
+PORTVERSION= 20010106
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.students.tut.fi/~tuomov/dl/
+
+MAINTAINER= ricci@cs.utah.edu
+
+MAN1= ion.1x
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ion-devel/distinfo b/x11-wm/ion-devel/distinfo
new file mode 100644
index 000000000000..644c4f8c0ab9
--- /dev/null
+++ b/x11-wm/ion-devel/distinfo
@@ -0,0 +1 @@
+MD5 (ion-20010106.tar.gz) = d192a99e71491f4d4e5e9432e1b003c3
diff --git a/x11-wm/ion-devel/files/patch-ion-edit b/x11-wm/ion-devel/files/patch-ion-edit
new file mode 100644
index 000000000000..b1313ff1a951
--- /dev/null
+++ b/x11-wm/ion-devel/files/patch-ion-edit
@@ -0,0 +1,9 @@
+*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
+--- scripts/ion-edit Sat Jan 20 01:51:17 2001
+***************
+*** 1,2 ****
+ #!/bin/sh
+! exec run-mailcap --action=edit "$1" > /dev/null
+--- 1,2 ----
+ #!/bin/sh
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion-devel/files/patch-ion-view b/x11-wm/ion-devel/files/patch-ion-view
new file mode 100644
index 000000000000..689e8a514757
--- /dev/null
+++ b/x11-wm/ion-devel/files/patch-ion-view
@@ -0,0 +1,18 @@
+*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
+--- scripts/ion-view Sat Jan 20 01:55:39 2001
+***************
+*** 1,7 ****
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape-remote "$1"
+ else
+! exec run-mailcap --action=view "$1" > /dev/null
+ fi
+
+--- 1,7 ----
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape "$1"
+ else
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
+ fi
diff --git a/x11-wm/ion-devel/files/patch-system.mk b/x11-wm/ion-devel/files/patch-system.mk
new file mode 100644
index 000000000000..b4356a1ab07f
--- /dev/null
+++ b/x11-wm/ion-devel/files/patch-system.mk
@@ -0,0 +1,49 @@
+--- system.mk.orig Thu Dec 28 21:42:07 2000
++++ system.mk Sun Jan 21 05:24:15 2001
+@@ -7,13 +7,13 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # No need to modify these usually
+ BINDIR=$(PREFIX)/bin
+ ETCDIR=$(PREFIX)/etc
+ MANDIR=$(PREFIX)/man
+-DOCDIR=$(PREFIX)/doc
++DOCDIR=$(PREFIX)/share/doc
+ # Not used
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib
+@@ -23,7 +23,7 @@
+ ## X libraries, includes and options
+ ##
+
+-X11_PREFIX=/usr/X11R6
++X11_PREFIX=$(X11BASE)
+
+ # SunOS/Solaris
+ #X11_PREFIX=/usr/openwin
+@@ -78,8 +78,8 @@
+ -Wparentheses -pedantic-errors -Wuninitialized
+
+
+-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+
+
+ ##
+@@ -104,9 +104,9 @@
+ ##
+
+ # Should work almost everywhere
+-INSTALL=install
++#INSTALL=install
+ # On a system with pure BSD install, -c might be preferred
+-#INSTALL=install -c
++INSTALL=install -c
+
+ INSTALLDIR=mkdir -p
diff --git a/x11-wm/ion-devel/pkg-comment b/x11-wm/ion-devel/pkg-comment
new file mode 100644
index 000000000000..da99ae290dd5
--- /dev/null
+++ b/x11-wm/ion-devel/pkg-comment
@@ -0,0 +1 @@
+A window manager with a text-editorish, keyboard friendly interface
diff --git a/x11-wm/ion-devel/pkg-descr b/x11-wm/ion-devel/pkg-descr
new file mode 100644
index 000000000000..6836b64dbe47
--- /dev/null
+++ b/x11-wm/ion-devel/pkg-descr
@@ -0,0 +1,23 @@
+Ion (based on PWM) is a new kind of window manager that brings a
+text-editorish, keyboard friendly user interface to window management.
+
+Modern GUIs are unusable. Overlapping windows are hard to manage, especially
+from the keyboard, and the user often ends up in a jungle. Not to mention the
+application programs, which are even worse. Mouse-based search-and-click
+interfaces are slow - keyboard is fast having learnt the commands. Ion (the
+last three letters of vision =-) was written as an example and an experiment of
+something presumably better (just the window manager, though).
+
+Ion simply divides the screen into frames that take the whole screen. Big
+displays have so much space that this is convenient and smaller displays
+couldn't show more than one window at a time anyway. The frames can be split
+and growing the size of one will shrink others. Alike in PWM, clients can be
+moved between frames and multiple clients can be attached to one frame.
+
+With Ion you will hardly ever have to touch the mouse again for navigation
+between windows and the windows are always in order.
+
+WWW: http://www.students.tut.fi/~tuomov/ion/
+
+-- Robert Ricci
+ ricci@cs.utah.edu
diff --git a/x11-wm/ion-devel/pkg-plist b/x11-wm/ion-devel/pkg-plist
new file mode 100644
index 000000000000..58d5e79a687b
--- /dev/null
+++ b/x11-wm/ion-devel/pkg-plist
@@ -0,0 +1,22 @@
+bin/ion
+bin/ion-edit
+bin/ion-man
+bin/ion-runinxterm
+bin/ion-ssh
+bin/ion-view
+etc/ion/bindings-default.conf
+etc/ion/bindings-sun.conf
+etc/ion/kludges.conf
+etc/ion/look-brownsteel.conf
+etc/ion/look-greyviolet.conf
+etc/ion/look-simpleblue.conf
+etc/ion/look-wheat.conf
+etc/ion/sample.conf
+etc/ion/ion.conf
+%%PORTDOCS%%share/doc/ion/README
+%%PORTDOCS%%share/doc/ion/LICENSE
+%%PORTDOCS%%share/doc/ion/ChangeLog
+%%PORTDOCS%%share/doc/ion/config.txt
+%%PORTDOCS%%share/doc/ion/functions.txt
+%%PORTDOCS%%@dirrm share/doc/ion
+@dirrm etc/ion
diff --git a/x11-wm/ion/Makefile b/x11-wm/ion/Makefile
new file mode 100644
index 000000000000..6a4fcc1a265c
--- /dev/null
+++ b/x11-wm/ion/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ion
+# Date created: 20 January 2001
+# Whom: ricci@cs.utah.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ion
+PORTVERSION= 20010106
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.students.tut.fi/~tuomov/dl/
+
+MAINTAINER= ricci@cs.utah.edu
+
+MAN1= ion.1x
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ion/distinfo b/x11-wm/ion/distinfo
new file mode 100644
index 000000000000..644c4f8c0ab9
--- /dev/null
+++ b/x11-wm/ion/distinfo
@@ -0,0 +1 @@
+MD5 (ion-20010106.tar.gz) = d192a99e71491f4d4e5e9432e1b003c3
diff --git a/x11-wm/ion/files/patch-ion-edit b/x11-wm/ion/files/patch-ion-edit
new file mode 100644
index 000000000000..b1313ff1a951
--- /dev/null
+++ b/x11-wm/ion/files/patch-ion-edit
@@ -0,0 +1,9 @@
+*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
+--- scripts/ion-edit Sat Jan 20 01:51:17 2001
+***************
+*** 1,2 ****
+ #!/bin/sh
+! exec run-mailcap --action=edit "$1" > /dev/null
+--- 1,2 ----
+ #!/bin/sh
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion/files/patch-ion-view b/x11-wm/ion/files/patch-ion-view
new file mode 100644
index 000000000000..689e8a514757
--- /dev/null
+++ b/x11-wm/ion/files/patch-ion-view
@@ -0,0 +1,18 @@
+*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
+--- scripts/ion-view Sat Jan 20 01:55:39 2001
+***************
+*** 1,7 ****
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape-remote "$1"
+ else
+! exec run-mailcap --action=view "$1" > /dev/null
+ fi
+
+--- 1,7 ----
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape "$1"
+ else
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
+ fi
diff --git a/x11-wm/ion/files/patch-system.mk b/x11-wm/ion/files/patch-system.mk
new file mode 100644
index 000000000000..b4356a1ab07f
--- /dev/null
+++ b/x11-wm/ion/files/patch-system.mk
@@ -0,0 +1,49 @@
+--- system.mk.orig Thu Dec 28 21:42:07 2000
++++ system.mk Sun Jan 21 05:24:15 2001
+@@ -7,13 +7,13 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # No need to modify these usually
+ BINDIR=$(PREFIX)/bin
+ ETCDIR=$(PREFIX)/etc
+ MANDIR=$(PREFIX)/man
+-DOCDIR=$(PREFIX)/doc
++DOCDIR=$(PREFIX)/share/doc
+ # Not used
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib
+@@ -23,7 +23,7 @@
+ ## X libraries, includes and options
+ ##
+
+-X11_PREFIX=/usr/X11R6
++X11_PREFIX=$(X11BASE)
+
+ # SunOS/Solaris
+ #X11_PREFIX=/usr/openwin
+@@ -78,8 +78,8 @@
+ -Wparentheses -pedantic-errors -Wuninitialized
+
+
+-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+
+
+ ##
+@@ -104,9 +104,9 @@
+ ##
+
+ # Should work almost everywhere
+-INSTALL=install
++#INSTALL=install
+ # On a system with pure BSD install, -c might be preferred
+-#INSTALL=install -c
++INSTALL=install -c
+
+ INSTALLDIR=mkdir -p
diff --git a/x11-wm/ion/pkg-comment b/x11-wm/ion/pkg-comment
new file mode 100644
index 000000000000..da99ae290dd5
--- /dev/null
+++ b/x11-wm/ion/pkg-comment
@@ -0,0 +1 @@
+A window manager with a text-editorish, keyboard friendly interface
diff --git a/x11-wm/ion/pkg-descr b/x11-wm/ion/pkg-descr
new file mode 100644
index 000000000000..6836b64dbe47
--- /dev/null
+++ b/x11-wm/ion/pkg-descr
@@ -0,0 +1,23 @@
+Ion (based on PWM) is a new kind of window manager that brings a
+text-editorish, keyboard friendly user interface to window management.
+
+Modern GUIs are unusable. Overlapping windows are hard to manage, especially
+from the keyboard, and the user often ends up in a jungle. Not to mention the
+application programs, which are even worse. Mouse-based search-and-click
+interfaces are slow - keyboard is fast having learnt the commands. Ion (the
+last three letters of vision =-) was written as an example and an experiment of
+something presumably better (just the window manager, though).
+
+Ion simply divides the screen into frames that take the whole screen. Big
+displays have so much space that this is convenient and smaller displays
+couldn't show more than one window at a time anyway. The frames can be split
+and growing the size of one will shrink others. Alike in PWM, clients can be
+moved between frames and multiple clients can be attached to one frame.
+
+With Ion you will hardly ever have to touch the mouse again for navigation
+between windows and the windows are always in order.
+
+WWW: http://www.students.tut.fi/~tuomov/ion/
+
+-- Robert Ricci
+ ricci@cs.utah.edu
diff --git a/x11-wm/ion/pkg-plist b/x11-wm/ion/pkg-plist
new file mode 100644
index 000000000000..58d5e79a687b
--- /dev/null
+++ b/x11-wm/ion/pkg-plist
@@ -0,0 +1,22 @@
+bin/ion
+bin/ion-edit
+bin/ion-man
+bin/ion-runinxterm
+bin/ion-ssh
+bin/ion-view
+etc/ion/bindings-default.conf
+etc/ion/bindings-sun.conf
+etc/ion/kludges.conf
+etc/ion/look-brownsteel.conf
+etc/ion/look-greyviolet.conf
+etc/ion/look-simpleblue.conf
+etc/ion/look-wheat.conf
+etc/ion/sample.conf
+etc/ion/ion.conf
+%%PORTDOCS%%share/doc/ion/README
+%%PORTDOCS%%share/doc/ion/LICENSE
+%%PORTDOCS%%share/doc/ion/ChangeLog
+%%PORTDOCS%%share/doc/ion/config.txt
+%%PORTDOCS%%share/doc/ion/functions.txt
+%%PORTDOCS%%@dirrm share/doc/ion
+@dirrm etc/ion
diff --git a/x11-wm/ion3/Makefile b/x11-wm/ion3/Makefile
new file mode 100644
index 000000000000..6a4fcc1a265c
--- /dev/null
+++ b/x11-wm/ion3/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ion
+# Date created: 20 January 2001
+# Whom: ricci@cs.utah.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ion
+PORTVERSION= 20010106
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.students.tut.fi/~tuomov/dl/
+
+MAINTAINER= ricci@cs.utah.edu
+
+MAN1= ion.1x
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-wm/ion3/distinfo b/x11-wm/ion3/distinfo
new file mode 100644
index 000000000000..644c4f8c0ab9
--- /dev/null
+++ b/x11-wm/ion3/distinfo
@@ -0,0 +1 @@
+MD5 (ion-20010106.tar.gz) = d192a99e71491f4d4e5e9432e1b003c3
diff --git a/x11-wm/ion3/files/patch-ion-edit b/x11-wm/ion3/files/patch-ion-edit
new file mode 100644
index 000000000000..b1313ff1a951
--- /dev/null
+++ b/x11-wm/ion3/files/patch-ion-edit
@@ -0,0 +1,9 @@
+*** scripts/ion-edit.orig Sat Jan 20 01:43:39 2001
+--- scripts/ion-edit Sat Jan 20 01:51:17 2001
+***************
+*** 1,2 ****
+ #!/bin/sh
+! exec run-mailcap --action=edit "$1" > /dev/null
+--- 1,2 ----
+ #!/bin/sh
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
diff --git a/x11-wm/ion3/files/patch-ion-view b/x11-wm/ion3/files/patch-ion-view
new file mode 100644
index 000000000000..689e8a514757
--- /dev/null
+++ b/x11-wm/ion3/files/patch-ion-view
@@ -0,0 +1,18 @@
+*** scripts/ion-view.orig Sat Jan 20 01:44:05 2001
+--- scripts/ion-view Sat Jan 20 01:55:39 2001
+***************
+*** 1,7 ****
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape-remote "$1"
+ else
+! exec run-mailcap --action=view "$1" > /dev/null
+ fi
+
+--- 1,7 ----
+ #!/bin/sh
+ if echo "$1"|grep -E '^([a-zA-Z]+://|www.)' > /dev/null; then
+! exec netscape "$1"
+ else
+! exec ion-runinxterm -T $1 $EDITOR "$1" > /dev/null
+ fi
diff --git a/x11-wm/ion3/files/patch-system.mk b/x11-wm/ion3/files/patch-system.mk
new file mode 100644
index 000000000000..b4356a1ab07f
--- /dev/null
+++ b/x11-wm/ion3/files/patch-system.mk
@@ -0,0 +1,49 @@
+--- system.mk.orig Thu Dec 28 21:42:07 2000
++++ system.mk Sun Jan 21 05:24:15 2001
+@@ -7,13 +7,13 @@
+ ## Installation paths
+ ##
+
+-PREFIX=/usr/local
++#PREFIX=/usr/local
+
+ # No need to modify these usually
+ BINDIR=$(PREFIX)/bin
+ ETCDIR=$(PREFIX)/etc
+ MANDIR=$(PREFIX)/man
+-DOCDIR=$(PREFIX)/doc
++DOCDIR=$(PREFIX)/share/doc
+ # Not used
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib
+@@ -23,7 +23,7 @@
+ ## X libraries, includes and options
+ ##
+
+-X11_PREFIX=/usr/X11R6
++X11_PREFIX=$(X11BASE)
+
+ # SunOS/Solaris
+ #X11_PREFIX=/usr/openwin
+@@ -78,8 +78,8 @@
+ -Wparentheses -pedantic-errors -Wuninitialized
+
+
+-CFLAGS=-g -O2 $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
+-LDFLAGS=-g $(LIBS) $(EXTRA_LIBS)
++CFLAGS+= $(WARN) $(DEFINES) $(INCLUDES) $(EXTRA_INCLUDES)
++LDFLAGS= $(LIBS) $(EXTRA_LIBS)
+
+
+ ##
+@@ -104,9 +104,9 @@
+ ##
+
+ # Should work almost everywhere
+-INSTALL=install
++#INSTALL=install
+ # On a system with pure BSD install, -c might be preferred
+-#INSTALL=install -c
++INSTALL=install -c
+
+ INSTALLDIR=mkdir -p
diff --git a/x11-wm/ion3/pkg-comment b/x11-wm/ion3/pkg-comment
new file mode 100644
index 000000000000..da99ae290dd5
--- /dev/null
+++ b/x11-wm/ion3/pkg-comment
@@ -0,0 +1 @@
+A window manager with a text-editorish, keyboard friendly interface
diff --git a/x11-wm/ion3/pkg-descr b/x11-wm/ion3/pkg-descr
new file mode 100644
index 000000000000..6836b64dbe47
--- /dev/null
+++ b/x11-wm/ion3/pkg-descr
@@ -0,0 +1,23 @@
+Ion (based on PWM) is a new kind of window manager that brings a
+text-editorish, keyboard friendly user interface to window management.
+
+Modern GUIs are unusable. Overlapping windows are hard to manage, especially
+from the keyboard, and the user often ends up in a jungle. Not to mention the
+application programs, which are even worse. Mouse-based search-and-click
+interfaces are slow - keyboard is fast having learnt the commands. Ion (the
+last three letters of vision =-) was written as an example and an experiment of
+something presumably better (just the window manager, though).
+
+Ion simply divides the screen into frames that take the whole screen. Big
+displays have so much space that this is convenient and smaller displays
+couldn't show more than one window at a time anyway. The frames can be split
+and growing the size of one will shrink others. Alike in PWM, clients can be
+moved between frames and multiple clients can be attached to one frame.
+
+With Ion you will hardly ever have to touch the mouse again for navigation
+between windows and the windows are always in order.
+
+WWW: http://www.students.tut.fi/~tuomov/ion/
+
+-- Robert Ricci
+ ricci@cs.utah.edu
diff --git a/x11-wm/ion3/pkg-plist b/x11-wm/ion3/pkg-plist
new file mode 100644
index 000000000000..58d5e79a687b
--- /dev/null
+++ b/x11-wm/ion3/pkg-plist
@@ -0,0 +1,22 @@
+bin/ion
+bin/ion-edit
+bin/ion-man
+bin/ion-runinxterm
+bin/ion-ssh
+bin/ion-view
+etc/ion/bindings-default.conf
+etc/ion/bindings-sun.conf
+etc/ion/kludges.conf
+etc/ion/look-brownsteel.conf
+etc/ion/look-greyviolet.conf
+etc/ion/look-simpleblue.conf
+etc/ion/look-wheat.conf
+etc/ion/sample.conf
+etc/ion/ion.conf
+%%PORTDOCS%%share/doc/ion/README
+%%PORTDOCS%%share/doc/ion/LICENSE
+%%PORTDOCS%%share/doc/ion/ChangeLog
+%%PORTDOCS%%share/doc/ion/config.txt
+%%PORTDOCS%%share/doc/ion/functions.txt
+%%PORTDOCS%%@dirrm share/doc/ion
+@dirrm etc/ion