aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/metakit/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index d9405a631b92..abc9f5b1ae72 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -58,10 +58,16 @@ PLIST_SUB+= WITH_TCL=""
PLIST_SUB+= WITH_TCL="@comment "
.endif
+.include <bsd.port.pre.mk>
+
pre-patch:
@${PERL5} -pi -e "s/= tclsh/=tclsh${TCL_V}/" \
${WRKSRC}/../unix/Makefile.in
@${PERL5} -pi -e "s=doc/==" ${WRKSRC}/../MetaKit.html
+.if defined(METAKIT_WITH_PYTHON)
+ ${PERL5} -pi -e "s=python2.1=${PYTHON_VERSION}=" \
+ ${WRKSRC}/../unix/Makefile.in
+.endif
post-install:
.if defined(METAKIT_WITH_PYTHON)
@@ -83,4 +89,4 @@ test:
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test-tcl)
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>