aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-uulib/Makefile46
-rw-r--r--devel/hs-uulib/distinfo3
-rw-r--r--devel/hs-uulib/pkg-descr24
-rw-r--r--devel/hs-uulib/pkg-plist53
5 files changed, 127 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a1828c4086e2..21e50a6a35ff 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -469,6 +469,7 @@
SUBDIR += hs-hpl
SUBDIR += hs-idoc
SUBDIR += hs-tclhaskell-ghc
+ SUBDIR += hs-uulib
SUBDIR += hypersrc
SUBDIR += i386-rtems-binutils
SUBDIR += i386-rtems-g77
diff --git a/devel/hs-uulib/Makefile b/devel/hs-uulib/Makefile
new file mode 100644
index 000000000000..575407918600
--- /dev/null
+++ b/devel/hs-uulib/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: hs-uulib
+# Date created: February 27 2008
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uulib
+PORTVERSION= 0.9.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Haskell Utrecht Tools Library
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.8.2
+UULIB_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+UULIB_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ UULIB_VERSION=${UULIB_VERSION} \
+ UULIB_LIBDIR_REL=${UULIB_LIBDIR_REL}
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${UULIB_LIBDIR_REL}/register.sh
+
+.include <bsd.port.mk>
diff --git a/devel/hs-uulib/distinfo b/devel/hs-uulib/distinfo
new file mode 100644
index 000000000000..dcd0eacdaba7
--- /dev/null
+++ b/devel/hs-uulib/distinfo
@@ -0,0 +1,3 @@
+MD5 (uulib-0.9.5.tar.gz) = 606dec3a8ea8797421e795336392f02f
+SHA256 (uulib-0.9.5.tar.gz) = 38415725133af464de582dadc7d7e60b1aeb96344b18b239d176bf2181f98563
+SIZE (uulib-0.9.5.tar.gz) = 93618
diff --git a/devel/hs-uulib/pkg-descr b/devel/hs-uulib/pkg-descr
new file mode 100644
index 000000000000..05502b0220e5
--- /dev/null
+++ b/devel/hs-uulib/pkg-descr
@@ -0,0 +1,24 @@
+Fast Parser Combinators and Pretty Printing Combinators
+libraries by the Utrecht University.
+
+author:
+maintainer: Arie Middelkoop <ariem@cs.uu.nl>
+license: LGPL-2.1
+WWW: http://www.cs.uu.nl/wiki/HUT/AttributeGrammarSystem
+package-url: http://nix.cs.uu.nl/dist/hut/
+
+exposed-modules:
+ UU.Parsing.CharParser UU.Parsing.Derived
+ UU.Parsing.Interface UU.Parsing.MachineInterface
+ UU.Parsing.Merge UU.Parsing.Offside UU.Parsing.Perms
+ UU.Parsing.StateParser UU.Parsing UU.DData.IntBag
+ UU.DData.Map UU.DData.MultiSet UU.DData.Queue
+ UU.DData.Scc UU.DData.Seq UU.DData.Set UU.PPrint
+ UU.Pretty.Ext UU.Pretty UU.Scanner.GenToken UU.Scanner.GenTokenOrd
+ UU.Scanner.GenTokenParser UU.Scanner.GenTokenSymbol
+ UU.Scanner.Position UU.Scanner.Scanner
+ UU.Scanner.Token UU.Scanner.TokenParser UU.Scanner.TokenShow
+ UU.Scanner UU.Util.BinaryTrees UU.Util.PermTree UU.Util.Utils
+ UU.Pretty.Basic UU.Parsing.Machine
+ UU.DData.IntMap
+ UU.DData.IntSet
diff --git a/devel/hs-uulib/pkg-plist b/devel/hs-uulib/pkg-plist
new file mode 100644
index 000000000000..c1c11961d535
--- /dev/null
+++ b/devel/hs-uulib/pkg-plist
@@ -0,0 +1,53 @@
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HSuulib-%%UULIB_VERSION%%.o
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/IntBag.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/IntMap.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/IntSet.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/Map.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/MultiSet.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/Queue.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/Scc.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/Seq.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData/Set.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/PPrint.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/CharParser.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Derived.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Interface.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Machine.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/MachineInterface.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Merge.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Offside.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/Perms.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing/StateParser.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Pretty.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Pretty/Basic.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Pretty/Ext.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/GenToken.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/GenTokenOrd.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/GenTokenParser.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/GenTokenSymbol.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/Position.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/Scanner.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/Token.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/TokenParser.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner/TokenShow.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Util/BinaryTrees.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Util/PermTree.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Util/Utils.hi
+%%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHSuulib-%%UULIB_VERSION%%.a
+%%UULIB_LIBDIR_REL%%/register.sh
+%%DOCSDIR%%/COPYRIGHT
+@dirrm %%DOCSDIR%%
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Util
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Scanner
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Pretty
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/Parsing
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU/DData
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/UU
+@dirrm %%UULIB_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%UULIB_LIBDIR_REL%%
+@exec /bin/sh %D/%%UULIB_LIBDIR_REL%%/register.sh
+@exec rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec if [ -x %D/bin/ghc-pkg ]; then %D/bin/ghc-pkg unregister uulib || /usr/bin/true; fi
+@unexec if [ -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old ]; then rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old || /usr/bin/true; fi