aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/ecasound/Makefile5
-rw-r--r--audio/jack/Makefile6
-rw-r--r--audio/lash/Makefile6
-rw-r--r--biology/mrbayes/Makefile3
-rw-r--r--cad/gnucap/Makefile5
-rw-r--r--deskutils/pal/Makefile6
-rw-r--r--devel/hs-haddock/Makefile6
-rw-r--r--devel/hs-hmake/Makefile4
-rw-r--r--devel/jtag/Makefile6
-rw-r--r--devel/omake/Makefile6
-rw-r--r--devel/urjtag/Makefile6
-rw-r--r--ftp/quftp/Makefile4
-rw-r--r--ftp/yafc/Makefile5
-rw-r--r--lang/clisp/Makefile3
-rw-r--r--lang/ghc/Makefile6
-rw-r--r--lang/ohugs/Makefile4
-rw-r--r--mail/abook/Makefile6
-rw-r--r--math/scilab/Makefile6
-rw-r--r--net/wire/Makefile5
-rw-r--r--security/osiris/Makefile5
20 files changed, 55 insertions, 48 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 3341ed301e80..82e88864c1ed 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ecasound
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/
@@ -38,8 +39,8 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.if defined(WITH_ARTS)
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 10485caad276..07d99ff2e6ad 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jackit
PORTVERSION= 0.116.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
@@ -41,8 +41,8 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
.endif
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
post-patch:
diff --git a/audio/lash/Makefile b/audio/lash/Makefile
index 6207119cc0f8..867fb7d8bde3 100644
--- a/audio/lash/Makefile
+++ b/audio/lash/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lash
PORTVERSION= 0.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://download.savannah.gnu.org/releases/lash/
@@ -27,8 +27,8 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>
diff --git a/biology/mrbayes/Makefile b/biology/mrbayes/Makefile
index 15384809bafe..8b6d02774b56 100644
--- a/biology/mrbayes/Makefile
+++ b/biology/mrbayes/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mrbayes
PORTVERSION= 3.1.2
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= SF
@@ -15,7 +16,7 @@ COMMENT= Bayesian inference of phylogeny
USE_GMAKE= yes
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
PLIST_FILES= bin/mb
diff --git a/cad/gnucap/Makefile b/cad/gnucap/Makefile
index ff639b2eb363..96101e267674 100644
--- a/cad/gnucap/Makefile
+++ b/cad/gnucap/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnucap
PORTVERSION= 2008.06.08
+PORTREVISION= 1
CATEGORIES= cad
MASTER_SITES= http://www.gnucap.org/devel/ \
http://www.gnucap.org/devel/archive/
@@ -26,8 +27,8 @@ MAN1= gnucap.1 gnucap-ibis.1
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_READLINE) || exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if !defined(WITHOUT_READLINE) || exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>
diff --git a/deskutils/pal/Makefile b/deskutils/pal/Makefile
index d8f0c9f19812..e53ff638f059 100644
--- a/deskutils/pal/Makefile
+++ b/deskutils/pal/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pal
PORTVERSION= 0.3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= palcal
@@ -25,8 +25,8 @@ MAN1= pal.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
.endif
post-patch:
diff --git a/devel/hs-haddock/Makefile b/devel/hs-haddock/Makefile
index ace2a14713c0..55e9b0d735b3 100644
--- a/devel/hs-haddock/Makefile
+++ b/devel/hs-haddock/Makefile
@@ -6,7 +6,7 @@
PORTNAME= haddock
PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/haddock/${PORTVERSION}/
PKGNAMEPREFIX= hs-
@@ -17,8 +17,8 @@ COMMENT= A documentation tool for Haskell
.if !defined(SLAVE)
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.else
diff --git a/devel/hs-hmake/Makefile b/devel/hs-hmake/Makefile
index 44fff25103ef..3df8f10ffb65 100644
--- a/devel/hs-hmake/Makefile
+++ b/devel/hs-hmake/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hmake
PORTVERSION= 3.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel haskell
MASTER_SITES= http://www.haskell.org/hmake/ \
ftp://ftp.cs.york.ac.uk/pub/haskell/hmake/ \
@@ -19,7 +19,7 @@ COMMENT= Intelligent compilation management tool for Haskell programs
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
.if exists(${LOCALBASE}/lib/libreadline.so)
-LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
diff --git a/devel/jtag/Makefile b/devel/jtag/Makefile
index f38644942ab6..b3aa69780c6d 100644
--- a/devel/jtag/Makefile
+++ b/devel/jtag/Makefile
@@ -8,7 +8,7 @@
PORTNAME= jtag
PORTVERSION= 0.5.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=openwince
@@ -33,8 +33,8 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
post-extract:
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
index da1f7329d5e3..f4d1ca859e05 100644
--- a/devel/omake/Makefile
+++ b/devel/omake/Makefile
@@ -8,7 +8,7 @@
PORTNAME= omake
PORTVERSION= 0.9.8.5
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://omake.metaprl.org/downloads/
DISTNAME= omake-0.9.8.5-3
@@ -28,8 +28,8 @@ INFO= omake-doc
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.endif
diff --git a/devel/urjtag/Makefile b/devel/urjtag/Makefile
index cff04993927c..13682320528a 100644
--- a/devel/urjtag/Makefile
+++ b/devel/urjtag/Makefile
@@ -7,7 +7,7 @@
PORTNAME= urjtag
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
@@ -51,8 +51,8 @@ CONFIGURE_ARGS+= --with-libftdi
LIB_DEPENDS+= ftdi.15:${PORTSDIR}/devel/libftdi
.endif
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index a516385ab4e6..3495ec6d422f 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quftp
PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= quftp
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= quftp
MAINTAINER= ports@FreeBSD.org
COMMENT= A scriptable FTP client
-LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
GNU_CONFIGURE= yes
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index 98c7f58a72db..c383c528a15c 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= yafc
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,8 +29,8 @@ PLIST_DIRS= %%EXAMPLESDIR%%
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
post-install:
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index 3714c9283315..0231c6c26dea 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clisp
PORTVERSION= 2.47
+PORTREVISION= 1
CATEGORIES= lang lisp
MASTER_SITES= GNU/${PORTNAME}/release/${PORTVERSION}
@@ -14,7 +15,7 @@ MAINTAINER= jsa@wickedmachine.net
COMMENT= A Common Lisp implementation
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall
-LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline \
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline \
sigsegv.0:${PORTSDIR}/devel/libsigsegv
USE_ICONV= yes
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index c28f0b1bfc23..10ef748a00d2 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ghc
PORTVERSION= 6.8.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
http://www.haskell.org/ghc/dist/${PORTVERSION}/FreeBSD/:boot \
@@ -45,8 +45,8 @@ OPTIONS+= DOCS "Install HTML documentation" on
.undef WITH_DOCS
.endif
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.if ${ARCH} == "i386"
diff --git a/lang/ohugs/Makefile b/lang/ohugs/Makefile
index 0636eed888a9..6e1cb69d3168 100644
--- a/lang/ohugs/Makefile
+++ b/lang/ohugs/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ohugs
PORTVERSION= 0.5
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang haskell
MASTER_SITES= http://www.math.chalmers.se/~nordland/ohugs/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -14,7 +14,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= haskell@FreeBSD.org
COMMENT= Interpreter for Haskell with object-oriented features
-LIB_DEPENDS= readline.5:${PORTSDIR}/devel/readline
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
.if !defined(WITHOUT_X11)
LIB_DEPENDS+= tix8184:${PORTSDIR}/x11-toolkits/tix
.endif
diff --git a/mail/abook/Makefile b/mail/abook/Makefile
index a597453d4cfa..501475dc96a7 100644
--- a/mail/abook/Makefile
+++ b/mail/abook/Makefile
@@ -7,7 +7,7 @@
PORTNAME= abook
PORTVERSION= 0.5.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -36,8 +36,8 @@ PORTDOCS= ANNOUNCE AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
post-install:
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index fabddf092150..8ad209fe6569 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scilab
PORTVERSION= 4.1.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math cad parallel
MASTER_SITES= http://www.scilab.org/download/${PORTVERSION}/
EXTRACT_SUFX= -src.tar.gz
@@ -48,8 +48,8 @@ CONFIGURE_ENV+= PVM_ROOT=${LOCALBASE}/lib/pvm
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
diff --git a/net/wire/Makefile b/net/wire/Makefile
index f8e38277e275..95d579f5bde1 100644
--- a/net/wire/Makefile
+++ b/net/wire/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wire
PORTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.zankasoftware.com/dist/ \
${MASTER_SITE_LOCAL}
@@ -25,8 +26,8 @@ MAN1= wire.1
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.include <bsd.port.post.mk>
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
index 094a72cc4f21..a0a8f37be639 100644
--- a/security/osiris/Makefile
+++ b/security/osiris/Makefile
@@ -7,6 +7,7 @@
PORTNAME= osiris
PORTVERSION= 4.2.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://osiris.shmoo.com/data/ \
http://redundancy.redundancy.org/mirror/
@@ -24,8 +25,8 @@ USE_RC_SUBR= yes
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.5)
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+.if exists(${LOCALBASE}/lib/libreadline.so.6)
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
.endif
.if defined(WITH_OSIRISMD)