aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/tcpflow/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/net/tcpflow/Makefile b/net/tcpflow/Makefile
index 7c01300a09df..47c85896c635 100644
--- a/net/tcpflow/Makefile
+++ b/net/tcpflow/Makefile
@@ -18,14 +18,11 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= tcpflow.1
-PLIST_FILES= bin/tcpflow
+PLIST_FILES= bin/tcpflow man/man1/tcpflow.1.gz
+PORTDOCS= AUTHORS ChangeLog NEWS README
OPTIONS_DEFINE= DOCS
-PORTDOCS= AUTHORS ChangeLog NEWS README
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
@@ -35,8 +32,8 @@ CFLAGS+= -march=i586
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>