aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/yaxi/Makefile36
-rw-r--r--textproc/yaxi/distinfo2
-rw-r--r--textproc/yaxi/files/patch-Makefile20
-rw-r--r--textproc/yaxi/pkg-descr5
5 files changed, 64 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d9774bee117a..1bda639467aa 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -564,6 +564,7 @@
SUBDIR += xt
SUBDIR += xxdiff
SUBDIR += y2l
+ SUBDIR += yaxi
SUBDIR += yodl
.include <bsd.port.subdir.mk>
diff --git a/textproc/yaxi/Makefile b/textproc/yaxi/Makefile
new file mode 100644
index 000000000000..81075f50c8be
--- /dev/null
+++ b/textproc/yaxi/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: yaxi
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= yaxi
+PORTVERSION= 0.5.2
+CATEGORIES= textproc
+MASTER_SITES= http://mattam.ath.cx/progs/yaxi/releases/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Yet Another X* Implementation for OCaml
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
+ ${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
+ ${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ulex \
+ ${OCAML_SITELIBDIR}/camomile/camomile.a:${PORTSDIR}/devel/camomile
+RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
+ ${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
+ ${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ulex \
+ ${OCAML_SITELIBDIR}/camomile/camomile.a:${PORTSDIR}/devel/camomile
+
+OCAML_SITELIBDIR= ${LOCALBASE}/lib/ocaml/site-lib
+USE_GMAKE= yes
+
+PLIST_FILES= bin/yaxsltproc
+
+post-install:
+ @${ECHO_CMD} "@unexec ocamlfind remove yaxi 2>/dev/null || true" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/textproc/yaxi/distinfo b/textproc/yaxi/distinfo
new file mode 100644
index 000000000000..893792032634
--- /dev/null
+++ b/textproc/yaxi/distinfo
@@ -0,0 +1,2 @@
+MD5 (yaxi-0.5.2.tar.gz) = ea17a507207057e3489cf987a9a80b10
+SIZE (yaxi-0.5.2.tar.gz) = 69067
diff --git a/textproc/yaxi/files/patch-Makefile b/textproc/yaxi/files/patch-Makefile
new file mode 100644
index 000000000000..99b2f46ee10c
--- /dev/null
+++ b/textproc/yaxi/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Thu Mar 18 09:56:55 2004
++++ Makefile Thu Mar 18 09:57:50 2004
+@@ -3,7 +3,7 @@
+
+ export VERSION
+ # Where the binaries will go (yaxsltproc)
+-BIN_DESTDIR = ${DESTDIR}/usr/bin/
++BIN_DESTDIR = ${PREFIX}/bin
+
+ DIST_FILES = Makefile OCamlMakefile AUTHORS README COPYING ChangeLog META.in TODO \
+ examples/Makefile examples/*.ml examples/*.x*l
+@@ -41,7 +41,7 @@
+
+ install: all META
+ ocamlfind install yaxi META src/*.mli src/*.cm* src/*.a
+- install -D src/yaxsltproc ${BIN_DESTDIR}/yaxsltproc
++ ${BSD_INSTALL_PROGRAM} src/yaxsltproc ${BIN_DESTDIR}/yaxsltproc
+
+ dist: clean
+ mkdir tmp/yaxi-$(VERSION)
diff --git a/textproc/yaxi/pkg-descr b/textproc/yaxi/pkg-descr
new file mode 100644
index 000000000000..b6b5e026bc3b
--- /dev/null
+++ b/textproc/yaxi/pkg-descr
@@ -0,0 +1,5 @@
+Yaxi contains a (currently non-validating) XML parser (SAX, DOM methods, pull
+parser in the works), a complete XPath implementation and a (still incomplete)
+XSL implementation.
+
+WWW: http://mattam.ath.cx/progs/yaxi.html