aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libconfuse/Makefile32
-rw-r--r--devel/libconfuse/distinfo2
-rw-r--r--devel/libconfuse/pkg-descr14
-rw-r--r--devel/libconfuse/pkg-plist5
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 24b44c57405a..02fe07d11d29 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -392,6 +392,7 @@
SUBDIR += libchipcard
SUBDIR += libchipcard-kde
SUBDIR += libcii
+ SUBDIR += libconfuse
SUBDIR += libcoro
SUBDIR += libcwd
SUBDIR += libdict
diff --git a/devel/libconfuse/Makefile b/devel/libconfuse/Makefile
new file mode 100644
index 000000000000..2e675ef86670
--- /dev/null
+++ b/devel/libconfuse/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libconfuse
+# Date created: 18 September 2004
+# Whom: Juraj Lutter <otis@sk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libconfuse
+PORTVERSION= 2.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
+ ftp://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
+MASTER_SITE_SUBDIR= confuse
+DISTNAME= confuse-${PORTVERSION}
+
+MAINTAINER= otis@freebsd.sk
+COMMENT= Configuration file parsing library
+
+.if defined(WITH_CHECK)
+LIB_DEPENDS+= ${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck
+.endif
+
+USE_ICONV= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ARGS+= --disable-nls
+CFLAGS+= -I${WRKSRC}/src
+.if defined(WITH_CHECK)
+CONFIGURE_ARGS+= --with-check=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libconfuse/distinfo b/devel/libconfuse/distinfo
new file mode 100644
index 000000000000..ed979c8ba32d
--- /dev/null
+++ b/devel/libconfuse/distinfo
@@ -0,0 +1,2 @@
+MD5 (confuse-2.4.tar.gz) = 2ed2f0eac99bc644d1d4c96a4f4a431b
+SIZE (confuse-2.4.tar.gz) = 438666
diff --git a/devel/libconfuse/pkg-descr b/devel/libconfuse/pkg-descr
new file mode 100644
index 000000000000..1265fd1193f5
--- /dev/null
+++ b/devel/libconfuse/pkg-descr
@@ -0,0 +1,14 @@
+libConfuse is a configuration file parser library, licensed under the terms of
+the LGPL, and written in C. It supports sections and (lists of) values
+(strings, integers, floats, booleans or other sections), as well as some other
+features (such as single/double-quoted strings, environment variable
+expansion, functions and nested include statements). It makes it very easy to
+add configuration file capability to a program using a simple API.
+
+The goal of libConfuse is not to be the configuration file parser library with
+a gazillion of features. Instead, it aims to be easy to use and quick to
+integrate with your code. libConfuse was called libcfg before, but was changed
+to not confuse with other similar libraries.
+
+Project homepage:
+WWW: http://savannah.nongnu.org/projects/confuse/
diff --git a/devel/libconfuse/pkg-plist b/devel/libconfuse/pkg-plist
new file mode 100644
index 000000000000..84a939b3e56b
--- /dev/null
+++ b/devel/libconfuse/pkg-plist
@@ -0,0 +1,5 @@
+bin/confuse-config
+include/confuse.h
+lib/libconfuse.a
+lib/libconfuse.so
+lib/libconfuse.so.0