aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-MP3/Makefile34
-rw-r--r--www/p5-Apache-MP3/distinfo1
-rw-r--r--www/p5-Apache-MP3/pkg-comment1
-rw-r--r--www/p5-Apache-MP3/pkg-descr11
-rw-r--r--www/p5-Apache-MP3/pkg-plist14
6 files changed, 62 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7aa2d2bf7145..34dcb988f353 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -151,6 +151,7 @@
SUBDIR += p5-Apache-DBI
SUBDIR += p5-Apache-Icon
SUBDIR += p5-Apache-Language
+ SUBDIR += p5-Apache-MP3
SUBDIR += p5-Apache-Peek
SUBDIR += p5-Apache-Radius
SUBDIR += p5-Apache-Reload
diff --git a/www/p5-Apache-MP3/Makefile b/www/p5-Apache-MP3/Makefile
new file mode 100644
index 000000000000..4e1334c57c53
--- /dev/null
+++ b/www/p5-Apache-MP3/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Apache-MP3
+# Date created: 23-Jan-2001
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-MP3
+PORTVERSION= 2.15
+CATEGORIES= www audio
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+BUILD_DEPENDS= ${SITE_PERL}/MPEG/MP3Info.pm:${PORTSDIR}/audio/p5-MP3-Info \
+ ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::MP3.3 \
+ Apache::MP3::Playlist.3 \
+ Apache::MP3::Sorted.3
+
+PKGDATADIR= ${PREFIX}/share/${PORTNAME}
+post-install:
+ ${MKDIR} ${PKGDATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/apache_mp3/* ${PKGDATADIR}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-MP3/distinfo b/www/p5-Apache-MP3/distinfo
new file mode 100644
index 000000000000..01e042430482
--- /dev/null
+++ b/www/p5-Apache-MP3/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-MP3-2.15.tar.gz) = 64eb56a488dc60f5aa52c5908f4fdade
diff --git a/www/p5-Apache-MP3/pkg-comment b/www/p5-Apache-MP3/pkg-comment
new file mode 100644
index 000000000000..719173a7f4f1
--- /dev/null
+++ b/www/p5-Apache-MP3/pkg-comment
@@ -0,0 +1 @@
+MP3 browsing and streaming under mod_perl and Apache
diff --git a/www/p5-Apache-MP3/pkg-descr b/www/p5-Apache-MP3/pkg-descr
new file mode 100644
index 000000000000..b819942dd424
--- /dev/null
+++ b/www/p5-Apache-MP3/pkg-descr
@@ -0,0 +1,11 @@
+This module takes a hierarchy of directories containing MP3 files
+and presents it as a browsable song library for streaming over the
+web. It requires the Apache web server, the mod_perl embedded Perl
+interpreter, and the MP3::Info module.
+
+MP3 files are displayed in a list that shows the MP3 title, artist,
+duration and bitrate. Subdirectories are displayed with "CD" icons.
+The user can download an MP3 file to disk by clicking on its title,
+stream it to an MP3 decoder by clicking on the "play" link. Users
+can also stream the entire contents of a directory, or select a
+subset of songs to play.
diff --git a/www/p5-Apache-MP3/pkg-plist b/www/p5-Apache-MP3/pkg-plist
new file mode 100644
index 000000000000..8e44acf1ec92
--- /dev/null
+++ b/www/p5-Apache-MP3/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/Apache/MP3.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/MP3/Playlist.pm
+lib/perl5/site_perl/%%PERL_VER%%/Apache/MP3/Sorted.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/MP3/.packlist
+share/Apache-MP3/apache_mp3.css
+share/Apache-MP3/apache_mp3_help.gif
+share/Apache-MP3/back.gif
+share/Apache-MP3/cd_icon.gif
+share/Apache-MP3/cd_icon_small.gif
+share/Apache-MP3/playlist.gif
+share/Apache-MP3/right_arrow.gif
+share/Apache-MP3/sound.gif
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/MP3
+@dirrm share/Apache-MP3