aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/llvm-devel/Makefile27
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo4
-rw-r--r--devel/llvm-devel/files/patch-utils_llvm-build_llvmbuild_main.py20
-rw-r--r--devel/llvm-devel/pkg-plist45
-rw-r--r--lang/clang-devel/Makefile2
-rw-r--r--lang/clang-devel/distinfo8
-rw-r--r--lang/clang-devel/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h8
-rw-r--r--lang/clang-devel/files/patch-utils_llvm-build_llvmbuild_main.py20
-rw-r--r--lang/clang-devel/pkg-plist55
10 files changed, 139 insertions, 52 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index fdde03fbcfaa..5ee6b6806933 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= llvm
-DISTVERSION= 3.0.r${SVN_REV}
+DISTVERSION= 3.1.r${SVN_REV}
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -30,12 +30,15 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
USE_PERL5= yes
+USE_PYTHON_BUILD= yes
MAKE_JOBS_SAFE= yes
# Suggested tweaks from http://llvm.org/docs/Packaging.html
# Commented out ones are currently broken.
MAKE_ARGS+= REQUIRES_RTTI=1
-#CONFIGURE_ARGS+= --enable-shared
+CONFIGURE_ARGS+= --enable-shared
+LIBNAME= libLLVM-${DISTVERSION:C/\.r[0-9]*//}svn.so
+PLIST_FILES+= lib/${LIBNAME} lib/${LIBNAME}.0
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
@@ -46,13 +49,14 @@ CONFIGURE_ARGS+= --enable-optimized
CONFIGURE_ARGS+= --enable-bindings=none
OPTIONS= ASSERTS "Enable assertions (thread unsafe)" off
+# LTOPLUGIN "Build LTO plugin (requires gold)" off
.if defined(NOPORTDOCS)
CONFIGURE_ARGS+= --disable-docs
.endif
-MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 \
- llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-diff.1 \
+MAN1= bugpoint.1 lit.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
+ llvm-bcanalyzer.1 llvm-cov.1 llvm-config.1 llvm-diff.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 opt.1 tblgen.1
@@ -85,6 +89,13 @@ CONFIGURE_ARGS+= --enable-assertions
CONFIGURE_ARGS+= --disable-assertions
.endif
+.ifdef(WITH_LTOPLUGIN)
+BUILD_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ld.gold:${PORTSDIR}/devel/binutils
+CONFIGURE_ARGS+= --with-binutils-include=${LOCALBASE}/include
+PLIST_FILES+= lib/LLVMgold.so
+.endif
+
.if defined(BOOTSTRAP) || defined(SVN_FETCH)
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
@@ -109,15 +120,19 @@ post-patch:
.if defined(NOPORTDOCS)
post-build:
@cd ${WRKSRC}/docs/CommandGuide && ${GMAKE} ${MAN1}
+.endif
post-install:
+ mv ${PREFIX}/lib/${LIBNAME} ${PREFIX}/lib/${LIBNAME}.0
+ ln -s ${LIBNAME}.0 ${PREFIX}/lib/${LIBNAME}
+.if defined(NOPORTDOCS)
.for man in ${MAN1}
@${INSTALL_MAN} ${WRKSRC}/docs/CommandGuide/${man} \
${MANPREFIX}/man/man1/
.endfor
.endif
-TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} ${GMAKE} check-local-lit)'
+TEST_CMD= '(cd ${WRKSRC}/test; ${SETENV} ${MAKE_ENV} LD_LIBRARY_PATH=${WRKSRC}/Release/lib ${GMAKE} check-local-lit)'
regression-test: ${BUILD_COOKIE}
if [ `${ID} -u` = 0 ]; then \
${CHOWN} -R nobody ${WRKSRC}/test; \
@@ -134,7 +149,6 @@ PLIST_FILE_LIST= bin/bugpoint \
bin/opt \
lib/LLVMHello.so \
lib/BugpointPasses.so \
- lib/libEnhancedDisassembly.a \
lib/libLTO.* \
lib/libLLVM* \
lib/libprofile_rt.so \
@@ -145,6 +159,7 @@ build-plist:
${RM} -f ${PLIST}
cd ${PREFIX} && \
(ls ${PLIST_FILE_LIST}; ${FIND} ${PLIST_DIR_LIST} -type f) | \
+ ${SED} -e 's|${PORTVERSION}|%%PORTVERSION%%|' | \
${SORT} >> ${PLIST}
${FIND} ${DOCSDIR} -type f | \
${SED} -e 's|${DOCSDIR}|%%PORTDOCS%%%%DOCSDIR%%|' | \
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index d897ff961869..1a3df964de13 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 141985
+SVN_REV= 150242
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index 84decc68bccc..100aff2bbd70 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (llvm-3.0.r141985.tar.bz2) = 4171bef5590c3bb54110cb92d3e6a7c1a145a4b209c9c0cd3376444d08930afa
-SIZE (llvm-3.0.r141985.tar.bz2) = 8022095
+SHA256 (llvm-3.1.r150242.tar.bz2) = 58df5cf4cbe97bd5f7007540b03e45abbc203190436e63b9535f9ef2c695e2ae
+SIZE (llvm-3.1.r150242.tar.bz2) = 8439654
diff --git a/devel/llvm-devel/files/patch-utils_llvm-build_llvmbuild_main.py b/devel/llvm-devel/files/patch-utils_llvm-build_llvmbuild_main.py
new file mode 100644
index 000000000000..1e2de0273d55
--- /dev/null
+++ b/devel/llvm-devel/files/patch-utils_llvm-build_llvmbuild_main.py
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- utils/llvm-build/llvmbuild/main.py.orig
++++ utils/llvm-build/llvmbuild/main.py
+@@ -633,7 +633,13 @@
+
+ # We handle a few special cases of target names here for historical
+ # reasons, as these are the names configure currently comes up with.
+- native_target_name = { 'x86' : 'X86',
++ native_target_name = { 'amd64' : 'X86',
++ 'arm' : 'ARM',
++ 'i386' : 'X86',
++ 'mips' : 'Mips',
++ 'powerpc' : 'PowerPC',
++ 'sparc64' : 'Sparc',
++ 'x86' : 'X86',
+ 'x86_64' : 'X86',
+ 'Unknown' : None }.get(opts.native_target,
+ opts.native_target)
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 148d4e9ff41d..ae5e9319a9f6 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -37,6 +37,7 @@ include/llvm-c/Target.h
include/llvm-c/Transforms/IPO.h
include/llvm-c/Transforms/PassManagerBuilder.h
include/llvm-c/Transforms/Scalar.h
+include/llvm-c/Transforms/Vectorize.h
include/llvm-c/lto.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
@@ -92,7 +93,7 @@ include/llvm/ADT/Triple.h
include/llvm/ADT/Twine.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/ValueMap.h
-include/llvm/ADT/VectorExtras.h
+include/llvm/ADT/VariadicFunction.h
include/llvm/ADT/ilist.h
include/llvm/ADT/ilist_node.h
include/llvm/Analysis/AliasAnalysis.h
@@ -169,9 +170,9 @@ include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/Analysis.h
include/llvm/CodeGen/AsmPrinter.h
-include/llvm/CodeGen/BinaryObject.h
include/llvm/CodeGen/CalcSpillWeights.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/DFAPacketizer.h
include/llvm/CodeGen/EdgeBundles.h
include/llvm/CodeGen/FastISel.h
include/llvm/CodeGen/FunctionLoweringInfo.h
@@ -204,6 +205,7 @@ include/llvm/CodeGen/MachineFunctionAnalysis.h
include/llvm/CodeGen/MachineFunctionPass.h
include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
+include/llvm/CodeGen/MachineInstrBundle.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineLoopRanges.h
@@ -215,7 +217,6 @@ include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/MachineSSAUpdater.h
-include/llvm/CodeGen/ObjectCodeEmitter.h
include/llvm/CodeGen/PBQP/Graph.h
include/llvm/CodeGen/PBQP/HeuristicBase.h
include/llvm/CodeGen/PBQP/HeuristicSolver.h
@@ -228,6 +229,7 @@ include/llvm/CodeGen/PseudoSourceValue.h
include/llvm/CodeGen/RegAllocPBQP.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterScavenging.h
+include/llvm/CodeGen/ResourcePriorityQueue.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/ScheduleHazardRecognizer.h
@@ -276,8 +278,8 @@ include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
include/llvm/IntrinsicsARM.td
-include/llvm/IntrinsicsAlpha.td
include/llvm/IntrinsicsCellSPU.td
+include/llvm/IntrinsicsHexagon.td
include/llvm/IntrinsicsPTX.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
@@ -336,6 +338,7 @@ include/llvm/MC/MCTargetAsmLexer.h
include/llvm/MC/MCTargetAsmParser.h
include/llvm/MC/MCValue.h
include/llvm/MC/MCWin64EH.h
+include/llvm/MC/MCWinCOFFObjectWriter.h
include/llvm/MC/MachineLocation.h
include/llvm/MC/SectionKind.h
include/llvm/MC/SubtargetFeature.h
@@ -377,6 +380,7 @@ include/llvm/Support/CrashRecoveryContext.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataExtractor.h
include/llvm/Support/DataFlow.h
+include/llvm/Support/DataStream.h
include/llvm/Support/DataTypes.h
include/llvm/Support/Debug.h
include/llvm/Support/DebugLoc.h
@@ -401,8 +405,10 @@ include/llvm/Support/IRReader.h
include/llvm/Support/IncludeFile.h
include/llvm/Support/InstIterator.h
include/llvm/Support/InstVisitor.h
+include/llvm/Support/JSONParser.h
include/llvm/Support/LICENSE.TXT
include/llvm/Support/LeakDetector.h
+include/llvm/Support/LockFileManager.h
include/llvm/Support/MachO.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/MathExtras.h
@@ -434,6 +440,7 @@ include/llvm/Support/SMLoc.h
include/llvm/Support/Signals.h
include/llvm/Support/Solaris.h
include/llvm/Support/SourceMgr.h
+include/llvm/Support/StreamableMemoryObject.h
include/llvm/Support/StringPool.h
include/llvm/Support/SwapByteOrder.h
include/llvm/Support/SystemUtils.h
@@ -491,8 +498,10 @@ include/llvm/Transforms/Utils/BasicBlockUtils.h
include/llvm/Transforms/Utils/BasicInliner.h
include/llvm/Transforms/Utils/BuildLibCalls.h
include/llvm/Transforms/Utils/Cloning.h
+include/llvm/Transforms/Utils/CmpInstAnalysis.h
include/llvm/Transforms/Utils/FunctionUtils.h
include/llvm/Transforms/Utils/Local.h
+include/llvm/Transforms/Utils/ModuleUtils.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/SSAUpdater.h
include/llvm/Transforms/Utils/SSAUpdaterImpl.h
@@ -500,6 +509,7 @@ include/llvm/Transforms/Utils/SimplifyIndVar.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
include/llvm/Transforms/Utils/UnrollLoop.h
include/llvm/Transforms/Utils/ValueMapper.h
+include/llvm/Transforms/Vectorize.h
include/llvm/Type.h
include/llvm/Use.h
include/llvm/User.h
@@ -507,36 +517,32 @@ include/llvm/Value.h
include/llvm/ValueSymbolTable.h
lib/BugpointPasses.so
lib/LLVMHello.so
-lib/libEnhancedDisassembly.a
lib/libLLVMARMAsmParser.a
lib/libLLVMARMAsmPrinter.a
lib/libLLVMARMCodeGen.a
lib/libLLVMARMDesc.a
lib/libLLVMARMDisassembler.a
lib/libLLVMARMInfo.a
-lib/libLLVMAlphaCodeGen.a
-lib/libLLVMAlphaDesc.a
-lib/libLLVMAlphaInfo.a
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMAsmPrinter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
-lib/libLLVMBlackfinCodeGen.a
-lib/libLLVMBlackfinDesc.a
-lib/libLLVMBlackfinInfo.a
-lib/libLLVMCBackend.a
+lib/libLLVMCBackendCodeGen.a
lib/libLLVMCBackendInfo.a
lib/libLLVMCellSPUCodeGen.a
lib/libLLVMCellSPUDesc.a
lib/libLLVMCellSPUInfo.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
-lib/libLLVMCppBackend.a
+lib/libLLVMCppBackendCodeGen.a
lib/libLLVMCppBackendInfo.a
lib/libLLVMDebugInfo.a
lib/libLLVMExecutionEngine.a
+lib/libLLVMHexagonCodeGen.a
+lib/libLLVMHexagonDesc.a
+lib/libLLVMHexagonInfo.a
lib/libLLVMInstCombine.a
lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
@@ -556,6 +562,7 @@ lib/libLLVMMSP430AsmPrinter.a
lib/libLLVMMSP430CodeGen.a
lib/libLLVMMSP430Desc.a
lib/libLLVMMSP430Info.a
+lib/libLLVMMipsAsmParser.a
lib/libLLVMMipsAsmPrinter.a
lib/libLLVMMipsCodeGen.a
lib/libLLVMMipsDesc.a
@@ -576,12 +583,10 @@ lib/libLLVMSparcCodeGen.a
lib/libLLVMSparcDesc.a
lib/libLLVMSparcInfo.a
lib/libLLVMSupport.a
-lib/libLLVMSystemZCodeGen.a
-lib/libLLVMSystemZDesc.a
-lib/libLLVMSystemZInfo.a
lib/libLLVMTableGen.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
+lib/libLLVMVectorize.a
lib/libLLVMX86AsmParser.a
lib/libLLVMX86AsmPrinter.a
lib/libLLVMX86CodeGen.a
@@ -617,7 +622,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-ar.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-as.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-bcanalyzer.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-build.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-config.html
+%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-cov.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-diff.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-dis.html
%%PORTDOCS%%%%DOCSDIR%%/html/CommandGuide/llvm-extract.html
@@ -642,8 +649,10 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStarted.html
%%PORTDOCS%%%%DOCSDIR%%/html/GettingStartedVS.html
%%PORTDOCS%%%%DOCSDIR%%/html/GoldPlugin.html
+%%PORTDOCS%%%%DOCSDIR%%/html/HowToAddABuilder.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToReleaseLLVM.html
%%PORTDOCS%%%%DOCSDIR%%/html/HowToSubmitABug.html
+%%PORTDOCS%%%%DOCSDIR%%/html/LLVMBuild.html
%%PORTDOCS%%%%DOCSDIR%%/html/LangRef.html
%%PORTDOCS%%%%DOCSDIR%%/html/Lexicon.html
%%PORTDOCS%%%%DOCSDIR%%/html/LinkTimeOptimization.html
@@ -658,7 +667,6 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/SystemLibrary.html
%%PORTDOCS%%%%DOCSDIR%%/html/TableGenFundamentals.html
%%PORTDOCS%%%%DOCSDIR%%/html/TestingGuide.html
-%%PORTDOCS%%%%DOCSDIR%%/html/UsingLibraries.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMBackend.html
%%PORTDOCS%%%%DOCSDIR%%/html/WritingAnLLVMPass.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
@@ -673,6 +681,7 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl2.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl3.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl5-cfg.png
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl5.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl6.html
%%PORTDOCS%%%%DOCSDIR%%/html/tutorial/LangImpl7.html
@@ -694,7 +703,9 @@ lib/libprofile_rt.so
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-ar.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-as.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-bcanalyzer.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-build.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-config.ps
+%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-cov.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-diff.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-dis.ps
%%PORTDOCS%%%%DOCSDIR%%/ps/llvm-extract.ps
diff --git a/lang/clang-devel/Makefile b/lang/clang-devel/Makefile
index ffcddd9613d8..ca1fb685aa24 100644
--- a/lang/clang-devel/Makefile
+++ b/lang/clang-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= clang
-PORTVERSION= 3.0.r${SVN_REV}
+PORTVERSION= 3.1.r${SVN_REV}
CATEGORIES= lang devel
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
diff --git a/lang/clang-devel/distinfo b/lang/clang-devel/distinfo
index 366346abb03d..8cda9aef7211 100644
--- a/lang/clang-devel/distinfo
+++ b/lang/clang-devel/distinfo
@@ -1,4 +1,4 @@
-SHA256 (clang-3.0.r141985.tar.bz2) = 895338d9597beb2641a0c33287359f8cfb2ab928510b4e3ae0f9b9bce4090d45
-SIZE (clang-3.0.r141985.tar.bz2) = 5939443
-SHA256 (llvm-3.0.r141985.tar.bz2) = 4171bef5590c3bb54110cb92d3e6a7c1a145a4b209c9c0cd3376444d08930afa
-SIZE (llvm-3.0.r141985.tar.bz2) = 8022095
+SHA256 (clang-3.1.r150242.tar.bz2) = c1123f4b74ce87cccfc849d2d4d86fe7350d391c8233d4a4735703c64e4674a8
+SIZE (clang-3.1.r150242.tar.bz2) = 6358664
+SHA256 (llvm-3.1.r150242.tar.bz2) = 58df5cf4cbe97bd5f7007540b03e45abbc203190436e63b9535f9ef2c695e2ae
+SIZE (llvm-3.1.r150242.tar.bz2) = 8439654
diff --git a/lang/clang-devel/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h b/lang/clang-devel/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
index 45a6b81cb300..611fa06f3733 100644
--- a/lang/clang-devel/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
+++ b/lang/clang-devel/files/patch-tools_clang_include_clang_Analysis_Analyses_FormatString.h
@@ -3,14 +3,14 @@ $FreeBSD$
--- tools/clang/include/clang/Analysis/Analyses/FormatString.h.orig
+++ tools/clang/include/clang/Analysis/Analyses/FormatString.h
-@@ -139,6 +139,10 @@
+@@ -141,6 +141,10 @@
SArg,
-
+
// ** Printf-specific **
-+
++
+ // FreeBSD specific specifiers
+ bArg,
+ DArg,
-
+
// Objective-C specific specifiers.
ObjCObjArg, // '@'
diff --git a/lang/clang-devel/files/patch-utils_llvm-build_llvmbuild_main.py b/lang/clang-devel/files/patch-utils_llvm-build_llvmbuild_main.py
new file mode 100644
index 000000000000..1e2de0273d55
--- /dev/null
+++ b/lang/clang-devel/files/patch-utils_llvm-build_llvmbuild_main.py
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- utils/llvm-build/llvmbuild/main.py.orig
++++ utils/llvm-build/llvmbuild/main.py
+@@ -633,7 +633,13 @@
+
+ # We handle a few special cases of target names here for historical
+ # reasons, as these are the names configure currently comes up with.
+- native_target_name = { 'x86' : 'X86',
++ native_target_name = { 'amd64' : 'X86',
++ 'arm' : 'ARM',
++ 'i386' : 'X86',
++ 'mips' : 'Mips',
++ 'powerpc' : 'PowerPC',
++ 'sparc64' : 'Sparc',
++ 'x86' : 'X86',
+ 'x86_64' : 'X86',
+ 'Unknown' : None }.get(opts.native_target,
+ opts.native_target)
diff --git a/lang/clang-devel/pkg-plist b/lang/clang-devel/pkg-plist
index 5789425db8fa..0ecbbaddb397 100644
--- a/lang/clang-devel/pkg-plist
+++ b/lang/clang-devel/pkg-plist
@@ -22,6 +22,7 @@ include/clang/AST/Attr.h
include/clang/AST/AttrImpl.inc
include/clang/AST/Attrs.inc
include/clang/AST/BaseSubobject.h
+include/clang/AST/BuiltinTypes.def
include/clang/AST/CXXInheritance.h
include/clang/AST/CanonicalType.h
include/clang/AST/CharUnits.h
@@ -74,8 +75,10 @@ include/clang/AST/UsuallyTinyPtrVector.h
include/clang/AST/VTTBuilder.h
include/clang/AST/VTableBuilder.h
include/clang/Analysis/Analyses/CFGReachabilityAnalysis.h
+include/clang/Analysis/Analyses/Dominators.h
include/clang/Analysis/Analyses/FormatString.h
include/clang/Analysis/Analyses/LiveVariables.h
+include/clang/Analysis/Analyses/PostOrderCFGView.h
include/clang/Analysis/Analyses/PseudoConstantAnalysis.h
include/clang/Analysis/Analyses/ReachableCode.h
include/clang/Analysis/Analyses/ThreadSafety.h
@@ -101,6 +104,7 @@ include/clang/Basic/AttrList.inc
include/clang/Basic/Builtins.def
include/clang/Basic/Builtins.h
include/clang/Basic/BuiltinsARM.def
+include/clang/Basic/BuiltinsHexagon.def
include/clang/Basic/BuiltinsPPC.def
include/clang/Basic/BuiltinsPTX.def
include/clang/Basic/BuiltinsX86.def
@@ -119,6 +123,7 @@ include/clang/Basic/DiagnosticIndexName.inc
include/clang/Basic/DiagnosticLexKinds.inc
include/clang/Basic/DiagnosticParseKinds.inc
include/clang/Basic/DiagnosticSemaKinds.inc
+include/clang/Basic/DiagnosticSerializationKinds.inc
include/clang/Basic/ExceptionSpecificationType.h
include/clang/Basic/ExpressionTraits.h
include/clang/Basic/FileManager.h
@@ -126,10 +131,12 @@ include/clang/Basic/FileSystemOptions.h
include/clang/Basic/FileSystemStatCache.h
include/clang/Basic/IdentifierTable.h
include/clang/Basic/LLVM.h
+include/clang/Basic/Lambda.h
include/clang/Basic/LangOptions.def
include/clang/Basic/LangOptions.h
include/clang/Basic/Linkage.h
include/clang/Basic/MacroBuilder.h
+include/clang/Basic/Module.h
include/clang/Basic/OnDiskHashTable.h
include/clang/Basic/OpenCL.h
include/clang/Basic/OpenCLExtensions.def
@@ -156,6 +163,7 @@ include/clang/Basic/arm_neon.inc
include/clang/CodeGen/BackendUtil.h
include/clang/CodeGen/CodeGenAction.h
include/clang/CodeGen/ModuleBuilder.h
+include/clang/Config/config.h
include/clang/Driver/Action.h
include/clang/Driver/Arg.h
include/clang/Driver/ArgList.h
@@ -166,7 +174,6 @@ include/clang/Driver/CC1Options.inc
include/clang/Driver/Compilation.h
include/clang/Driver/Driver.h
include/clang/Driver/DriverDiagnostic.h
-include/clang/Driver/HostInfo.h
include/clang/Driver/Job.h
include/clang/Driver/ObjCRuntime.h
include/clang/Driver/OptSpecifier.h
@@ -185,12 +192,14 @@ include/clang/Frontend/ASTUnit.h
include/clang/Frontend/Analyses.def
include/clang/Frontend/AnalyzerOptions.h
include/clang/Frontend/ChainedDiagnosticConsumer.h
+include/clang/Frontend/ChainedIncludesSource.h
include/clang/Frontend/CodeGenOptions.h
include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompilerInstance.h
include/clang/Frontend/CompilerInvocation.h
include/clang/Frontend/DependencyOutputOptions.h
include/clang/Frontend/DiagnosticOptions.h
+include/clang/Frontend/DiagnosticRenderer.h
include/clang/Frontend/FrontendAction.h
include/clang/Frontend/FrontendActions.h
include/clang/Frontend/FrontendDiagnostic.h
@@ -199,10 +208,14 @@ include/clang/Frontend/FrontendPluginRegistry.h
include/clang/Frontend/HeaderSearchOptions.h
include/clang/Frontend/LangStandard.h
include/clang/Frontend/LangStandards.def
+include/clang/Frontend/LayoutOverrideSource.h
include/clang/Frontend/LogDiagnosticPrinter.h
+include/clang/Frontend/MigratorOptions.h
include/clang/Frontend/MultiplexConsumer.h
include/clang/Frontend/PreprocessorOptions.h
include/clang/Frontend/PreprocessorOutputOptions.h
+include/clang/Frontend/SerializedDiagnosticPrinter.h
+include/clang/Frontend/TextDiagnostic.h
include/clang/Frontend/TextDiagnosticBuffer.h
include/clang/Frontend/TextDiagnosticPrinter.h
include/clang/Frontend/Utils.h
@@ -232,6 +245,7 @@ include/clang/Lex/Lexer.h
include/clang/Lex/LiteralSupport.h
include/clang/Lex/MacroInfo.h
include/clang/Lex/ModuleLoader.h
+include/clang/Lex/ModuleMap.h
include/clang/Lex/MultipleIncludeOpt.h
include/clang/Lex/PPCallbacks.h
include/clang/Lex/PTHLexer.h
@@ -258,6 +272,7 @@ include/clang/Rewrite/Rewriter.h
include/clang/Rewrite/Rewriters.h
include/clang/Rewrite/TokenRewriter.h
include/clang/Sema/AnalysisBasedWarnings.h
+include/clang/Sema/AttrTemplateInstantiate.inc
include/clang/Sema/AttributeList.h
include/clang/Sema/CXXFieldCollector.h
include/clang/Sema/CodeCompleteConsumer.h
@@ -292,10 +307,10 @@ include/clang/Serialization/ASTReader.h
include/clang/Serialization/ASTWriter.h
include/clang/Serialization/AttrPCHRead.inc
include/clang/Serialization/AttrPCHWrite.inc
-include/clang/Serialization/ChainedIncludesSource.h
include/clang/Serialization/ContinuousRangeMap.h
include/clang/Serialization/Module.h
include/clang/Serialization/ModuleManager.h
+include/clang/Serialization/SerializationDiagnostic.h
include/clang/StaticAnalyzer/Checkers/ClangCheckers.h
include/clang/StaticAnalyzer/Checkers/DereferenceChecker.h
include/clang/StaticAnalyzer/Checkers/LocalCheckers.h
@@ -318,11 +333,11 @@ include/clang/StaticAnalyzer/Core/PathSensitive/CoreEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/Environment.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExplodedGraph.h
include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngine.h
-include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngineBuilders.h
include/clang/StaticAnalyzer/Core/PathSensitive/MemRegion.h
include/clang/StaticAnalyzer/Core/PathSensitive/ObjCMessage.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState.h
include/clang/StaticAnalyzer/Core/PathSensitive/ProgramStateTrait.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ProgramState_Fwd.h
include/clang/StaticAnalyzer/Core/PathSensitive/SValBuilder.h
include/clang/StaticAnalyzer/Core/PathSensitive/SVals.h
include/clang/StaticAnalyzer/Core/PathSensitive/Store.h
@@ -330,21 +345,24 @@ include/clang/StaticAnalyzer/Core/PathSensitive/StoreRef.h
include/clang/StaticAnalyzer/Core/PathSensitive/SubEngine.h
include/clang/StaticAnalyzer/Core/PathSensitive/SummaryManager.h
include/clang/StaticAnalyzer/Core/PathSensitive/SymbolManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/TaintManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/TaintTag.h
include/clang/StaticAnalyzer/Core/PathSensitive/WorkList.h
include/clang/StaticAnalyzer/Frontend/CheckerRegistration.h
include/clang/StaticAnalyzer/Frontend/FrontendActions.h
-lib/clang/3.0/include/arm_neon.h
-lib/clang/3.0/include/emmintrin.h
-lib/clang/3.0/include/immintrin.h
-lib/clang/3.0/include/mm3dnow.h
-lib/clang/3.0/include/mm_malloc.h
-lib/clang/3.0/include/mmintrin.h
-lib/clang/3.0/include/nmmintrin.h
-lib/clang/3.0/include/pmmintrin.h
-lib/clang/3.0/include/smmintrin.h
-lib/clang/3.0/include/tmmintrin.h
-lib/clang/3.0/include/wmmintrin.h
-lib/clang/3.0/include/xmmintrin.h
+lib/clang/3.1/include/arm_neon.h
+lib/clang/3.1/include/emmintrin.h
+lib/clang/3.1/include/immintrin.h
+lib/clang/3.1/include/mm3dnow.h
+lib/clang/3.1/include/mm_malloc.h
+lib/clang/3.1/include/mmintrin.h
+lib/clang/3.1/include/module.map
+lib/clang/3.1/include/nmmintrin.h
+lib/clang/3.1/include/pmmintrin.h
+lib/clang/3.1/include/smmintrin.h
+lib/clang/3.1/include/tmmintrin.h
+lib/clang/3.1/include/wmmintrin.h
+lib/clang/3.1/include/xmmintrin.h
lib/libclang.a
lib/libclang.so
lib/libclangARCMigrate.a
@@ -367,6 +385,7 @@ lib/libclangStaticAnalyzerFrontend.a
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
+%%PORTDOCS%%%%DOCSDIR%%/html/AddressSanitizer.html
%%PORTDOCS%%%%DOCSDIR%%/html/AnalyzerRegions.html
%%PORTDOCS%%%%DOCSDIR%%/html/AutomaticReferenceCounting.html
%%PORTDOCS%%%%DOCSDIR%%/html/DriverInternals.html
@@ -374,6 +393,7 @@ lib/libclangStaticAnalyzerFrontend.a
%%PORTDOCS%%%%DOCSDIR%%/html/LanguageExtensions.html
%%PORTDOCS%%%%DOCSDIR%%/html/PCHInternals.html
%%PORTDOCS%%%%DOCSDIR%%/html/PTHInternals.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ReleaseNotes.html
%%PORTDOCS%%%%DOCSDIR%%/html/UsersManual.html
%%PORTDOCS%%%%DOCSDIR%%/html/clang/clang.html
%%PORTDOCS%%%%DOCSDIR%%/html/clang/manpage.css
@@ -385,8 +405,8 @@ lib/libclangStaticAnalyzerFrontend.a
%%PYTHON_SITELIBDIR%%/Resources/bugcatcher.ico
%%PYTHON_SITELIBDIR%%/ScanView.py
%%PYTHON_SITELIBDIR%%/startfile.py
-@dirrm lib/clang/3.0/include
-@dirrm lib/clang/3.0
+@dirrm lib/clang/3.1/include
+@dirrm lib/clang/3.1
@dirrm lib/clang
@dirrm include/clang/StaticAnalyzer/Frontend
@dirrm include/clang/StaticAnalyzer/Core/PathSensitive
@@ -403,6 +423,7 @@ lib/libclangStaticAnalyzerFrontend.a
@dirrm include/clang/FrontendTool
@dirrm include/clang/Frontend
@dirrm include/clang/Driver
+@dirrm include/clang/Config
@dirrm include/clang/CodeGen
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors