aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_authnz_external/Makefile33
-rw-r--r--www/mod_authnz_external/distinfo3
-rw-r--r--www/mod_authnz_external/pkg-descr11
4 files changed, 48 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c4357742cd4e..c249d11daf02 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -320,6 +320,7 @@
SUBDIR += mod_auth_remote
SUBDIR += mod_auth_useragent
SUBDIR += mod_authenticache
+ SUBDIR += mod_authnz_external
SUBDIR += mod_backhand
SUBDIR += mod_bandwidth
SUBDIR += mod_bf
diff --git a/www/mod_authnz_external/Makefile b/www/mod_authnz_external/Makefile
new file mode 100644
index 000000000000..8017d3800370
--- /dev/null
+++ b/www/mod_authnz_external/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mod_authnz_external
+# Date created: March 26, 2007
+# Whom: José García Juanino <jjuanino@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_authnz_external
+PORTVERSION= 3.1.0
+CATEGORIES= www
+MASTER_SITES= http://www.unixpapa.com/software/
+DIST_SUBDIR= apache22
+
+MAINTAINER= jjuanino@gmail.com
+COMMENT= Allows users authentication based on external mechanisms on apache 2.2
+
+USE_APACHE= 22
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+SHORTMODNAME= authnz_external
+
+PORTDOCS= AUTHENTICATORS INSTALL README \
+ CHANGES UPGRADE INSTALL.HARDCODE
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_authnz_external/distinfo b/www/mod_authnz_external/distinfo
new file mode 100644
index 000000000000..4d4428396584
--- /dev/null
+++ b/www/mod_authnz_external/distinfo
@@ -0,0 +1,3 @@
+MD5 (apache22/mod_authnz_external-3.1.0.tar.gz) = 5051bffe6a3992336f4a9f84430a58d2
+SHA256 (apache22/mod_authnz_external-3.1.0.tar.gz) = c3b26376042c0ba85d99ef0266af0bc9d893cce2da41b71c640ee3a9c415b86c
+SIZE (apache22/mod_authnz_external-3.1.0.tar.gz) = 171832
diff --git a/www/mod_authnz_external/pkg-descr b/www/mod_authnz_external/pkg-descr
new file mode 100644
index 000000000000..00a1825bb57a
--- /dev/null
+++ b/www/mod_authnz_external/pkg-descr
@@ -0,0 +1,11 @@
+Mod_authnz_external is an Apache module used for authentication. The Apache HTTP
+Daemon can be configured to require users to supply logins and passwords
+before accessing pages in some directories. Authentication is the process of
+checking if the password given is correct for a user. Apache has standard
+modules for authenticating out of several different kinds of databases.
+Mod_authnz_external is a flexible tool for creating authentication systems based
+on other databases.
+
+This port gives the same funcionality as mod_auth_external, but over apache 2.2.
+
+WWW: http://www.unixpapa.com/mod_auth_external.html