aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/android-tools-adb-devel/files/Makefile1
-rw-r--r--devel/android-tools-adb-devel/files/patch-base_include_android-base_logging.h11
2 files changed, 11 insertions, 1 deletions
diff --git a/devel/android-tools-adb-devel/files/Makefile b/devel/android-tools-adb-devel/files/Makefile
index 66368c5ea612..d9d149f8ac3f 100644
--- a/devel/android-tools-adb-devel/files/Makefile
+++ b/devel/android-tools-adb-devel/files/Makefile
@@ -68,7 +68,6 @@ TEST_SRCS+= stringprintf_test.cpp
TEST_SRCS+= strings_test.cpp
TEST_SRCS+= test_main.cpp
TEST_SRCS+= test_utils.cpp
-CPPFLAGS.logging_test.cpp+= -DNDEBUG # XXX DCHECK vs. timestamps
.PATH: ${.CURDIR}/../libcrypto_utils
SRCS+= android_pubkey.c
diff --git a/devel/android-tools-adb-devel/files/patch-base_include_android-base_logging.h b/devel/android-tools-adb-devel/files/patch-base_include_android-base_logging.h
new file mode 100644
index 000000000000..3fc6644c9a6f
--- /dev/null
+++ b/devel/android-tools-adb-devel/files/patch-base_include_android-base_logging.h
@@ -0,0 +1,11 @@
+--- base/include/android-base/logging.h.orig 2017-07-02 22:55:50 UTC
++++ base/include/android-base/logging.h
+@@ -321,7 +321,7 @@ struct LogAbortAfterFullExpr {
+ // DCHECKs are debug variants of CHECKs only enabled in debug builds. Generally
+ // CHECK should be used unless profiling identifies a CHECK as being in
+ // performance critical code.
+-#if defined(NDEBUG) && !defined(__clang_analyzer__)
++#if defined(NDEBUG) && !defined(__clang_analyzer__) || !defined(__ANDROID__)
+ static constexpr bool kEnableDChecks = false;
+ #else
+ static constexpr bool kEnableDChecks = true;