aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/catdoc/Makefile19
-rw-r--r--textproc/catdoc/pkg-descr29
-rw-r--r--textproc/catdoc/pkg-plist2
3 files changed, 24 insertions, 26 deletions
diff --git a/textproc/catdoc/Makefile b/textproc/catdoc/Makefile
index 20595938e0e3..ad66334e7e9b 100644
--- a/textproc/catdoc/Makefile
+++ b/textproc/catdoc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= catdoc
PORTVERSION= 0.94.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
ftp://ftp.dvo.ru/pub/Gentoo/distfiles/ \
@@ -19,7 +20,9 @@ COMMENT= MS Word/Excel converter to plain ASCII or TeX. TK viewer included
GNU_CONFIGURE= yes
USE_GMAKE= yes
-MAN1= catdoc.1 wordview.1 xls2csv.1 catppt.1
+MAN1= catdoc.1 xls2csv.1 catppt.1
+
+OPTIONS= WORDVIEW "Build Tcl/Tk document viewer" On
.if !defined(LANG) || ${LANG} != ru_RU.KOI8-R
# Remove the below line to get Cyrillic code page support instead
@@ -31,11 +34,15 @@ post-patch:
.include <bsd.port.pre.mk>
-.for i in 0 1 2 3 4
-.if exists(${LOCALBASE}/bin/wish8.${i})
-CONFIGURE_ARGS= --with-wish=${LOCALBASE}/bin/wish8.${i}
-RUN_DEPENDS+= ${LOCALBASE}/bin/wish8.${i}:${PORTSDIR}/x11-toolkits/tk8${i}
+.if defined(WITH_WORDVIEW)
+USE_TK= 80+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+CONFIGURE_ARGS+= --with-wish=${WISH}
+PLIST_SUB+= WORDVIEW=""
+MAN1+= wordview.1
+.else
+CONFIGURE_ARGS+= --disable-wordview
+PLIST_SUB+= WORDVIEW="@comment "
.endif
-.endfor
.include <bsd.port.post.mk>
diff --git a/textproc/catdoc/pkg-descr b/textproc/catdoc/pkg-descr
index b576dc800a07..364418fd3201 100644
--- a/textproc/catdoc/pkg-descr
+++ b/textproc/catdoc/pkg-descr
@@ -1,19 +1,10 @@
-This is a program for viewing MS Word documents. It produces plain
-text output and can optionally convert non-standard characters into
-TeX control sequences. It works with MS Word 97 documents.
-
-There is also a cute little Tcl/Tk program included called wordview, which
-is basically a small GUI frontend to catdoc for viewing word documents.
-The wordview program works with Tcl 7.6 and up, but uses Tk 8.0 by default.
-
-There are two more utilities, xls2csv and xlsview, for dealing with
-MS Excel spreadsheets. xls2csv converts an Excel spreadsheet to a plain
-text file with CSV (comma-separated values) lines.
-
-WWW: http://www.45.free.net/~vitus/software/catdoc/
-
-- Brion
-brion@queeg.com
-
-- Steve
-steve@farrell.org
+This is a program for viewing RTF and MS Word 97 documents. It produces
+plain text output and can optionally convert some non-standard characters
+into TeX control sequences. It has rudimentary table handling in TeX
+mode. Also included are:
+- wordview, a small GUI frontend to catdoc that works with Tcl/Tk 7.6 and up;
+- xls2csv, which converts Excel spreadsheets to plain text files with CSV
+ (comma-separated value) lines; and
+- catppt, which extracts text from PowerPoint files.
+
+WWW: http://wagner.pp.ru/~vitus/software/catdoc/
diff --git a/textproc/catdoc/pkg-plist b/textproc/catdoc/pkg-plist
index 402064a1f1f2..f19e20b413ba 100644
--- a/textproc/catdoc/pkg-plist
+++ b/textproc/catdoc/pkg-plist
@@ -1,6 +1,6 @@
bin/catdoc
bin/catppt
-bin/wordview
+%%WORDVIEW%%bin/wordview
bin/xls2csv
%%DATADIR%%/8859-1.txt
%%DATADIR%%/8859-10.txt