aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/nmap/Makefile11
-rw-r--r--security/nmap/distinfo6
-rw-r--r--security/nmap/files/patch-configure46
-rw-r--r--security/nmap/pkg-plist4
4 files changed, 18 insertions, 49 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 2411cffc1e48..ecd858d6d725 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -17,11 +17,10 @@ DISTNAME= nmap-${DISTVERSION} # needed for security/nmapfe
MAINTAINER= daniel@roe.ch
COMMENT?= Port scanning utility for large networks
-DISTVERSION= 3.95
+DISTVERSION= 4.00
USE_BZIP2= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-localdirs
@@ -31,7 +30,6 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.ifndef BUILD_NMAPFE
MAN1= nmap.1
-MANLANG= "" pt.ISO8859-1 pt_BR.ISO8859-1
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
@@ -53,13 +51,6 @@ post-configure:
@${REINPLACE_CMD} -e "s|^DESTDIR *=|& ${DESTDIR}|" ${WRKSRC}/Makefile
post-install:
- @for lang in pt.ISO8859-1=pt-pt pt_BR.ISO8859-1=pt-br; do \
- llang="`expr $${lang} : '\([^=]*\)'`"; \
- elang="`expr $${lang} : '.*=\([^=]*\)'`"; \
- ${MKDIR} ${DESTDIR}${MAN1PREFIX}/man/$${llang}/man1; \
- ${INSTALL_MAN} ${WRKSRC}/docs/man-$${elang}.1 \
- ${DESTDIR}${MAN1PREFIX}/man/$${llang}/man1/nmap.1; \
- done
.ifndef NOPORTDOCS
@${MKDIR} ${DESTDIR}${DOCSDIR}
@for doc in CHANGELOG HACKING docs/nmap.dtd; do \
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index 48ce90f2f502..2db223864706 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1,3 +1,3 @@
-MD5 (nmap-3.95.tar.bz2) = a16e9d7f7912af7c93faa794bd63b6d1
-SHA256 (nmap-3.95.tar.bz2) = ec48a1d9ae7d34bbcab61f75527a36fe5869581336e201d2ca8e9c680d3d5d2f
-SIZE (nmap-3.95.tar.bz2) = 1923771
+MD5 (nmap-4.00.tar.bz2) = b409d632d753588f5691562209b83eed
+SHA256 (nmap-4.00.tar.bz2) = bbcf97aa6afff3ff4485d6e060853d1a29e68965d0e79a6ae6c0e4a2a9fe370f
+SIZE (nmap-4.00.tar.bz2) = 1896480
diff --git a/security/nmap/files/patch-configure b/security/nmap/files/patch-configure
index 6e3aff880cfd..d12d998de06b 100644
--- a/security/nmap/files/patch-configure
+++ b/security/nmap/files/patch-configure
@@ -1,41 +1,23 @@
---- configure.orig Mon Oct 6 13:03:26 2003
-+++ configure Mon Oct 6 13:03:38 2003
-@@ -2637,7 +2637,7 @@
- CXXFLAGS="$CXXFLAGS -Wall "
- fi
- # Extract the first word of ""$CXX"", so it can be a program name with args.
--set dummy "$CXX"; ac_word=$2
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -1395,7 +1395,7 @@
+ if test -z "$ac_cv_prog_CC"; then
+ ac_ct_CC=$CC
+ # Extract the first word of "gcc", so it can be a program name with args.
+-set dummy gcc; ac_word=$2
+set dummy $CXX; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_prog_CXXPROG+set}" = set; then
-@@ -2646,6 +2646,10 @@
- if test -n "$CXXPROG"; then
- ac_cv_prog_CXXPROG="$CXXPROG" # Let the user override the test.
- else
-+ case $ac_word in
-+ [\\/]* | ?:[\\/]* ) # absolute path given.
-+ ac_cv_prog_CXXPROG=$ac_word ;;
-+ *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
- for as_dir in $PATH
- do
-@@ -2658,7 +2662,8 @@
- break 2
- fi
- done
--done
-+done ;;
-+esac
-
- test -z "$ac_cv_prog_CXXPROG" && ac_cv_prog_CXXPROG=""MISSING""
- fi
-@@ -3505,7 +3510,7 @@
+ if test "${ac_cv_prog_ac_ct_CC+set}" = set; then
+@@ -3552,7 +3552,7 @@
--for ac_header in string.h getopt.h strings.h memory.h sys/param.h sys/sockio.h bstring.h sys/time.h pwd.h unistd.h
-+for ac_header in string.h strings.h memory.h sys/param.h sys/sockio.h bstring.h sys/time.h pwd.h unistd.h
+-for ac_header in string.h getopt.h strings.h memory.h sys/param.h sys/sockio.h bstring.h sys/time.h sys/stat.h fcntl.h termios.h pwd.h unistd.h
++for ac_header in string.h strings.h memory.h sys/param.h sys/sockio.h bstring.h sys/time.h sys/stat.h fcntl.h termios.h pwd.h unistd.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 1da8797a351f..c53f5d796ef3 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -12,7 +12,3 @@ bin/nmap
%%PORTDOCS%%%%DOCSDIR%%/HACKING
%%PORTDOCS%%%%DOCSDIR%%/nmap.dtd
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry man/pt.ISO8859-1/man1
-@dirrmtry man/pt_BR.ISO8859-1/man1
-@dirrmtry man/pt.ISO8859-1
-@dirrmtry man/pt_BR.ISO8859-1