aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/varnish/Makefile23
-rw-r--r--www/varnish/distinfo3
-rw-r--r--www/varnish/pkg-descr11
-rw-r--r--www/varnish/pkg-plist17
-rw-r--r--www/varnish2/Makefile23
-rw-r--r--www/varnish2/distinfo3
-rw-r--r--www/varnish2/pkg-descr11
-rw-r--r--www/varnish2/pkg-plist17
9 files changed, 109 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d7c997d7a45b..c0159ac973e1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1018,6 +1018,7 @@
SUBDIR += urchin5
SUBDIR += usermanager
SUBDIR += validator
+ SUBDIR += varnish
SUBDIR += visitors
SUBDIR += vtiger
SUBDIR += w3
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
new file mode 100644
index 000000000000..a482437e0c6a
--- /dev/null
+++ b/www/varnish/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: varnish
+# Date created: 2006-08-11
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= varnish
+PORTVERSION= 0.9.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= The Varnish high-performance HTTP accelerator
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LDCONFIG= yes
+
+MAN1= varnishd.1 varnishlog.1 varnishncsa.1 varnishstat.1
+
+.include <bsd.port.mk>
diff --git a/www/varnish/distinfo b/www/varnish/distinfo
new file mode 100644
index 000000000000..a3862912e557
--- /dev/null
+++ b/www/varnish/distinfo
@@ -0,0 +1,3 @@
+MD5 (varnish-0.9.1.tar.gz) = 3a1f4fcc469461d1fcf442c648791d0e
+SHA256 (varnish-0.9.1.tar.gz) = 4e91c122bed2fd646be3b25caf971ff91acbcd15ea25709303dacaed235b2f41
+SIZE (varnish-0.9.1.tar.gz) = 481494
diff --git a/www/varnish/pkg-descr b/www/varnish/pkg-descr
new file mode 100644
index 000000000000..79ba2a84aeb2
--- /dev/null
+++ b/www/varnish/pkg-descr
@@ -0,0 +1,11 @@
+This is an alpha release of the Varnish high-performance HTTP accelerator.
+
+The following Wiki page provides instructions for building and testing
+Varnish:
+
+ http://varnish.projects.linpro.no/wiki/AlphaReadme
+
+Please direct any technical questions to the Varnish development
+mailing list, <varnish-dev@projects.linpro.no>.
+
+WWW: http://varnish.linpro.no/
diff --git a/www/varnish/pkg-plist b/www/varnish/pkg-plist
new file mode 100644
index 000000000000..d0897f6d1c5c
--- /dev/null
+++ b/www/varnish/pkg-plist
@@ -0,0 +1,17 @@
+bin/varnishd
+bin/varnishlog
+bin/varnishncsa
+bin/varnishstat
+bin/varnishtop
+lib/libvarnish.so.0
+lib/libvarnish.so
+lib/libvarnish.la
+lib/libvarnish.a
+lib/libvarnishapi.so.0
+lib/libvarnishapi.so
+lib/libvarnishapi.la
+lib/libvarnishapi.a
+lib/libvcl.so.0
+lib/libvcl.so
+lib/libvcl.la
+lib/libvcl.a
diff --git a/www/varnish2/Makefile b/www/varnish2/Makefile
new file mode 100644
index 000000000000..a482437e0c6a
--- /dev/null
+++ b/www/varnish2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: varnish
+# Date created: 2006-08-11
+# Whom: des
+#
+# $FreeBSD$
+#
+
+PORTNAME= varnish
+PORTVERSION= 0.9.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= des@FreeBSD.org
+COMMENT= The Varnish high-performance HTTP accelerator
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LDCONFIG= yes
+
+MAN1= varnishd.1 varnishlog.1 varnishncsa.1 varnishstat.1
+
+.include <bsd.port.mk>
diff --git a/www/varnish2/distinfo b/www/varnish2/distinfo
new file mode 100644
index 000000000000..a3862912e557
--- /dev/null
+++ b/www/varnish2/distinfo
@@ -0,0 +1,3 @@
+MD5 (varnish-0.9.1.tar.gz) = 3a1f4fcc469461d1fcf442c648791d0e
+SHA256 (varnish-0.9.1.tar.gz) = 4e91c122bed2fd646be3b25caf971ff91acbcd15ea25709303dacaed235b2f41
+SIZE (varnish-0.9.1.tar.gz) = 481494
diff --git a/www/varnish2/pkg-descr b/www/varnish2/pkg-descr
new file mode 100644
index 000000000000..79ba2a84aeb2
--- /dev/null
+++ b/www/varnish2/pkg-descr
@@ -0,0 +1,11 @@
+This is an alpha release of the Varnish high-performance HTTP accelerator.
+
+The following Wiki page provides instructions for building and testing
+Varnish:
+
+ http://varnish.projects.linpro.no/wiki/AlphaReadme
+
+Please direct any technical questions to the Varnish development
+mailing list, <varnish-dev@projects.linpro.no>.
+
+WWW: http://varnish.linpro.no/
diff --git a/www/varnish2/pkg-plist b/www/varnish2/pkg-plist
new file mode 100644
index 000000000000..d0897f6d1c5c
--- /dev/null
+++ b/www/varnish2/pkg-plist
@@ -0,0 +1,17 @@
+bin/varnishd
+bin/varnishlog
+bin/varnishncsa
+bin/varnishstat
+bin/varnishtop
+lib/libvarnish.so.0
+lib/libvarnish.so
+lib/libvarnish.la
+lib/libvarnish.a
+lib/libvarnishapi.so.0
+lib/libvarnishapi.so
+lib/libvarnishapi.la
+lib/libvarnishapi.a
+lib/libvcl.so.0
+lib/libvcl.so
+lib/libvcl.la
+lib/libvcl.a