aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/yassl/Makefile23
-rw-r--r--security/yassl/distinfo4
-rw-r--r--security/yassl/pkg-plist89
3 files changed, 58 insertions, 58 deletions
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
index 97c85c0dd706..c4987c6fc77e 100644
--- a/security/yassl/Makefile
+++ b/security/yassl/Makefile
@@ -1,11 +1,11 @@
# $FreeBSD$
PORTNAME= cyassl
-PORTVERSION= 1.6.0
+PORTVERSION= 2.4.0
CATEGORIES= security devel
MASTER_SITES= http://www.yassl.com/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= A embedded SSL C-Library
LICENSE= GPLv2
@@ -13,12 +13,11 @@ LICENSE= GPLv2
USE_ZIP= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-dependency-tracking
-CONFIGURE_ARGS+= --enable-shared --enable-static
-CONFIGURE_ARGS+= --enable-dtls --enable-opensslExtra --enable-ipv6
-CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/${PORTNAME} --includedir=${PREFIX}/include/${PORTNAME}
-USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
-PORTDOCS= AUTHORS ChangeLog NEWS README
+CONFIGURE_ARGS= --disable-dependency-tracking \
+ --enable-shared --enable-static \
+ --enable-dtls --enable-opensslExtra --enable-ipv6
+USE_LDCONFIG= yes
+PORTDOCS= *
post-configure:
${REINPLACE_CMD} \
@@ -26,12 +25,4 @@ post-configure:
-e 's|$${prefix}/cyassl/lib|$${prefix}/lib/cyassl|' \
${WRKSRC}/Makefile
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/security/yassl/distinfo b/security/yassl/distinfo
index 37feaaa37fc9..9386996e6529 100644
--- a/security/yassl/distinfo
+++ b/security/yassl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cyassl-1.6.0.zip) = be8c8ecee415e90ca958672706ac9c5ece91d8f7c926c3d38cdae0ab2cb0fb2e
-SIZE (cyassl-1.6.0.zip) = 1591801
+SHA256 (cyassl-2.4.0.zip) = 5fcfccfac906d122e7d37b610d69a22e587e1a810670aa9eecc8f0cd02178d60
+SIZE (cyassl-2.4.0.zip) = 1027685
diff --git a/security/yassl/pkg-plist b/security/yassl/pkg-plist
index f576e7fc78b8..752007671a7a 100644
--- a/security/yassl/pkg-plist
+++ b/security/yassl/pkg-plist
@@ -1,34 +1,13 @@
-include/cyassl/aes.h
-include/cyassl/arc4.h
-include/cyassl/asn.h
-include/cyassl/coding.h
-include/cyassl/config.h
-include/cyassl/config.h.in
-include/cyassl/cyassl_error.h
-include/cyassl/cyassl_int.h
-include/cyassl/des3.h
-include/cyassl/dh.h
-include/cyassl/dsa.h
-include/cyassl/error.h
-include/cyassl/hc128.h
-include/cyassl/hmac.h
-include/cyassl/integer.h
-include/cyassl/md4.h
-include/cyassl/md5.h
-include/cyassl/misc.h
-include/cyassl/mpi_class.h
-include/cyassl/mpi_superclass.h
include/cyassl/openssl/asn1.h
include/cyassl/openssl/bio.h
include/cyassl/openssl/bn.h
include/cyassl/openssl/conf.h
include/cyassl/openssl/crypto.h
-include/cyassl/openssl/cyassl_callbacks.h
include/cyassl/openssl/des.h
include/cyassl/openssl/dh.h
include/cyassl/openssl/dsa.h
-include/cyassl/openssl/ec.h
include/cyassl/openssl/ecdsa.h
+include/cyassl/openssl/ec.h
include/cyassl/openssl/engine.h
include/cyassl/openssl/err.h
include/cyassl/openssl/evp.h
@@ -36,6 +15,7 @@ include/cyassl/openssl/hmac.h
include/cyassl/openssl/lhash.h
include/cyassl/openssl/md4.h
include/cyassl/openssl/md5.h
+include/cyassl/openssl/ripemd.h
include/cyassl/openssl/ocsp.h
include/cyassl/openssl/opensslconf.h
include/cyassl/openssl/opensslv.h
@@ -50,24 +30,53 @@ include/cyassl/openssl/stack.h
include/cyassl/openssl/ui.h
include/cyassl/openssl/x509.h
include/cyassl/openssl/x509v3.h
-include/cyassl/pwdbased.h
-include/cyassl/rabbit.h
-include/cyassl/random.h
-include/cyassl/ripemd.h
-include/cyassl/rsa.h
-include/cyassl/sha.h
-include/cyassl/sha256.h
-include/cyassl/sha512.h
-include/cyassl/sniffer.h
+include/cyassl/ctaocrypt/aes.h
+include/cyassl/ctaocrypt/arc4.h
+include/cyassl/ctaocrypt/asn.h
+include/cyassl/ctaocrypt/asn_public.h
+include/cyassl/ctaocrypt/coding.h
+include/cyassl/ctaocrypt/des3.h
+include/cyassl/ctaocrypt/dh.h
+include/cyassl/ctaocrypt/dsa.h
+include/cyassl/ctaocrypt/ecc.h
+include/cyassl/ctaocrypt/error.h
+include/cyassl/ctaocrypt/hc128.h
+include/cyassl/ctaocrypt/hmac.h
+include/cyassl/ctaocrypt/integer.h
+include/cyassl/ctaocrypt/md2.h
+include/cyassl/ctaocrypt/md4.h
+include/cyassl/ctaocrypt/md5.h
+include/cyassl/ctaocrypt/misc.h
+include/cyassl/ctaocrypt/pwdbased.h
+include/cyassl/ctaocrypt/rabbit.h
+include/cyassl/ctaocrypt/random.h
+include/cyassl/ctaocrypt/ripemd.h
+include/cyassl/ctaocrypt/rsa.h
+include/cyassl/ctaocrypt/settings.h
+include/cyassl/ctaocrypt/sha256.h
+include/cyassl/ctaocrypt/sha512.h
+include/cyassl/ctaocrypt/sha.h
+include/cyassl/ctaocrypt/tfm.h
+include/cyassl/ctaocrypt/types.h
+include/cyassl/ctaocrypt/visibility.h
+include/cyassl/ctaocrypt/logging.h
+include/cyassl/ctaocrypt/memory.h
+include/cyassl/ctaocrypt/mpi_class.h
+include/cyassl/ctaocrypt/mpi_superclass.h
+include/cyassl/error.h
+include/cyassl/internal.h
+include/cyassl/ssl.h
include/cyassl/sniffer_error.h
-include/cyassl/sniffer_error.rc
-include/cyassl/stamp-h1
-include/cyassl/tfm.h
-include/cyassl/types.h
-lib/cyassl/libcyassl.a
-lib/cyassl/libcyassl.la
-lib/cyassl/libcyassl.so
-lib/cyassl/libcyassl.so.0
-@dirrm lib/cyassl
+include/cyassl/sniffer.h
+include/cyassl/callbacks.h
+include/cyassl/test.h
+include/cyassl/version.h
+include/cyassl/ocsp.h
+include/cyassl/crl.h
+lib/libcyassl.a
+lib/libcyassl.la
+lib/libcyassl.so
+lib/libcyassl.so.3
@dirrm include/cyassl/openssl
+@dirrm include/cyassl/ctaocrypt
@dirrm include/cyassl