aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/tmux/Makefile24
-rw-r--r--misc/tmux/distinfo3
-rw-r--r--misc/tmux/pkg-descr5
-rw-r--r--sysutils/tmux/Makefile24
-rw-r--r--sysutils/tmux/distinfo3
-rw-r--r--sysutils/tmux/pkg-descr5
7 files changed, 65 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 3433040b6bbf..c0df9eef4188 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -463,6 +463,7 @@
SUBDIR += tkman
SUBDIR += tkregexp
SUBDIR += tkrunit
+ SUBDIR += tmux
SUBDIR += toilet
SUBDIR += tpp
SUBDIR += translate
diff --git a/misc/tmux/Makefile b/misc/tmux/Makefile
new file mode 100644
index 000000000000..51f4aa2db7e1
--- /dev/null
+++ b/misc/tmux/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: tmux
+# Date created: 28 May 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmux
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Terminal Multiplexer
+
+MAN1= tmux.1
+
+PLIST_FILES= bin/tmux
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tmux.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/tmux/distinfo b/misc/tmux/distinfo
new file mode 100644
index 000000000000..9ed60e038f42
--- /dev/null
+++ b/misc/tmux/distinfo
@@ -0,0 +1,3 @@
+MD5 (tmux-0.2.tar.gz) = 455a69bcebcd326a0c3736f9b1ef9ea3
+SHA256 (tmux-0.2.tar.gz) = 1866c83a9700636170e4d342d21f6b4c227a19ab1070702258c1ac9f9e1df4a3
+SIZE (tmux-0.2.tar.gz) = 76574
diff --git a/misc/tmux/pkg-descr b/misc/tmux/pkg-descr
new file mode 100644
index 000000000000..a97db267814f
--- /dev/null
+++ b/misc/tmux/pkg-descr
@@ -0,0 +1,5 @@
+Tmux is a terminal multiplexer, it enables a number of terminals to be accessed
+and controlled from a single terminal. tmux is intended to be a simple, modern,
+BSD-licensed alternative to programs such as GNU screen.
+
+WWW: http://tmux.sf.net/
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
new file mode 100644
index 000000000000..51f4aa2db7e1
--- /dev/null
+++ b/sysutils/tmux/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: tmux
+# Date created: 28 May 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tmux
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Terminal Multiplexer
+
+MAN1= tmux.1
+
+PLIST_FILES= bin/tmux
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tmux.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/tmux/distinfo b/sysutils/tmux/distinfo
new file mode 100644
index 000000000000..9ed60e038f42
--- /dev/null
+++ b/sysutils/tmux/distinfo
@@ -0,0 +1,3 @@
+MD5 (tmux-0.2.tar.gz) = 455a69bcebcd326a0c3736f9b1ef9ea3
+SHA256 (tmux-0.2.tar.gz) = 1866c83a9700636170e4d342d21f6b4c227a19ab1070702258c1ac9f9e1df4a3
+SIZE (tmux-0.2.tar.gz) = 76574
diff --git a/sysutils/tmux/pkg-descr b/sysutils/tmux/pkg-descr
new file mode 100644
index 000000000000..a97db267814f
--- /dev/null
+++ b/sysutils/tmux/pkg-descr
@@ -0,0 +1,5 @@
+Tmux is a terminal multiplexer, it enables a number of terminals to be accessed
+and controlled from a single terminal. tmux is intended to be a simple, modern,
+BSD-licensed alternative to programs such as GNU screen.
+
+WWW: http://tmux.sf.net/